summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNaveen Saini <naveen.kumar.saini@intel.com>2021-09-03 09:20:02 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2021-09-03 09:25:01 +0800
commit7cd64cc018d4eed644826076ec3eae3573f24e8f (patch)
tree9867170a012e68657c20d095183ef13d46209390
parenta6dadb2499dcb5127b8a411db10d2f9ae53fb4d1 (diff)
downloadmeta-intel-7cd64cc018d4eed644826076ec3eae3573f24e8f.tar.gz
opencl-clang: restructure
Restructured recipes, having common code in .inc Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang.inc24
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_10.0.0.bb28
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_11.0.0.bb26
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_12.0.0.bb25
4 files changed, 34 insertions, 69 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang.inc b/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang.inc
new file mode 100644
index 00000000..1d9b4d51
--- /dev/null
+++ b/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang.inc
@@ -0,0 +1,24 @@
1SUMMARY = "Common clang is a thin wrapper library around clang"
2DESCRIPTION = "Common clang has OpenCL-oriented API and is capable \
3 to compile OpenCL C kernels to SPIR-V modules."
4
5LICENSE = "NCSA"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=e8a15bf1416762a09ece07e44c79118c"
7
8SRC_URI = "git://github.com/intel/opencl-clang.git;branch=${BRANCH};protocol=https \
9 "
10S = "${WORKDIR}/git"
11
12inherit cmake
13DEPENDS += "clang"
14DEPENDS:append:class-target = " opencl-clang-native"
15
16COMPATIBLE_HOST = '(x86_64).*-linux'
17COMPATIBLE_HOST:libc-musl = "null"
18
19do_install:append:class-native() {
20 install -d ${D}${bindir}
21 install -m 0755 ${B}/linux_linker/linux_resource_linker ${D}${bindir}/
22}
23
24BBCLASSEXTEND = "native nativesdk"
diff --git a/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_10.0.0.bb b/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_10.0.0.bb
index c870b90b..e08f2278 100644
--- a/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_10.0.0.bb
+++ b/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_10.0.0.bb
@@ -1,35 +1,15 @@
1SUMMARY = "Common clang is a thin wrapper library around clang" 1require opencl-clang.inc
2DESCRIPTION = "Common clang has OpenCL-oriented API and is capable \
3 to compile OpenCL C kernels to SPIR-V modules."
4 2
5LICENSE = "NCSA" 3SRC_URI:append = " file://0001-don-t-redefine-LLVM_TABLEGEN_EXE.patch \
6LIC_FILES_CHKSUM = "file://LICENSE;md5=e8a15bf1416762a09ece07e44c79118c"
7
8SRC_URI = "git://github.com/intel/opencl-clang.git;branch=ocl-open-100;protocol=https \
9 file://0001-don-t-redefine-LLVM_TABLEGEN_EXE.patch \
10 file://0001-Building-in-tree-with-LLVM-10.0-with-the-LLVM_LINK_L.patch \ 4 file://0001-Building-in-tree-with-LLVM-10.0-with-the-LLVM_LINK_L.patch \
11 " 5 "
12SRC_URI:append:class-native = " file://0002-make-sure-only-static-libraries-linked-for-native-bu.patch" 6SRC_URI:append:class-native = " file://0002-make-sure-only-static-libraries-linked-for-native-bu.patch"
13 7
14SRCREV = "c8cd72e32b6abc18ce6da71c357ea45ba78b52f0" 8BRANCH = "ocl-open-100"
15
16S = "${WORKDIR}/git"
17
18inherit cmake
19DEPENDS += "clang"
20DEPENDS:append:class-target = " opencl-clang-native"
21 9
22COMPATIBLE_HOST = '(x86_64).*-linux' 10SRCREV = "c8cd72e32b6abc18ce6da71c357ea45ba78b52f0"
23COMPATIBLE_HOST:libc-musl = "null"
24 11
25EXTRA_OECMAKE += "\ 12EXTRA_OECMAKE += "\
26 -DLLVM_TABLEGEN_EXE=${STAGING_BINDIR_NATIVE}/llvm-tblgen \ 13 -DLLVM_TABLEGEN_EXE=${STAGING_BINDIR_NATIVE}/llvm-tblgen \
27 -DCMAKE_SKIP_RPATH=TRUE \ 14 -DCMAKE_SKIP_RPATH=TRUE \
28 " 15 "
29
30do_install:append:class-native() {
31 install -d ${D}${bindir}
32 install -m 0755 ${B}/linux_linker/linux_resource_linker ${D}${bindir}/
33}
34
35BBCLASSEXTEND = "native nativesdk"
diff --git a/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_11.0.0.bb b/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_11.0.0.bb
index e0b12d1f..60d5f0cc 100644
--- a/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_11.0.0.bb
+++ b/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_11.0.0.bb
@@ -1,35 +1,15 @@
1SUMMARY = "Common clang is a thin wrapper library around clang" 1require opencl-clang.inc
2DESCRIPTION = "Common clang has OpenCL-oriented API and is capable \
3 to compile OpenCL C kernels to SPIR-V modules."
4 2
5LICENSE = "NCSA" 3SRC_URI:append = " file://0001-don-t-redefine-LLVM_TABLEGEN_EXE.patch \
6LIC_FILES_CHKSUM = "file://LICENSE;md5=e8a15bf1416762a09ece07e44c79118c"
7
8SRC_URI = "git://github.com/intel/opencl-clang.git;branch=ocl-open-110;protocol=https \
9 file://0001-don-t-redefine-LLVM_TABLEGEN_EXE.patch \
10 " 4 "
11SRC_URI:append:class-native = " file://0002-make-sure-only-static-libraries-linked-for-native-bu.patch" 5SRC_URI:append:class-native = " file://0002-make-sure-only-static-libraries-linked-for-native-bu.patch"
12 6
13SRCREV = "c67648d41df00ea8ee9d701d17299b86f86f0321" 7SRCREV = "c67648d41df00ea8ee9d701d17299b86f86f0321"
14 8
15S = "${WORKDIR}/git" 9BRANCH = "ocl-open-110"
16
17inherit cmake
18DEPENDS += "clang"
19DEPENDS:append:class-target = " opencl-clang-native"
20
21COMPATIBLE_HOST = '(x86_64).*-linux'
22COMPATIBLE_HOST:libc-musl = "null"
23 10
24EXTRA_OECMAKE += "\ 11EXTRA_OECMAKE += "\
25 -DLLVM_TABLEGEN_EXE=${STAGING_BINDIR_NATIVE}/llvm-tblgen \ 12 -DLLVM_TABLEGEN_EXE=${STAGING_BINDIR_NATIVE}/llvm-tblgen \
26 -DCMAKE_SKIP_RPATH=TRUE \ 13 -DCMAKE_SKIP_RPATH=TRUE \
27 -DPREFERRED_LLVM_VERSION="11.1.0" \ 14 -DPREFERRED_LLVM_VERSION="11.1.0" \
28 " 15 "
29
30do_install:append:class-native() {
31 install -d ${D}${bindir}
32 install -m 0755 ${B}/linux_linker/linux_resource_linker ${D}${bindir}/
33}
34
35BBCLASSEXTEND = "native nativesdk"
diff --git a/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_12.0.0.bb b/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_12.0.0.bb
index 92befaf0..d0b2acfb 100644
--- a/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_12.0.0.bb
+++ b/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_12.0.0.bb
@@ -1,31 +1,12 @@
1SUMMARY = "Common clang is a thin wrapper library around clang" 1require opencl-clang.inc
2DESCRIPTION = "Common clang has OpenCL-oriented API and is capable \
3 to compile OpenCL C kernels to SPIR-V modules."
4 2
5LICENSE = "NCSA"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=e8a15bf1416762a09ece07e44c79118c"
7
8SRC_URI = "git://github.com/intel/opencl-clang.git;branch=ocl-open-120;protocol=https \
9 "
10SRCREV = "8fc6b059248dc6c9c40c7cbe5fedcc6ebb951983" 3SRCREV = "8fc6b059248dc6c9c40c7cbe5fedcc6ebb951983"
11 4
12S = "${WORKDIR}/git" 5DEPENDS += " spirv-llvm-translator"
13
14inherit cmake
15DEPENDS += " clang spirv-llvm-translator"
16DEPENDS:append:class-target = " opencl-clang-native"
17 6
18COMPATIBLE_HOST = '(x86_64).*-linux' 7BRANCH = "ocl-open-120"
19COMPATIBLE_HOST:libc-musl = "null"
20 8
21EXTRA_OECMAKE += "\ 9EXTRA_OECMAKE += "\
22 -DCMAKE_SKIP_RPATH=TRUE \ 10 -DCMAKE_SKIP_RPATH=TRUE \
23 -DPREFERRED_LLVM_VERSION="12.0.0" \ 11 -DPREFERRED_LLVM_VERSION="12.0.0" \
24 " 12 "
25
26do_install:append:class-native() {
27 install -d ${D}${bindir}
28 install -m 0755 ${B}/linux_linker/linux_resource_linker ${D}${bindir}/
29}
30
31BBCLASSEXTEND = "native nativesdk"