summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNaveen Saini <naveen.kumar.saini@intel.com>2021-12-21 16:46:14 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2021-12-21 16:57:59 +0800
commit0da0b5f8a9c2eef2f5c882dc26bf5532c1a7ddbf (patch)
tree0e89639ab0b97ebcdadeda0386e5a9b4757631aa
parent0cc95e338c27c0424ff036ab550c1ff22dd2727a (diff)
downloadmeta-intel-0da0b5f8a9c2eef2f5c882dc26bf5532c1a7ddbf.tar.gz
linux-intel/5.10: update to v5.10.78
Update kernel config as well. Backported patch to fix 32-bit compilation failure. 32-bit compilation failure log: build/tmp/work-shared/intel-core2-32/kernel-source/include/linux/io-mapping.h:88:16: error: implicit declaration of function '__iomap_local_pfn_prot'; did you mean '__kmap_local_pfn_prot'? [-Werror=implicit-function-declaration] | 88 | return __iomap_local_pfn_prot(PHYS_PFN(phys_addr), mapping->prot); | | ^~~~~~~~~~~~~~~~~~~~~~ | | __kmap_local_pfn_prot | build/tmp/work-shared/intel-core2-32/kernel-source/include/linux/io-mapping.h:88:16: warning: returning 'int' from a function with return type 'void *' makes pointer from integer without a cast [-Wint-conversion] | 88 | return __iomap_local_pfn_prot(PHYS_PFN(phys_addr), mapping->prot); | | ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
-rw-r--r--recipes-kernel/linux/linux-intel/0001-io-mapping-Cleanup-atomic-iomap.patch94
-rw-r--r--recipes-kernel/linux/linux-intel_5.10.bb7
2 files changed, 98 insertions, 3 deletions
diff --git a/recipes-kernel/linux/linux-intel/0001-io-mapping-Cleanup-atomic-iomap.patch b/recipes-kernel/linux/linux-intel/0001-io-mapping-Cleanup-atomic-iomap.patch
new file mode 100644
index 00000000..e3608238
--- /dev/null
+++ b/recipes-kernel/linux/linux-intel/0001-io-mapping-Cleanup-atomic-iomap.patch
@@ -0,0 +1,94 @@
1From cc3ff5fe73139251070775308dcaadf474566b4b Mon Sep 17 00:00:00 2001
2From: Thomas Gleixner <tglx@linutronix.de>
3Date: Tue, 3 Nov 2020 10:27:32 +0100
4Subject: [PATCH] io-mapping: Cleanup atomic iomap
5
6Switch the atomic iomap implementation over to kmap_local and stick the
7preempt/pagefault mechanics into the generic code similar to the
8kmap_atomic variants.
9
10Rename the x86 map function in preparation for a non-atomic variant.
11
12Upstream-Status: Backport [https://github.com/torvalds/linux/commit/351191ad55c8a1eccaf23e4187c62056229c0779]
13
14Signed-off-by: Thomas Gleixner <tglx@linutronix.de>
15Cc: Linus Torvalds <torvalds@linuxfoundation.org>
16Cc: Christoph Hellwig <hch@lst.de>
17Cc: Andrew Morton <akpm@linux-foundation.org>
18Link: https://lore.kernel.org/r/20201103095858.625310005@linutronix.de
19---
20 arch/x86/include/asm/iomap.h | 9 +--------
21 arch/x86/mm/iomap_32.c | 6 ++----
22 include/linux/io-mapping.h | 8 ++++++--
23 3 files changed, 9 insertions(+), 14 deletions(-)
24
25diff --git a/arch/x86/include/asm/iomap.h b/arch/x86/include/asm/iomap.h
26index 0be7a30fd6bc..e2de092fc38c 100644
27--- a/arch/x86/include/asm/iomap.h
28+++ b/arch/x86/include/asm/iomap.h
29@@ -13,14 +13,7 @@
30 #include <asm/cacheflush.h>
31 #include <asm/tlbflush.h>
32
33-void __iomem *iomap_atomic_pfn_prot(unsigned long pfn, pgprot_t prot);
34-
35-static inline void iounmap_atomic(void __iomem *vaddr)
36-{
37- kunmap_local_indexed((void __force *)vaddr);
38- pagefault_enable();
39- preempt_enable();
40-}
41+void __iomem *__iomap_local_pfn_prot(unsigned long pfn, pgprot_t prot);
42
43 int iomap_create_wc(resource_size_t base, unsigned long size, pgprot_t *prot);
44
45diff --git a/arch/x86/mm/iomap_32.c b/arch/x86/mm/iomap_32.c
46index e0a40d7cc66c..9aaa756ddf21 100644
47--- a/arch/x86/mm/iomap_32.c
48+++ b/arch/x86/mm/iomap_32.c
49@@ -44,7 +44,7 @@ void iomap_free(resource_size_t base, unsigned long size)
50 }
51 EXPORT_SYMBOL_GPL(iomap_free);
52
53-void __iomem *iomap_atomic_pfn_prot(unsigned long pfn, pgprot_t prot)
54+void __iomem *__iomap_local_pfn_prot(unsigned long pfn, pgprot_t prot)
55 {
56 /*
57 * For non-PAT systems, translate non-WB request to UC- just in
58@@ -60,8 +60,6 @@ void __iomem *iomap_atomic_pfn_prot(unsigned long pfn, pgprot_t prot)
59 /* Filter out unsupported __PAGE_KERNEL* bits: */
60 pgprot_val(prot) &= __default_kernel_pte_mask;
61
62- preempt_disable();
63- pagefault_disable();
64 return (void __force __iomem *)__kmap_local_pfn_prot(pfn, prot);
65 }
66-EXPORT_SYMBOL_GPL(iomap_atomic_pfn_prot);
67+EXPORT_SYMBOL_GPL(__iomap_local_pfn_prot);
68diff --git a/include/linux/io-mapping.h b/include/linux/io-mapping.h
69index 0a1a186a43c5..e9743cfd8585 100644
70--- a/include/linux/io-mapping.h
71+++ b/include/linux/io-mapping.h
72@@ -69,13 +69,17 @@ io_mapping_map_atomic_wc(struct io_mapping *mapping,
73
74 BUG_ON(offset >= mapping->size);
75 phys_addr = mapping->base + offset;
76- return iomap_atomic_pfn_prot(PHYS_PFN(phys_addr), mapping->prot);
77+ preempt_disable();
78+ pagefault_disable();
79+ return __iomap_local_pfn_prot(PHYS_PFN(phys_addr), mapping->prot);
80 }
81
82 static inline void
83 io_mapping_unmap_atomic(void __iomem *vaddr)
84 {
85- iounmap_atomic(vaddr);
86+ kunmap_local_indexed((void __force *)vaddr);
87+ pagefault_enable();
88+ preempt_enable();
89 }
90
91 static inline void __iomem *
92--
932.17.1
94
diff --git a/recipes-kernel/linux/linux-intel_5.10.bb b/recipes-kernel/linux/linux-intel_5.10.bb
index 90a95db2..9264c22a 100644
--- a/recipes-kernel/linux/linux-intel_5.10.bb
+++ b/recipes-kernel/linux/linux-intel_5.10.bb
@@ -6,13 +6,14 @@ KMETA_BRANCH = "yocto-5.10"
6LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46" 6LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
7 7
8SRC_URI:append = " file://0001-menuconfig-mconf-cfg-Allow-specification-of-ncurses-.patch \ 8SRC_URI:append = " file://0001-menuconfig-mconf-cfg-Allow-specification-of-ncurses-.patch \
9 file://0001-io-mapping-Cleanup-atomic-iomap.patch \
9 " 10 "
10 11
11DEPENDS += "elfutils-native openssl-native util-linux-native" 12DEPENDS += "elfutils-native openssl-native util-linux-native"
12 13
13LINUX_VERSION ?= "5.10.59" 14LINUX_VERSION ?= "5.10.78"
14SRCREV_machine ?= "9efba09f984bb30bd3ea01a811c500eb26356a15" 15SRCREV_machine ?= "4e8162d8163c74e46a9f0bafb860f42249702791"
15SRCREV_meta ?= "f8afd84b117f336477846b9e22178ebefb26c08d" 16SRCREV_meta ?= "64fb693a6c11f21bab3ff9bb8dcb65a70abe05e3"
16 17
17# For Crystalforest and Romley 18# For Crystalforest and Romley
18KERNEL_MODULE_AUTOLOAD:append:core2-32-intel-common = " uio" 19KERNEL_MODULE_AUTOLOAD:append:core2-32-intel-common = " uio"