summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2021-04-20 15:24:18 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2021-04-22 14:42:29 +0800
commit9766d5c4e2ff5877195e161e81c7708bbf0697ee (patch)
treefe6ba65cc39a44f640ef20711145444845f16d7f
parent7113b578c6a9074627faad5198bcfc79e76cb303 (diff)
downloadmeta-intel-9766d5c4e2ff5877195e161e81c7708bbf0697ee.tar.gz
open-model-zoo: upgrade 2021.2 -> 2021.3
Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo/0001-use-oe-gflags.patch22
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo_2021.3.bb (renamed from dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo_2021.2.bb)15
2 files changed, 20 insertions, 17 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo/0001-use-oe-gflags.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo/0001-use-oe-gflags.patch
index 864c735e..f38e0669 100644
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo/0001-use-oe-gflags.patch
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo/0001-use-oe-gflags.patch
@@ -1,4 +1,4 @@
1From 56078933a8397b7fae146156743408319eac1ae0 Mon Sep 17 00:00:00 2001 1From 6a0046c523a67b4d21d856ea73861c00b5a9c9fd Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com> 2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Mon, 19 Oct 2020 23:29:23 +0800 3Date: Mon, 19 Oct 2020 23:29:23 +0800
4Subject: [PATCH] demos: use gflags from meta-oe 4Subject: [PATCH] demos: use gflags from meta-oe
@@ -11,23 +11,23 @@ Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
11 1 file changed, 2 insertions(+), 2 deletions(-) 11 1 file changed, 2 insertions(+), 2 deletions(-)
12 12
13diff --git a/demos/CMakeLists.txt b/demos/CMakeLists.txt 13diff --git a/demos/CMakeLists.txt b/demos/CMakeLists.txt
14index e5f17231..08d4e4e6 100644 14index c5e3b1ec3..4e78c72a6 100644
15--- a/demos/CMakeLists.txt 15--- a/demos/CMakeLists.txt
16+++ b/demos/CMakeLists.txt 16+++ b/demos/CMakeLists.txt
17@@ -90,11 +90,11 @@ if (${CMAKE_CXX_COMPILER_ID} STREQUAL GNU) 17@@ -62,11 +62,11 @@ set(CMAKE_CXX_STANDARD 11)
18 endif() 18 set(CMAKE_CXX_STANDARD_REQUIRED ON)
19 #################################### 19 ####################################
20 20
21-set (GFLAGS_IS_SUBPROJECT TRUE) 21-set(GFLAGS_IS_SUBPROJECT TRUE)
22+set (GFLAGS_IS_SUBPROJECT FALSE) 22+set(GFLAGS_IS_SUBPROJECT FALSE)
23 set (HAVE_SYS_STAT_H 1) 23 set(HAVE_SYS_STAT_H 1)
24 set (HAVE_INTTYPES_H 1) 24 set(HAVE_INTTYPES_H 1)
25 25
26-add_subdirectory(thirdparty/gflags) 26-add_subdirectory(thirdparty/gflags)
27+#add_subdirectory(thirdparty/gflags) 27+#add_subdirectory(thirdparty/gflags)
28 28
29 if (${CMAKE_CXX_COMPILER_ID} STREQUAL GNU) 29 if(CMAKE_CXX_COMPILER_ID MATCHES "^GNU|(Apple)?Clang$")
30 set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall") 30 set(COMPILER_IS_GCC_LIKE TRUE)
31-- 31--
322.26.2 322.29.0
33 33
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo_2021.2.bb b/dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo_2021.3.bb
index 6784d0d8..700f78c2 100644
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo_2021.2.bb
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo_2021.3.bb
@@ -5,18 +5,19 @@ models and a set of demos to expedite development of high-performance \
5deep learning inference applications." 5deep learning inference applications."
6 6
7SRC_URI = "git://github.com/opencv/open_model_zoo.git;protocol=git;branch=master \ 7SRC_URI = "git://github.com/opencv/open_model_zoo.git;protocol=git;branch=master \
8 file://0001-use-oe-gflags.patch;striplevel=2 \ 8 file://0001-use-oe-gflags.patch \
9 " 9 "
10 10
11SRCREV = "338630987b403a6981d03ab6d04c2d5ad367793a" 11SRCREV = "9ca5dbeff80464bf5728e8be25daedfe9a9208d7"
12 12
13LICENSE = "Apache-2.0" 13LICENSE = "Apache-2.0"
14LIC_FILES_CHKSUM = "file://../LICENSE;md5=86d3f3a95c324c9479bd8986968f4327 \ 14LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327 \
15" 15"
16 16
17inherit cmake 17inherit cmake
18 18
19S = "${WORKDIR}/git/demos" 19S = "${WORKDIR}/git"
20OECMAKE_SOURCEPATH = "${S}/demos"
20 21
21DEPENDS += "openvino-inference-engine opencv gflags" 22DEPENDS += "openvino-inference-engine opencv gflags"
22 23
@@ -28,6 +29,8 @@ RDEPENDS_${PN} += " \
28 python3-test-generator \ 29 python3-test-generator \
29 python3-requests \ 30 python3-requests \
30 python3-pyyaml \ 31 python3-pyyaml \
32 python3-numpy \
33 bash \
31" 34"
32 35
33COMPATIBLE_HOST = '(x86_64).*-linux' 36COMPATIBLE_HOST = '(x86_64).*-linux'
@@ -52,12 +55,12 @@ do_install(){
52 install -d ${D}${libdir} 55 install -d ${D}${libdir}
53 install -d ${D}${bindir} 56 install -d ${D}${bindir}
54 install -d ${D}${datadir}/openvino/open-model-zoo/tools 57 install -d ${D}${datadir}/openvino/open-model-zoo/tools
55 install -d ${D}${datadir}/openvino/open-model-zoo/demos/python_demos 58 install -d ${D}${datadir}/openvino/open-model-zoo/demos
56 cp -rf ${WORKDIR}/build/intel64/Release/lib/*.a ${D}${libdir} 59 cp -rf ${WORKDIR}/build/intel64/Release/lib/*.a ${D}${libdir}
57 cp -rf ${WORKDIR}/build/intel64/Release/*_demo* ${D}${bindir} 60 cp -rf ${WORKDIR}/build/intel64/Release/*_demo* ${D}${bindir}
58 cp -rf ${WORKDIR}/git/models ${D}${datadir}/openvino/open-model-zoo 61 cp -rf ${WORKDIR}/git/models ${D}${datadir}/openvino/open-model-zoo
62 cp -rf ${WORKDIR}/git/demos ${D}${datadir}/openvino/open-model-zoo
59 cp -rf ${WORKDIR}/git/tools/downloader ${D}${datadir}/openvino/open-model-zoo/tools 63 cp -rf ${WORKDIR}/git/tools/downloader ${D}${datadir}/openvino/open-model-zoo/tools
60 cp -rf ${WORKDIR}/git/demos/python_demos ${D}${datadir}/openvino/open-model-zoo/demos
61} 64}
62 65
63FILES_${PN} += "${datadir}/openvino" 66FILES_${PN} += "${datadir}/openvino"