summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2020-10-28 12:27:38 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2020-10-28 12:33:08 +0800
commit9d3400dd7e4483abb84d068dc8480a34ffc2d75a (patch)
treee95e667a18624dea49f9336fc02eb03a40acc894
parentbc6663d2caa748527a296424a2049f9e4b456dd4 (diff)
downloadmeta-intel-9d3400dd7e4483abb84d068dc8480a34ffc2d75a.tar.gz
lms: add PACKAGECONFIG to select network manager
Allow users to select either ConnMan or Network Manager. Also fixes an issue introduced because of a recent change in 2022.0.0.0 that removed the build time check in favor of explicit options to select the right network manager [1]. [1] https://github.com/intel/lms/commit/1b8fa452644bdedcdd80d3c8741f73ef8191d439 Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
-rw-r--r--dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_2022.0.0.0.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_2022.0.0.0.bb b/dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_2022.0.0.0.bb
index 4b1e35f0..63bc7b6a 100644
--- a/dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_2022.0.0.0.bb
+++ b/dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_2022.0.0.0.bb
@@ -12,10 +12,15 @@ COMPATIBLE_HOST_libc-musl = "null"
12 12
13inherit cmake systemd features_check 13inherit cmake systemd features_check
14 14
15DEPENDS = "metee ace xerces-c libnl libxml2 glib-2.0 glib-2.0-native connman" 15DEPENDS = "metee ace xerces-c libnl libxml2 glib-2.0 glib-2.0-native"
16 16
17EXTRA_OECMAKE += "-DPYTHON_EXECUTABLE=${HOSTTOOLS_DIR}/python3" 17EXTRA_OECMAKE += "-DPYTHON_EXECUTABLE=${HOSTTOOLS_DIR}/python3"
18 18
19# Enable either connman or networkmanager or none but not both.
20PACKAGECONFIG ??= "connman"
21PACKAGECONFIG[connman] = "-DNETWORK_CN=ON, -DNETWORK_CN=OFF, connman"
22PACKAGECONFIG[networkmanager] = "-DNETWORK_NM=ON, -DNETWORK_NM=OFF, networkmanager"
23
19REQUIRED_DISTRO_FEATURES= "systemd" 24REQUIRED_DISTRO_FEATURES= "systemd"
20 25
21FILES_${PN} += "${datadir}/dbus-1/system-services/*.service" 26FILES_${PN} += "${datadir}/dbus-1/system-services/*.service"