summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNaveen Saini <naveen.kumar.saini@intel.com>2020-11-04 09:27:53 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2020-11-21 07:48:12 +0800
commit8699f7009ed3d9fbc652270cb737cfa7f3898cd4 (patch)
treef6ee3bc4514fd3e5248e6c9058838a634c0cf00c
parent8089e92d77bc11051463580eb0b0687e768bc8d2 (diff)
downloadmeta-intel-8699f7009ed3d9fbc652270cb737cfa7f3898cd4.tar.gz
intel-graphics-compiler: disable vector compiler option
IGC has a copy of legacy spirv translator and additional patcheset to produce spirv shared object (libSPIRVDLL.so) to support Vector compiler. But we build spirv externally and link, which does not provide spirv shared object (libSPIRVDLL.so). Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.5176.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.5176.bb b/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.5176.bb
index d55e2c61..b4067ed0 100644
--- a/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.5176.bb
+++ b/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.5176.bb
@@ -32,7 +32,7 @@ DEPENDS_append_class-target = " clang-cross-x86_64"
32RDEPENDS_${PN} += "opencl-clang" 32RDEPENDS_${PN} += "opencl-clang"
33 33
34LLVM_COMPAT_VERSION = "${@bb.utils.contains('LLVMVERSION', '10.0.1', '10.0.0', '11.0.0', d)}" 34LLVM_COMPAT_VERSION = "${@bb.utils.contains('LLVMVERSION', '10.0.1', '10.0.0', '11.0.0', d)}"
35EXTRA_OECMAKE = "-DIGC_PREFERRED_LLVM_VERSION=${LLVM_COMPAT_VERSION} -DPYTHON_EXECUTABLE=${HOSTTOOLS_DIR}/python3 -DINSTALL_SPIRVDLL=0" 35EXTRA_OECMAKE = "-DIGC_PREFERRED_LLVM_VERSION=${LLVM_COMPAT_VERSION} -DPYTHON_EXECUTABLE=${HOSTTOOLS_DIR}/python3 -DINSTALL_SPIRVDLL=0 -DIGC_BUILD__VC_ENABLED=OFF"
36 36
37# VectorCompiler doesn't build with LLVM11 as of this release. 37# VectorCompiler doesn't build with LLVM11 as of this release.
38# Re-enable after those issues have been fixed. 38# Re-enable after those issues have been fixed.