summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2021-01-21 10:34:23 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2021-01-21 10:31:41 +0800
commit7a21b1adf3f23b019633b058cd9e3c2eccd2ba00 (patch)
tree2cf783d9f41bff4a816cf89dbd971ae7bb76aca7
parentc7ddf7bb8973503dc94293c3c25522d3c68fccc3 (diff)
downloadmeta-intel-7a21b1adf3f23b019633b058cd9e3c2eccd2ba00.tar.gz
linux-intel-rt/5.10: add recipe
Based on v5.10.1-rt20. Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
-rw-r--r--recipes-kernel/linux/linux-intel-rt_5.10.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-intel-rt_5.10.bb b/recipes-kernel/linux/linux-intel-rt_5.10.bb
new file mode 100644
index 00000000..d3ee342c
--- /dev/null
+++ b/recipes-kernel/linux/linux-intel-rt_5.10.bb
@@ -0,0 +1,25 @@
1require linux-intel.inc
2
3# Skip processing of this recipe if it is not explicitly specified as the
4# PREFERRED_PROVIDER for virtual/kernel. This avoids errors when trying
5# to build multiple virtual/kernel providers, e.g. as dependency of
6# core-image-rt-sdk, core-image-rt.
7python () {
8 if d.getVar("KERNEL_PACKAGE_NAME", True) == "kernel" and d.getVar("PREFERRED_PROVIDER_virtual/kernel") != "linux-intel-rt":
9 raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-intel-rt to enable it")
10}
11
12LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
13SRC_URI_append = " file://0001-menuconfig-mconf-cfg-Allow-specification-of-ncurses-.patch \
14"
15
16KBRANCH = "5.10/preempt-rt"
17KMETA_BRANCH = "yocto-5.10"
18
19DEPENDS += "elfutils-native openssl-native util-linux-native"
20
21LINUX_VERSION ?= "5.10.1"
22SRCREV_machine ?= "7cc9ab35ca5c12de2484deeb2ffe0ebc063e409a"
23SRCREV_meta ?= "30c21625f9989859ade341ebe738664f3efbf122"
24
25LINUX_KERNEL_TYPE = "preempt-rt"