summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2020-11-20 23:16:50 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2020-11-21 07:48:12 +0800
commit3d202236fc57db510fa637c01a1ccca7083fcd66 (patch)
tree2f102592b5fbd4ca84e7b8813c77016b070de813
parent57a90f3d293c5948e4aff43a340befb617412f6e (diff)
downloadmeta-intel-3d202236fc57db510fa637c01a1ccca7083fcd66.tar.gz
intel-compute-runtime: upgrade 20.40.18075 -> 20.40.18403
Release notes: https://github.com/intel/compute-runtime/releases/tag/20.45.18403 Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/allow-to-find-cpp-generation-tool.patch14
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_20.40.18403.bb (renamed from dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_20.40.18075.bb)2
2 files changed, 8 insertions, 8 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/allow-to-find-cpp-generation-tool.patch b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/allow-to-find-cpp-generation-tool.patch
index 881359c8..631e0ce6 100644
--- a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/allow-to-find-cpp-generation-tool.patch
+++ b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/allow-to-find-cpp-generation-tool.patch
@@ -1,4 +1,4 @@
1From bde2a2b58d7f7b3063406db600e5b988fbcf01aa Mon Sep 17 00:00:00 2001 1From 32851d269ac0c027730168c04d9ce32d0eb50905 Mon Sep 17 00:00:00 2001
2From: Naveen Saini <naveen.kumar.saini@intel.com> 2From: Naveen Saini <naveen.kumar.saini@intel.com>
3Date: Wed, 27 May 2020 11:12:09 +0000 3Date: Wed, 27 May 2020 11:12:09 +0000
4Subject: [PATCH] intel-compute-runtime: allow to find cpp_generation_tool 4Subject: [PATCH] intel-compute-runtime: allow to find cpp_generation_tool
@@ -12,22 +12,22 @@ Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com>
12 1 file changed, 4 insertions(+), 4 deletions(-) 12 1 file changed, 4 insertions(+), 4 deletions(-)
13 13
14diff --git a/shared/source/built_ins/kernels/CMakeLists.txt b/shared/source/built_ins/kernels/CMakeLists.txt 14diff --git a/shared/source/built_ins/kernels/CMakeLists.txt b/shared/source/built_ins/kernels/CMakeLists.txt
15index 84935be2d..150c450d7 100644 15index 1b1225077..2e8148c25 100644
16--- a/shared/source/built_ins/kernels/CMakeLists.txt 16--- a/shared/source/built_ins/kernels/CMakeLists.txt
17+++ b/shared/source/built_ins/kernels/CMakeLists.txt 17+++ b/shared/source/built_ins/kernels/CMakeLists.txt
18@@ -84,9 +84,9 @@ function(compile_builtin gen_type platform_type builtin bits builtin_options) 18@@ -93,9 +93,9 @@ function(compile_builtin gen_type platform_type builtin bits builtin_options mod
19 ) 19 )
20 add_custom_command( 20 add_custom_command(
21 OUTPUT ${OUTPUT_FILE_CPP} 21 OUTPUT ${OUTPUT_FILE_CPP}
22- COMMAND $<TARGET_FILE:cpp_generate_tool> --file ${OUTPUTPATH_BASE}.gen --output ${OUTPUT_FILE_CPP} --array ${BASENAME} --platform ${family_name_with_type} 22- COMMAND $<TARGET_FILE:cpp_generate_tool> --file ${OUTPUTPATH_BASE}.gen --output ${OUTPUT_FILE_CPP} --array ${mode}_${BASENAME} --platform ${family_name_with_type}
23+ COMMAND cpp_generate_tool --file ${OUTPUTPATH_BASE}.gen --output ${OUTPUT_FILE_CPP} --array ${BASENAME} --platform ${family_name_with_type} 23+ COMMAND cpp_generate_tool --file ${OUTPUTPATH_BASE}.gen --output ${OUTPUT_FILE_CPP} --array ${mode}_${BASENAME} --platform ${family_name_with_type}
24 WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR} 24 WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
25- DEPENDS ${OUTPUTPATH_BASE}.gen $<TARGET_FILE:cpp_generate_tool> 25- DEPENDS ${OUTPUTPATH_BASE}.gen $<TARGET_FILE:cpp_generate_tool>
26+ DEPENDS ${OUTPUTPATH_BASE}.gen cpp_generate_tool 26+ DEPENDS ${OUTPUTPATH_BASE}.gen cpp_generate_tool
27 ) 27 )
28 endfunction() 28 endfunction()
29 29
30@@ -127,9 +127,9 @@ function(generate_cpp_spirv builtin) 30@@ -136,9 +136,9 @@ function(generate_cpp_spirv builtin)
31 ) 31 )
32 add_custom_command( 32 add_custom_command(
33 OUTPUT ${OUTPUT_FILE_CPP} 33 OUTPUT ${OUTPUT_FILE_CPP}
@@ -40,5 +40,5 @@ index 84935be2d..150c450d7 100644
40 endfunction() 40 endfunction()
41 41
42-- 42--
432.26.2 432.28.0
44 44
diff --git a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_20.40.18075.bb b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_20.40.18403.bb
index bc096833..1cefa1a8 100644
--- a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_20.40.18075.bb
+++ b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_20.40.18403.bb
@@ -12,7 +12,7 @@ SRC_URI = "git://github.com/intel/compute-runtime.git;protocol=https \
12 " 12 "
13SRC_URI_append_class-target = " file://allow-to-find-cpp-generation-tool.patch" 13SRC_URI_append_class-target = " file://allow-to-find-cpp-generation-tool.patch"
14 14
15SRCREV = "7e31ec37d78693c08a1fcb2ec31801e64cb497d3" 15SRCREV = "152f89f2f2b38efe3d3c0423b76d65a8f63916be"
16 16
17S = "${WORKDIR}/git" 17S = "${WORKDIR}/git"
18 18