summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnuj Mittal <anujx.mittal@intel.com>2015-07-28 16:05:11 +0800
committerDarren Hart <dvhart@linux.intel.com>2015-07-29 13:06:55 -0700
commit903c1a61639692b068d5202c410d4eebc338dcb8 (patch)
treecac47dfe4d822cf7067cab67cc26040f34009726
parentcdec96764e4640ceddb493d3022004b7f0aa3621 (diff)
downloadmeta-intel-903c1a61639692b068d5202c410d4eebc338dcb8.tar.gz
meta-isg: fix build of dpdk_qat example app
Make sure that the dpdk_qat example app builds okay when enabled using PACKAGECONFIG ?= " dpdk_qat". Added a patch to dpdk_qat makefile to point to correct location of qat libs and headers. Signed-off-by: Anuj Mittal <anujx.mittal@intel.com> Signed-off-by: Darren Hart <dvhart@linux.intel.com> (cherry picked from commit 76526b2b28b4e840e9a8b83840433de53e7f0e59) Signed-off-by: Darren Hart <dvhart@linux.intel.com>
-rw-r--r--meta-isg/common/recipes-extended/dpdk/dpdk.inc2
-rw-r--r--meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-1.8.0-and-2.0.0-point-to-the-right-include-and-lib-path.patch43
2 files changed, 45 insertions, 0 deletions
diff --git a/meta-isg/common/recipes-extended/dpdk/dpdk.inc b/meta-isg/common/recipes-extended/dpdk/dpdk.inc
index 3106959e..4b1a0c6e 100644
--- a/meta-isg/common/recipes-extended/dpdk/dpdk.inc
+++ b/meta-isg/common/recipes-extended/dpdk/dpdk.inc
@@ -7,6 +7,7 @@ SRC_URI = "http://dpdk.org/browse/dpdk/snapshot/dpdk-${PV}.tar.gz;name=dpdk \
7 file://dpdk-1.8.0-and-2.0.0-examples-add-config-variable-to-enable-disable-dpdk.patch \ 7 file://dpdk-1.8.0-and-2.0.0-examples-add-config-variable-to-enable-disable-dpdk.patch \
8 file://dpdk-1.8.0-and-2.0.0-add-RTE_KERNELDIR_OUT-to-split-kernel-bu.patch \ 8 file://dpdk-1.8.0-and-2.0.0-add-RTE_KERNELDIR_OUT-to-split-kernel-bu.patch \
9 file://dpdk-1.8.0-and-2.0.0-add-sysroot-option-within-app-makefile.patch \ 9 file://dpdk-1.8.0-and-2.0.0-add-sysroot-option-within-app-makefile.patch \
10 file://dpdk-1.8.0-and-2.0.0-point-to-the-right-include-and-lib-path.patch \
10 " 11 "
11 12
12# dpdk example apps dpdk_qat and vhost have dependancy on fuse and qat. 13# dpdk example apps dpdk_qat and vhost have dependancy on fuse and qat.
@@ -40,6 +41,7 @@ export RTE_KERNELDIR_OUT = "${STAGING_KERNEL_BUILDDIR}"
40export INSTALL_PATH = "${prefix}/dpdk" 41export INSTALL_PATH = "${prefix}/dpdk"
41export SYSROOTPATH = "--sysroot=${STAGING_DIR_HOST}" 42export SYSROOTPATH = "--sysroot=${STAGING_DIR_HOST}"
42export DPDK_TARGET_MACH = "${@get_dpdk_target_mach(bb,d)}" 43export DPDK_TARGET_MACH = "${@get_dpdk_target_mach(bb,d)}"
44export ICP_LAC_API_DIR = "${STAGING_DIR_TARGET}${includedir}/lac"
43 45
44# The list of intel Comms platforms and their target machine 46# The list of intel Comms platforms and their target machine
45# process mapping. The supported target machine is listed under 47# process mapping. The supported target machine is listed under
diff --git a/meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-1.8.0-and-2.0.0-point-to-the-right-include-and-lib-path.patch b/meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-1.8.0-and-2.0.0-point-to-the-right-include-and-lib-path.patch
new file mode 100644
index 00000000..75bb517d
--- /dev/null
+++ b/meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-1.8.0-and-2.0.0-point-to-the-right-include-and-lib-path.patch
@@ -0,0 +1,43 @@
1From 928595c80ae28d19861d7e76ed898a8fb3f2c1dc Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anujx.mittal@intel.com>
3Date: Fri, 24 Jul 2015 23:57:17 +0800
4Subject: [PATCH] dpdk: point to the right include and lib path
5
6Upstream-Status: Inappropriate [Configuration]
7
8Make sure that we point to the right location of qat
9lac headers and library.
10
11Signed-off-by: Anuj Mittal <anujx.mittal@intel.com>
12---
13 examples/dpdk_qat/Makefile | 7 ++-----
14 1 file changed, 2 insertions(+), 5 deletions(-)
15
16diff --git a/examples/dpdk_qat/Makefile b/examples/dpdk_qat/Makefile
17index f1e06a1..5b906f7 100644
18--- a/examples/dpdk_qat/Makefile
19+++ b/examples/dpdk_qat/Makefile
20@@ -66,18 +66,15 @@ SRCS-y := main.c crypto.c
21
22 CFLAGS += -O3
23 CFLAGS += $(WERROR_FLAGS)
24-CFLAGS += -I$(ICP_ROOT)/quickassist/include \
25- -I$(ICP_ROOT)/quickassist/include/lac \
26- -I$(ICP_ROOT)/quickassist/lookaside/access_layer/include
27+CFLAGS += -I$(ICP_LAC_API_DIR)
28
29 # From CRF 1.2 driver, library was renamed to libicp_qa_al.a
30 ifneq ($(wildcard $(ICP_ROOT)/build/icp_qa_al.a),)
31 ICP_LIBRARY_PATH = $(ICP_ROOT)/build/icp_qa_al.a
32 else
33-ICP_LIBRARY_PATH = $(ICP_ROOT)/build/libicp_qa_al.a
34+ICP_LIBRARY_PATH = $(ICP_LIB_ROOT)/libicp_qa_al.a
35 endif
36
37-LDLIBS += -L$(ICP_ROOT)/build
38 LDLIBS += $(ICP_LIBRARY_PATH) \
39 -lz \
40 -losal \
41--
421.7.9.5
43