summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOng Boon Leong <boon.leong.ong@intel.com>2015-07-10 21:23:46 +0800
committerSaul Wold <sgw@linux.intel.com>2015-07-10 13:52:28 -0700
commit54d7c147bb83da874c92fdf938233b59ccba0cdb (patch)
treec71894509416de273b1ee5d28205e6d915ec9d0e
parent3bbcb7aa8cb6e3bbb48eab9e3a969c379b01cb48 (diff)
downloadmeta-intel-54d7c147bb83da874c92fdf938233b59ccba0cdb.tar.gz
meta-isg: dpdk v1.8: add app makefile patch to enable sysroot setting
DPDK v1.8.0 app Makefile does not support "--sysroot=<path>" option in LDFLAGS because of Makefile internal logic that always add -Wl, before. This causes poky GNU linker search path issue for target machine sysroot usr/lib. Signed-off-by: Ong Boon Leong <boon.leong.ong@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
-rw-r--r--meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-1.8.0-add-sysroot-option-within-app-makefile.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-1.8.0-add-sysroot-option-within-app-makefile.patch b/meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-1.8.0-add-sysroot-option-within-app-makefile.patch
new file mode 100644
index 00000000..02c7dc3c
--- /dev/null
+++ b/meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-1.8.0-add-sysroot-option-within-app-makefile.patch
@@ -0,0 +1,33 @@
1From 3112250f6452215890fc7db73c8127e111af956f Mon Sep 17 00:00:00 2001
2From: Ong Boon Leong <boon.leong.ong@intel.com>
3Date: Thu, 2 Jul 2015 23:51:01 +0800
4Subject: [PATCH] dpdk v1.8.0: add --sysroot option within app makefile
5
6Upstream-Status: Inappropriate [configuration]
7
8in DPDK v1.8.0, rte.app.mk has been changed to add -Wl, to
9all items listed under EXTRA_LDFLAGS. It causes --sysroot=
10<path> to not setup correctly when we depends on gcc to setup
11for GNU ld.
12
13Signed-off-by: Ong Boon Leong <boon.leong.ong@intel.com>
14---
15 mk/rte.app.mk | 2 +-
16 1 file changed, 1 insertion(+), 1 deletion(-)
17
18diff --git a/mk/rte.app.mk b/mk/rte.app.mk
19index e1a0dbf..9528588 100644
20--- a/mk/rte.app.mk
21+++ b/mk/rte.app.mk
22@@ -259,7 +259,7 @@ ifeq ($(LINK_USING_CC),1)
23 override EXTRA_LDFLAGS := $(call linkerprefix,$(EXTRA_LDFLAGS))
24 O_TO_EXE = $(CC) $(CFLAGS) $(LDFLAGS_$(@)) \
25 -Wl,-Map=$(@).map,--cref -o $@ $(OBJS-y) $(call linkerprefix,$(LDFLAGS)) \
26- $(EXTRA_LDFLAGS) $(call linkerprefix,$(LDLIBS))
27+ $(EXTRA_LDFLAGS) $(SYSROOTPATH) $(call linkerprefix,$(LDLIBS))
28 else
29 O_TO_EXE = $(LD) $(LDFLAGS) $(LDFLAGS_$(@)) $(EXTRA_LDFLAGS) \
30 -Map=$(@).map --cref -o $@ $(OBJS-y) $(LDLIBS)
31--
321.7.9.5
33