summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRahul Saxena <rahul.saxena@intel.com>2012-03-19 18:15:15 -0700
committerTom Zanussi <tom.zanussi@intel.com>2012-03-26 17:41:47 -0500
commitf4602df2ce6caa6676a3c27cfae73eedc6296e1d (patch)
tree14b064c3555de0801382f012f71cf6cf3286b2f5
parente402b37fbe35ab3479325b835b3c8bd6e7ac5083 (diff)
downloadmeta-intel-f4602df2ce6caa6676a3c27cfae73eedc6296e1d.tar.gz
meta-cedartrail: update Kernel recipes to add support for pvr driver
Modify kernel recipes to enable pvr kernel patches and to include additional Kernel config files for pvr driver Signed-off-by: Rahul Saxena <rahul.saxena@.intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
-rwxr-xr-xmeta-cedartrail/recipes-kernel/linux/linux-yocto-rt_3.0.bbappend13
-rwxr-xr-xmeta-cedartrail/recipes-kernel/linux/linux-yocto_3.0.bbappend15
2 files changed, 23 insertions, 5 deletions
diff --git a/meta-cedartrail/recipes-kernel/linux/linux-yocto-rt_3.0.bbappend b/meta-cedartrail/recipes-kernel/linux/linux-yocto-rt_3.0.bbappend
index 39789519..828e6fd5 100755
--- a/meta-cedartrail/recipes-kernel/linux/linux-yocto-rt_3.0.bbappend
+++ b/meta-cedartrail/recipes-kernel/linux/linux-yocto-rt_3.0.bbappend
@@ -2,10 +2,21 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2COMPATIBLE_MACHINE_cedartrail = "cedartrail" 2COMPATIBLE_MACHINE_cedartrail = "cedartrail"
3KMACHINE_cedartrail = "cedartrail" 3KMACHINE_cedartrail = "cedartrail"
4 4
5# The Cedarview processors have hyperthreading and includes dual-core versions 5COMPATIBLE_MACHINE_cedartrail-nopvr = "cedartrail"
6KMACHINE_cedartrail-nopvr = "cedartrail"
7KERNEL_FEATURES_append_cedartrail-nopvr += " cfg/smp.scc"
8
9COMPATIBLE_MACHINE_cedartrail = "cedartrail"
10KMACHINE_cedartrail = "cedartrail"
6KERNEL_FEATURES_append_cedartrail += " cfg/smp.scc" 11KERNEL_FEATURES_append_cedartrail += " cfg/smp.scc"
12KERNEL_FEATURES_append_cedartrail += " cfg/drm-cdvpvr.scc"
13KERNEL_FEATURES_append_cedartrail += " bsp/cedartrail/cedartrail-pvr-merge.scc"
7 14
8# Update the following to use a different BSP branch or meta SRCREV 15# Update the following to use a different BSP branch or meta SRCREV
16#KBRANCH_cedartrail-nopvr = "yocto/standard/preempt-rt/base"
17#SRCREV_machine_pn-linux-yocto-rt_cedartrail-nopvr ?= XXXX
18#SRCREV_meta_pn-linux-yocto-rt_cedartrail-nopvr ?= XXXX
19
9#KBRANCH_cedartrail = "yocto/standard/preempt-rt/base" 20#KBRANCH_cedartrail = "yocto/standard/preempt-rt/base"
10#SRCREV_machine_pn-linux-yocto-rt_cedartrail ?= XXXX 21#SRCREV_machine_pn-linux-yocto-rt_cedartrail ?= XXXX
11#SRCREV_meta_pn-linux-yocto-rt_cedartrail ?= XXXX 22#SRCREV_meta_pn-linux-yocto-rt_cedartrail ?= XXXX
diff --git a/meta-cedartrail/recipes-kernel/linux/linux-yocto_3.0.bbappend b/meta-cedartrail/recipes-kernel/linux/linux-yocto_3.0.bbappend
index 858db15e..14c0b9dc 100755
--- a/meta-cedartrail/recipes-kernel/linux/linux-yocto_3.0.bbappend
+++ b/meta-cedartrail/recipes-kernel/linux/linux-yocto_3.0.bbappend
@@ -1,10 +1,17 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3COMPATIBLE_MACHINE_cedartrail-nopvr = "cedartrail"
4KMACHINE_cedartrail-nopvr = "yocto/standard/cedartrail"
5KERNEL_FEATURES_append_cedartrail-nopvr += " cfg/smp.scc"
6
3COMPATIBLE_MACHINE_cedartrail = "cedartrail" 7COMPATIBLE_MACHINE_cedartrail = "cedartrail"
4KMACHINE_cedartrail = "yocto/standard/cedartrail" 8KMACHINE_cedartrail = "yocto/standard/cedartrail"
5
6# The Cedarview processors have hyperthreading and includes dual-core versions
7KERNEL_FEATURES_append_cedartrail += " cfg/smp.scc" 9KERNEL_FEATURES_append_cedartrail += " cfg/smp.scc"
10KERNEL_FEATURES_append_cedartrail += " cfg/drm-cdvpvr.scc"
11KERNEL_FEATURES_append_cedartrail += " bsp/cedartrail/cedartrail-pvr-merge.scc"
12
13SRCREV_machine_pn-linux-yocto_cedartrail ?= "5746120ee0afefd1e28400bea4b74f285bd5e59a"
14SRCREV_meta_pn-linux-yocto_cedartrail ?= "a4ac64fe873f08ef718e2849b88914725dc99c1c"
8 15
9SRCREV_machine_pn-linux-yocto_cedartrail ?= "f389d310965a56091f688b28ea8be6d9cbb7fbbe" 16SRCREV_machine_pn-linux-yocto_cedartrail-nopvr ?= "5746120ee0afefd1e28400bea4b74f285bd5e59a"
10SRCREV_meta_pn-linux-yocto_cedartrail ?= "04a52a32cbdf0972033b97b83eaa83eb275dfdc9" 17SRCREV_meta_pn-linux-yocto_cedartrail-nopvr ?= "d588bdafc0d9b4d2386144b7d76a1d379e2d16c0"