summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRahul Saxena <rahul.saxena@intel.com>2012-03-19 18:02:39 -0700
committerTom Zanussi <tom.zanussi@intel.com>2012-03-26 17:41:28 -0500
commite402b37fbe35ab3479325b835b3c8bd6e7ac5083 (patch)
tree6138143ba7c8a800990f45b54a020ad081499e95
parent2e94d8b114a69c4e26535cf0ba0986ef9e80227e (diff)
downloadmeta-intel-e402b37fbe35ab3479325b835b3c8bd6e7ac5083.tar.gz
meta-cedartrail: add Cedar Trail PVR driver
The Cedar Trail PVR driver consists of user-space binaries that enable the Video and Graphics acceleration capabilites of the Power VR SGX545 Integrated Graphics Controller in the Cedarview processor. The driver binaries are provided under "Intel Free Distribution Binary License" The instructions to enable the build of this driver are provided in the meta-cedartrail/README file Signed-off-by: Rahul Saxena <rahul.saxena@.intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
-rw-r--r--meta-cedartrail/recipes-graphics/xorg-driver/cdv-graphics-drivers_1.0.bb89
1 files changed, 89 insertions, 0 deletions
diff --git a/meta-cedartrail/recipes-graphics/xorg-driver/cdv-graphics-drivers_1.0.bb b/meta-cedartrail/recipes-graphics/xorg-driver/cdv-graphics-drivers_1.0.bb
new file mode 100644
index 00000000..249246b9
--- /dev/null
+++ b/meta-cedartrail/recipes-graphics/xorg-driver/cdv-graphics-drivers_1.0.bb
@@ -0,0 +1,89 @@
1SUMMARY = "Cedartrail PowerVR Graphics Driver version [Gold] 1.0 binaries"
2DESCRIPTION = "2D, 3D and Media user space driver for Cedartrail platform \
3The binaries are covered by the Intel Free Distribution Binary License. \
4The user must make himself/herself aware of the Licensing terms \
5before enabling build of the Cedartrail PowerVR Graphics Driver via \
6this recipe. Please see the README in meta-cedartrail for instructions \
7for enabling the build of the driver "
8
9
10PR = r0
11
12S = ${WORKDIR}/cdv-graphics-drivers_${PV}
13
14LICENSE = "Intel Free Distribution Binary License"
15LIC_FILES_CHKSUM = " \
16 file://${S}/usr/share/doc/psb-video-cdv-0.12/license.txt;md5=b14d99f8d4ed664e9ce95057f0bb5b65 \
17 file://${S}/usr/share/doc/pvr-bin-cdv-1.7.788837_05/license.txt;md5=b14d99f8d4ed664e9ce95057f0bb5b65"
18
19DEPENDS = "libva"
20
21CDR_TRAIL = "download.meego.com/live/MeeGo:/1.2.0:/CedarTrail:"
22
23SRC_URI = " \
24 http://${CDR_TRAIL}/non-oss/MeeGo_1.2.0_CedarTrail/i586/psb-video-cdv-0.12-1.1.i586.rpm;name=psb \
25 http://${CDR_TRAIL}/non-oss/MeeGo_1.2.0_CedarTrail/i586/pvr-bin-cdv-1.7.788837_05-1.1.i586.rpm;name=pvr \
26 http://${CDR_TRAIL}/oss/standard/i586/libwsbm-cdv-1.1.0-3.1.i586.rpm;name=libwsbm \
27 "
28SRC_URI[psb.md5sum] = "d4b6b383722264f3b781aeb240c88037"
29SRC_URI[psb.sha256sum] = "e88f95fc73a79adf76ee33d3d9874cec23bb1afe8149d7dc5842d67e58da72f5"
30SRC_URI[pvr.md5sum] = "951fa9edcbc2a3ddb30450079869362e"
31SRC_URI[pvr.sha256sum] = "537dd8a98ac2e3a101063abc62682c3be8c37ac29782a876eafce113ffa5b421"
32SRC_URI[libwsbm.md5sum] = "8d90436b151ddf72f620771f2552b597"
33SRC_URI[libwsbm.sha256sum] = "82f78f47c151f0e7d567574ee372504e5b395fb13796caa765f9c30754b5bf63"
34
35do_configure () {
36
37# Extract license files from rpms
38rpm2cpio ${WORKDIR}/psb-video-cdv-0.12-1.1.i586.rpm |cpio -ivd ./usr/share/doc/psb-video-cdv-0.12/license.txt
39rpm2cpio ${WORKDIR}/pvr-bin-cdv-1.7.788837_05-1.1.i586.rpm |cpio -ivd ./usr/share/doc/pvr-bin-cdv-1.7.788837_05/license.txt
40
41}
42
43do_install() {
44
45install -m 0644 ${WORKDIR}/psb-video-cdv-0.12-1.1.i586.rpm ${D}
46install -m 0644 ${WORKDIR}/pvr-bin-cdv-1.7.788837_05-1.1.i586.rpm ${D}
47install -m 0644 ${WORKDIR}/libwsbm-cdv-1.1.0-3.1.i586.rpm ${D}
48
49cd ${D}
50
51rpm2cpio psb-video-cdv-0.12-1.1.i586.rpm | cpio -idmv
52rpm2cpio pvr-bin-cdv-1.7.788837_05-1.1.i586.rpm | cpio -idmv
53rpm2cpio libwsbm-cdv-1.1.0-3.1.i586.rpm | cpio -idmv
54
55install -m 0755 ${D}/${libdir}/libpvr2d.so.1.7.788837 ${D}/${libdir}/libpvr2d.so
56install -m 0755 ${D}/${libdir}/libsrv_um.so.1.7.788837 ${D}/${libdir}/libsrv_um.so
57install -m 0755 ${D}/${libdir}/libegl4ogl.so.1.7.788837 ${D}/${libdir}/libegl4ogl.so
58install -m 0755 ${D}/${libdir}/libPVROGL_MESA.so.1.7.788837 ${D}/${libdir}/libPVROGL_MESA.so
59install -m 0755 ${D}/${libdir}/libIMGegl.so.1.7.788837 ${D}/${libdir}/libIMGegl.so
60install -m 0755 ${D}/${libdir}/libusc.so.1.7.788837 ${D}/${libdir}/libusc.so
61install -m 0755 ${D}/${libdir}/libOpenVG.so.1.7.788837 ${D}/${libdir}/libOpenVG.so
62
63install -m 0644 ${S}/usr/share/doc/psb-video-cdv-0.12/license.txt ${WORKDIR}/license-destdir/cdv-graphics-drivers/license.txt
64
65rm -f *.rpm
66}
67
68FILES_${PN} += "${libdir}/pvr/cdv/lib*.so.*"
69FILES_${PN} += "${base_libdir}/firmware"
70FILES_${PN} += "${libdir}/debug/usr/bin"
71FILES_${PN} += "${libdir}/debug/usr/lib"
72FILES_${PN} += "${libdir}/lib*.so"
73
74FILES_${PN} += "${libdir}/dri/*.so"
75FILES_${PN} += "${libdir}/pvr/cdv/dri/*.so"
76FILES_${PN} += "${libdir}/xorg/modules/drivers/*.so"
77FILES_${PN} += "${libdir}/pvr/cdv/xorg/modules/drivers/*.so"
78
79FILES_${PN}-dbg += "${libdir}/dri/.debug/*"
80
81addtask check_pvr_license before do_fetch
82
83python do_check_pvr_license() {
84 pn = bb.data.getVar('PN', d, 1)
85 pvr_license = bb.data.getVar('PVR_LICENSE', d, 1)
86 if not pvr_license or not pvr_license.lower() == "yes":
87 bb.debug(1, "Skipping %s because it may have a non-free license" % pn)
88 raise bb.parse.SkipPackage("because it requires PVR_LICENSE = \"yes\" in local.conf to ship")
89}