diff options
author | Nitin A Kamble <nitin.a.kamble@intel.com> | 2013-02-25 09:04:49 -0800 |
---|---|---|
committer | Tom Zanussi <tom.zanussi@intel.com> | 2013-03-04 16:53:19 -0600 |
commit | 5b9c36be97095705c82bd36a524efc6171ea9af8 (patch) | |
tree | c8ae3decb1ac13035a867fbb2eab8d800f60436b | |
parent | 4ffe40409f8cd0f354a7488113ef888b42867033 (diff) | |
download | meta-intel-5b9c36be97095705c82bd36a524efc6171ea9af8.tar.gz |
sys940x: use EMGD version 1.16 instead of 1.14
The link for the source tarball of the emgd 1.14 driver is not working
anymore. Also the sys940x BSP should also use the latest EMGD driver
like rest of the EMGD based BSPs.
This partly addresses:
[YOCTO #3809]
Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
Acked-by: Darren Hart <dvhart@linux.intel.com>
-rw-r--r-- | meta-sys940x/README | 8 | ||||
-rw-r--r-- | meta-sys940x/conf/machine/sys940x.conf | 2 | ||||
-rw-r--r-- | meta-sys940x/recipes-kernel/linux/linux-yocto_3.4.bbappend | 4 |
3 files changed, 7 insertions, 7 deletions
diff --git a/meta-sys940x/README b/meta-sys940x/README index 75bd7e00..be5bc0fc 100644 --- a/meta-sys940x/README +++ b/meta-sys940x/README | |||
@@ -79,7 +79,7 @@ between BSPs) e.g.: | |||
79 | The meta-sys940x layer contains support for two different machine | 79 | The meta-sys940x layer contains support for two different machine |
80 | configurations. These configurations are identical except for the fact | 80 | configurations. These configurations are identical except for the fact |
81 | that the one prefixed with 'sys940x' makes use of the Intel-proprietary | 81 | that the one prefixed with 'sys940x' makes use of the Intel-proprietary |
82 | EMGD 1.10 graphics driver, while the one prefixed with 'sys940x-noemgd' | 82 | EMGD graphics driver, while the one prefixed with 'sys940x-noemgd' |
83 | does not. | 83 | does not. |
84 | 84 | ||
85 | If you want to enable the layer that supports EMGD graphics add the | 85 | If you want to enable the layer that supports EMGD graphics add the |
@@ -89,10 +89,10 @@ following to the local.conf file: | |||
89 | 89 | ||
90 | The 'sys940x' machine includes the emgd-driver-bin package, which has a | 90 | The 'sys940x' machine includes the emgd-driver-bin package, which has a |
91 | proprietary license that must be whitelisted by adding the string | 91 | proprietary license that must be whitelisted by adding the string |
92 | "license_emgd-driver-bin_1.10" to the LICENSE_FLAGS_WHITELIST variable | 92 | "license_emgd-driver-bin" to the LICENSE_FLAGS_WHITELIST variable |
93 | in your local.conf. For example: | 93 | in your local.conf. For example: |
94 | 94 | ||
95 | LICENSE_FLAGS_WHITELIST = "license_emgd-driver-bin_1.10" | 95 | LICENSE_FLAGS_WHITELIST = "license_emgd-driver-bin" |
96 | 96 | ||
97 | If you want to enable the layer that does not support EMGD graphics | 97 | If you want to enable the layer that does not support EMGD graphics |
98 | add the following to the local.conf file: | 98 | add the following to the local.conf file: |
@@ -114,7 +114,7 @@ added to the the LICENSE_FLAGS_WHITELIST variable in your local.conf. | |||
114 | 114 | ||
115 | For example: | 115 | For example: |
116 | 116 | ||
117 | LICENSE_FLAGS_WHITELIST = "license_emgd-driver-bin_1.10 commercial" | 117 | LICENSE_FLAGS_WHITELIST = "license_emgd-driver-bin commercial" |
118 | 118 | ||
119 | The reason this is needed is to prevent the image from including | 119 | The reason this is needed is to prevent the image from including |
120 | anything that might violate the license terms of the packages used to | 120 | anything that might violate the license terms of the packages used to |
diff --git a/meta-sys940x/conf/machine/sys940x.conf b/meta-sys940x/conf/machine/sys940x.conf index 5ab592ff..c4aa5db6 100644 --- a/meta-sys940x/conf/machine/sys940x.conf +++ b/meta-sys940x/conf/machine/sys940x.conf | |||
@@ -26,7 +26,7 @@ XSERVER ?= "${XSERVER_IA32_BASE} \ | |||
26 | PREFERRED_VERSION_xserver-xorg ?= "1.9.3" | 26 | PREFERRED_VERSION_xserver-xorg ?= "1.9.3" |
27 | PREFERRED_VERSION_mesa-dri ?= "9.0.2" | 27 | PREFERRED_VERSION_mesa-dri ?= "9.0.2" |
28 | PREFERRED_VERSION_xf86-input-evdev ?= "2.6.0" | 28 | PREFERRED_VERSION_xf86-input-evdev ?= "2.6.0" |
29 | PREFERRED_VERSION_emgd-driver-bin ?= "1.14" | 29 | PREFERRED_VERSION_emgd-driver-bin ?= "1.16" |
30 | 30 | ||
31 | SERIAL_CONSOLE = "115200 ttyS0" | 31 | SERIAL_CONSOLE = "115200 ttyS0" |
32 | APPEND += "console=ttyS0,115200 console=tty0" | 32 | APPEND += "console=ttyS0,115200 console=tty0" |
diff --git a/meta-sys940x/recipes-kernel/linux/linux-yocto_3.4.bbappend b/meta-sys940x/recipes-kernel/linux/linux-yocto_3.4.bbappend index 541b0d8a..121145bc 100644 --- a/meta-sys940x/recipes-kernel/linux/linux-yocto_3.4.bbappend +++ b/meta-sys940x/recipes-kernel/linux/linux-yocto_3.4.bbappend | |||
@@ -5,7 +5,7 @@ KMETA = "meta" | |||
5 | COMPATIBLE_MACHINE_sys940x = "sys940x" | 5 | COMPATIBLE_MACHINE_sys940x = "sys940x" |
6 | KMACHINE_sys940x = "sys940x" | 6 | KMACHINE_sys940x = "sys940x" |
7 | KBRANCH_sys940x = "standard/base" | 7 | KBRANCH_sys940x = "standard/base" |
8 | KERNEL_FEATURES_sys940x = " features/drm-emgd" | 8 | KERNEL_FEATURES_sys940x = " features/drm-emgd/drm-emgd-1.16" |
9 | 9 | ||
10 | COMPATIBLE_MACHINE_sys940x-noemgd = "sys940x-noemgd" | 10 | COMPATIBLE_MACHINE_sys940x-noemgd = "sys940x-noemgd" |
11 | KMACHINE_sys940x-noemgd = "sys940x" | 11 | KMACHINE_sys940x-noemgd = "sys940x" |
@@ -19,6 +19,6 @@ SRCREV_emgd_pn-linux-yocto_sys940x ?= "86643bdd8cbad616a161ab91f51108cf0da827bc" | |||
19 | SRCREV_machine_pn-linux-yocto_sys940x-noemgd ?= "13809f2cfd9be0ce86bd486e1643f9b90bed6f4f" | 19 | SRCREV_machine_pn-linux-yocto_sys940x-noemgd ?= "13809f2cfd9be0ce86bd486e1643f9b90bed6f4f" |
20 | SRCREV_meta_pn-linux-yocto_sys940x-noemgd ?= "f697e099bc76d5df3a307a5bc0cc25021dd6dfe0" | 20 | SRCREV_meta_pn-linux-yocto_sys940x-noemgd ?= "f697e099bc76d5df3a307a5bc0cc25021dd6dfe0" |
21 | 21 | ||
22 | SRC_URI_sys940x = "git://git.yoctoproject.org/linux-yocto-3.4.git;protocol=git;nocheckout=1;branch=${KBRANCH},${KMETA},emgd-1.14;name=machine,meta,emgd" | 22 | SRC_URI_sys940x = "git://git.yoctoproject.org/linux-yocto-3.4.git;protocol=git;nocheckout=1;branch=${KBRANCH},${KMETA},emgd-1.16;name=machine,meta,emgd" |
23 | 23 | ||
24 | LINUX_VERSION = "3.4.28" | 24 | LINUX_VERSION = "3.4.28" |