summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOng Boon Leong <boon.leong.ong@intel.com>2013-11-27 10:48:44 +0800
committerTom Zanussi <tom.zanussi@intel.com>2013-12-09 10:27:49 -0600
commite272e0208cbe5f38718f5d3453e33a53dc65dbf7 (patch)
tree697b24294d7c50c2a9a24a1ea4068f8ee2801078
parent722ed4b974a32c65491eb05e0dd42c08ae0f6479 (diff)
downloadmeta-intel-e272e0208cbe5f38718f5d3453e33a53dc65dbf7.tar.gz
meta-mohonpeak: new BSP layer for Intel Atom Processor C2000
This layer provides support for Intel Atom Processor C2000 product line. Signed-off-by: Ong Boon Leong <boon.leong.ong@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
-rw-r--r--meta-mohonpeak/COPYING.MIT17
-rw-r--r--meta-mohonpeak/README145
-rw-r--r--meta-mohonpeak/README.sources18
-rw-r--r--meta-mohonpeak/conf/layer.conf12
4 files changed, 192 insertions, 0 deletions
diff --git a/meta-mohonpeak/COPYING.MIT b/meta-mohonpeak/COPYING.MIT
new file mode 100644
index 00000000..89de3547
--- /dev/null
+++ b/meta-mohonpeak/COPYING.MIT
@@ -0,0 +1,17 @@
1Permission is hereby granted, free of charge, to any person obtaining a copy
2of this software and associated documentation files (the "Software"), to deal
3in the Software without restriction, including without limitation the rights
4to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
5copies of the Software, and to permit persons to whom the Software is
6furnished to do so, subject to the following conditions:
7
8The above copyright notice and this permission notice shall be included in
9all copies or substantial portions of the Software.
10
11THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
12IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
13FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
14AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
15LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
16OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
17THE SOFTWARE.
diff --git a/meta-mohonpeak/README b/meta-mohonpeak/README
new file mode 100644
index 00000000..9c95a675
--- /dev/null
+++ b/meta-mohonpeak/README
@@ -0,0 +1,145 @@
1This README file contains information on building the meta-mohonpeak
2BSP layer, and booting the images contained in the /binary directory.
3Please see the corresponding sections below for details.
4
5The mohonpeak platform consists of two versions:
61. 32-bit Mohon Peak
72. 64-bit Mohon Peak
8
9The Mohon Peak platform consists of the Intel Atom Processor C2000
10Product Family (Formerly Rangeley)
11
12This BSP assumes ASPEED Technology graphics card is being used.
13
14Further information about the platforms supported by this BSP can be
15found here:
16
17 http://www.intel.com/content/www/us/en/intelligent-systems/rangeley/
18 atom-c2000-product-family-based-platforms-overview.html
19
20Information on all IntelĀ® embedded platforms can be found here:
21
22 http://www.intel.com/p/en_US/embedded/hwsw/hardware
23
24
25Yocto Project Compatible
26========================
27
28This BSP is compatible with the Yocto Project as per the requirements
29listed here:
30
31 https://www.yoctoproject.org/webform/yocto-project-compatible-registration
32
33
34Dependencies
35============
36
37This layer depends on:
38
39 URI: git://git.openembedded.org/bitbake
40 branch: master
41
42 URI: git://git.openembedded.org/openembedded-core
43 layers: meta
44 branch: master
45
46 URI: git://git.yoctoproject.org/meta-intel
47 layers: intel
48 branch: master
49
50
51Patches
52=======
53
54Please submit any patches against this BSP to the Yocto mailing list
55(yocto@yoctoproject.org) and cc: the maintainer:
56
57Maintainer: Ong Boon Leong <boon.leong.ong@intel.com>
58
59Please see the meta-intel/MAINTAINERS file for more details.
60
61
62Table of Contents
63=================
64
65 I. Building the meta-mohonpeak BSP layer
66 II. Booting the images in /binary
67
68I. Building the meta-mohonpeak BSP layer
69=======================================
70
71In order to build an image with BSP support for a given release, you
72need to download the corresponding BSP tarball from the 'Board Support
73Package (BSP) Downloads' page of the Yocto Project website.
74
75Having done that, and assuming you extracted the BSP tarball contents
76at the top-level of your yocto build tree, you can build a mohonpeak
77image by adding the location of the meta-mohonpeak layer to
78bblayers.conf, along with the meta-intel layer itself (to access
79common metadata shared between BSPs) e.g.:
80
81 yocto/meta-intel \
82 yocto/meta-intel/meta-mohonpeak \
83
84To enable the 32-bit Mohon Peak layer, add the mohonpeak32 MACHINE to local.conf:
85
86 MACHINE ?= "mohonpeak32"
87
88To enable the 64-bit Mohon Peak layer, add the mohonpeak64 MACHINE to local.conf:
89
90 MACHINE ?= "mohonpeak64"
91
92You should then be able to build a mohonpeak image as such:
93
94 $ source oe-init-build-env
95 $ bitbake core-image-sato
96
97At the end of a successful build, you should have a live image that
98you can boot from a USB flash drive (see instructions on how to do
99that below, in the section 'Booting the images from /binary').
100
101As an alternative to downloading the BSP tarball, you can also work
102directly from the meta-intel git repository. For each BSP in the
103'meta-intel' repository, there are multiple branches, one
104corresponding to each major release starting with 'laverne' (0.90), in
105addition to the latest code which tracks the current master (note that
106not all BSPs are present in every release). Instead of extracting a
107BSP tarball at the top level of your yocto build tree, you can
108equivalently check out the appropriate branch from the meta-intel
109repository at the same location.
110
111
112II. Booting the images in /binary
113=================================
114
115This BSP contains bootable live images, which can be used to directly
116boot Yocto off of a USB flash drive.
117
118Under Linux, insert a USB flash drive. Assuming the USB flash drive
119takes device /dev/sdf, use dd to copy the live image to it. For
120example:
121
122# dd if=core-image-sato-mohonpeak64.hddimg of=/dev/sdf
123# sync
124# eject /dev/sdf
125
126This should give you a bootable USB flash device. Insert the device
127into a bootable USB socket on the target, and power on. This should
128result in a system booted to the Sato graphical desktop.
129
130If you want a terminal, use the arrows at the top of the UI to move to
131different pages of available applications, one of which is named
132'Terminal'. Clicking that should give you a root terminal.
133
134If you want to ssh into the system, you can use the root terminal to
135ifconfig the IP address and use that to ssh in. The root password is
136empty, so to log in type 'root' for the user name and hit 'Enter' at
137the Password prompt: and you should be in.
138
139----
140
141If you find you're getting corrupt images on the USB (it doesn't show
142the syslinux boot: prompt, or the boot: prompt contains strange
143characters), try doing this first:
144
145# dd if=/dev/zero of=/dev/sdf bs=1M count=512
diff --git a/meta-mohonpeak/README.sources b/meta-mohonpeak/README.sources
new file mode 100644
index 00000000..07654121
--- /dev/null
+++ b/meta-mohonpeak/README.sources
@@ -0,0 +1,18 @@
1The sources for the packages comprising the images shipped with this
2BSP can be found at the following location:
3
4http://downloads.yoctoproject.org/mirror/sources/
5
6The metadata used to generate the images shipped with this BSP, in
7addition to the code contained in this BSP, can be found at the
8following location:
9
10http://www.yoctoproject.org/downloads/yocto-1.4.2/poky-dylan-9.0.2.tar.bz2
11
12The metadata used to generate the images shipped with this BSP, in
13addition to the code contained in this BSP, can also be found at the
14following locations:
15
16git://git.yoctoproject.org/poky.git
17
18git://git.yoctoproject.org/meta-intel.git
diff --git a/meta-mohonpeak/conf/layer.conf b/meta-mohonpeak/conf/layer.conf
new file mode 100644
index 00000000..93ec112d
--- /dev/null
+++ b/meta-mohonpeak/conf/layer.conf
@@ -0,0 +1,12 @@
1# We have a conf and classes directory, add to BBPATH
2BBPATH := "${BBPATH}:${LAYERDIR}"
3
4# We have a recipes directory, add to BBFILES
5BBFILES := "${BBFILES} ${LAYERDIR}/recipes-*/*/*.bb \
6 ${LAYERDIR}/recipes-*/*/*.bbappend"
7
8BBFILE_COLLECTIONS += "mohonpeak"
9BBFILE_PATTERN_mohonpeak := "^${LAYERDIR}/"
10BBFILE_PRIORITY_mohonpeak = "6"
11
12LAYERDEPENDS_mohonpeak = "intel"