summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2022-09-19 12:20:01 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2022-09-19 12:52:12 +0800
commita26ea404d91b11825bdcfb57283e59717ca019fc (patch)
treef29eb1ec435e784cb66c70ccce86f1e91076a6ef
parent203e26c918fbd52b5a3b22520e81a48a059cbfba (diff)
downloadmeta-intel-a26ea404d91b11825bdcfb57283e59717ca019fc.tar.gz
intel-compute-runtime: fix build error
Backport a patch to fix errors like: 12:14:05 | /poky/build/tmp/work/x86_64-linux/intel-compute-runtime-native/20.15.16524-r0/git/shared/source/helpers/basic_math.h:166:21: error: ânumeric_limitsâ is not a member of âstdâ 12:14:05 | 166 | return std::numeric_limits<T>::max(); Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/compute-runtime/files/113cef897712c8b475f668f2bcf77a12db76a90e.patch45
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_20.15.16524.bb1
2 files changed, 46 insertions, 0 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/files/113cef897712c8b475f668f2bcf77a12db76a90e.patch b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/files/113cef897712c8b475f668f2bcf77a12db76a90e.patch
new file mode 100644
index 00000000..5edb52d0
--- /dev/null
+++ b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/files/113cef897712c8b475f668f2bcf77a12db76a90e.patch
@@ -0,0 +1,45 @@
1From a72b1fe0c571c191d857297114e0393ce017b7ab Mon Sep 17 00:00:00 2001
2From: Mateusz Jablonski <mateusz.jablonski@intel.com>
3Date: Wed, 28 Jul 2021 09:25:56 +0000
4Subject: [PATCH] Add missing includes
5
6Signed-off-by: Florian Minnecker <florian.github@minnecker.com>
7Signed-off-by: Mateusz Jablonski <mateusz.jablonski@intel.com>
8
9Upstream-Status: Backport
10Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
11---
12 shared/source/helpers/basic_math.h | 3 ++-
13 shared/source/helpers/registered_method_dispatcher.h | 1 +
14 2 files changed, 3 insertions(+), 1 deletion(-)
15
16diff --git a/shared/source/helpers/basic_math.h b/shared/source/helpers/basic_math.h
17index fd62b9e6b..f339677eb 100644
18--- a/shared/source/helpers/basic_math.h
19+++ b/shared/source/helpers/basic_math.h
20@@ -11,8 +11,9 @@
21 #include <algorithm>
22 #include <cmath>
23 #include <cstdint>
24+#include <cstdio>
25 #include <cstdlib>
26-#include <stdio.h>
27+#include <limits>
28
29 #define KB 1024uLL
30 #define MB (KB * KB)
31diff --git a/shared/source/helpers/registered_method_dispatcher.h b/shared/source/helpers/registered_method_dispatcher.h
32index 56f880a16..cd778fad0 100644
33--- a/shared/source/helpers/registered_method_dispatcher.h
34+++ b/shared/source/helpers/registered_method_dispatcher.h
35@@ -7,6 +7,7 @@
36
37 #pragma once
38
39+#include <cstddef>
40 #include <cstdint>
41 #include <functional>
42
43--
442.37.3
45
diff --git a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_20.15.16524.bb b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_20.15.16524.bb
index 5525b66a..eb17b642 100644
--- a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_20.15.16524.bb
+++ b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_20.15.16524.bb
@@ -9,6 +9,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=ae27f47fd6755510247c19e547e4c804 \
9 file://third_party/opencl_headers/LICENSE;md5=dcefc90f4c3c689ec0c2489064e7273b" 9 file://third_party/opencl_headers/LICENSE;md5=dcefc90f4c3c689ec0c2489064e7273b"
10 10
11SRC_URI = "git://github.com/intel/compute-runtime.git;protocol=https \ 11SRC_URI = "git://github.com/intel/compute-runtime.git;protocol=https \
12 file://113cef897712c8b475f668f2bcf77a12db76a90e.patch \
12 " 13 "
13 14
14SRCREV = "e0633548a9bd025c70bc7f3539eef094b1bc9ce1" 15SRCREV = "e0633548a9bd025c70bc7f3539eef094b1bc9ce1"