summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNaveen Saini <naveen.kumar.saini@intel.com>2022-08-15 10:28:05 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2022-08-19 12:22:24 +0800
commit8ed6f20cfb116e88e573ee6a08637aa5ac12e1c5 (patch)
tree45e418fb954f6734c33337e76d897ada816bb3aa
parent8741ef362e485d790dc1f48b10bd617d23936772 (diff)
downloadmeta-intel-8ed6f20cfb116e88e573ee6a08637aa5ac12e1c5.tar.gz
linux-intel-dev: update to 5.19.0
Also bring in the latest kernel config data. Update license checksum as per: https://github.com/torvalds/linux/commit/74835c7db0322b6eddf091b8b062f127b8999a0a Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> (cherry picked from commit 94d6ec3730ac57fa2c27d1b04124d55cd5f88952) Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
-rw-r--r--recipes-kernel/linux/linux-intel-dev.bb10
-rw-r--r--recipes-kernel/linux/linux-intel/0001-v5.19-menuconfig-mconf-cfg-Allow-specification-of-ncurses-.patch50
2 files changed, 55 insertions, 5 deletions
diff --git a/recipes-kernel/linux/linux-intel-dev.bb b/recipes-kernel/linux/linux-intel-dev.bb
index 4da6e3b9..12dda6cb 100644
--- a/recipes-kernel/linux/linux-intel-dev.bb
+++ b/recipes-kernel/linux/linux-intel-dev.bb
@@ -6,7 +6,7 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/linux-intel:"
6SRC_URI = " \ 6SRC_URI = " \
7 git://github.com/intel/mainline-tracking.git;protocol=https;name=machine;nobranch=1; \ 7 git://github.com/intel/mainline-tracking.git;protocol=https;name=machine;nobranch=1; \
8 git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=${KMETA_BRANCH};destsuffix=${KMETA} \ 8 git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=${KMETA_BRANCH};destsuffix=${KMETA} \
9 file://0001-menuconfig-mconf-cfg-Allow-specification-of-ncurses-.patch \ 9 file://0001-v5.19-menuconfig-mconf-cfg-Allow-specification-of-ncurses-.patch \
10 " 10 "
11SRC_URI_append_core2-32-intel-common = " file://disable_skylake_sound.cfg" 11SRC_URI_append_core2-32-intel-common = " file://disable_skylake_sound.cfg"
12 12
@@ -15,13 +15,13 @@ KCONF_BSP_AUDIT_LEVEL = "2"
15 15
16KMETA_BRANCH = "master" 16KMETA_BRANCH = "master"
17 17
18LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814" 18LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
19 19
20DEPENDS += "elfutils-native openssl-native util-linux-native" 20DEPENDS += "elfutils-native openssl-native util-linux-native"
21 21
22LINUX_VERSION ?= "5.5-rc3" 22LINUX_VERSION ?= "5.19.0"
23SRCREV_machine ?= "0c5d381c6f1ebd88b4da2c3392f86d1611daba84" 23SRCREV_machine ?= "270ddbd02fe9e1761ebccf792acadbb3cd52b69f"
24SRCREV_meta ?= "1b65db46af4e00e257a6be18cb06736cb83d54dd" 24SRCREV_meta ?= "423df1333e1e2a0c2bff9b29d40d16d74b775a79"
25 25
26LINUX_VERSION_EXTENSION ?= "-mainline-tracking-${LINUX_KERNEL_TYPE}" 26LINUX_VERSION_EXTENSION ?= "-mainline-tracking-${LINUX_KERNEL_TYPE}"
27PV = "${LINUX_VERSION}+git${SRCPV}" 27PV = "${LINUX_VERSION}+git${SRCPV}"
diff --git a/recipes-kernel/linux/linux-intel/0001-v5.19-menuconfig-mconf-cfg-Allow-specification-of-ncurses-.patch b/recipes-kernel/linux/linux-intel/0001-v5.19-menuconfig-mconf-cfg-Allow-specification-of-ncurses-.patch
new file mode 100644
index 00000000..0ebbb008
--- /dev/null
+++ b/recipes-kernel/linux/linux-intel/0001-v5.19-menuconfig-mconf-cfg-Allow-specification-of-ncurses-.patch
@@ -0,0 +1,50 @@
1From ecb938c19d20543382c9bbc42588c29b5ebfd3ed Mon Sep 17 00:00:00 2001
2From: Bruce Ashfield <bruce.ashfield@windriver.com>
3Date: Fri, 12 Aug 2022 13:12:18 +0800
4Subject: [PATCH] menuconfig,mconf-cfg: Allow specification of ncurses location
5
6In some cross build environments such as the Yocto Project build
7environment it provides an ncurses library that is compiled
8differently than the host's version. This causes display corruption
9problems when the host's curses includes are used instead of the
10includes from the provided compiler are overridden. There is a second
11case where there is no curses libraries at all on the host system and
12menuconfig will just fail entirely.
13
14The solution is simply to allow an override variable in
15check-lxdialog.sh for environments such as the Yocto Project. Adding
16a CROSS_CURSES_LIB and CROSS_CURSES_INC solves the issue and allowing
17compiling and linking against the right headers and libraries.
18
19Signed-off-by: Jason Wessel <jason.wessel@windriver.com>
20cc: Michal Marek <mmarek@suse.cz>
21cc: linux-kbuild@vger.kernel.org
22Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
23Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com>
24---
25 scripts/kconfig/mconf-cfg.sh | 9 +++++++++
26 1 file changed, 9 insertions(+)
27
28diff --git a/scripts/kconfig/mconf-cfg.sh b/scripts/kconfig/mconf-cfg.sh
29index 025b565e0b7c..6514d19790e6 100755
30--- a/scripts/kconfig/mconf-cfg.sh
31+++ b/scripts/kconfig/mconf-cfg.sh
32@@ -4,6 +4,15 @@
33 PKG="ncursesw"
34 PKG2="ncurses"
35
36+if [ "$CROSS_CURSES_LIB" != "" ]; then
37+ echo libs=\'$CROSS_CURSES_LIB\'
38+ if [ x"$CROSS_CURSES_INC" != x ]; then
39+ echo cflags=\'$CROSS_CURSES_INC\'
40+ fi
41+ exit 0
42+fi
43+
44+
45 if [ -n "$(command -v ${HOSTPKG_CONFIG})" ]; then
46 if ${HOSTPKG_CONFIG} --exists $PKG; then
47 echo cflags=\"$(${HOSTPKG_CONFIG} --cflags $PKG)\"
48--
492.25.1
50