summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2013-02-25 11:39:39 -0800
committerTom Zanussi <tom.zanussi@intel.com>2013-03-04 16:54:55 -0600
commitef380cf61f48a03d9d2232a76d11f477c4b1f376 (patch)
treedc53f0f46a1a2c8369c9a4cae124a6e8ed7d844a
parent443a85b57237f4a367de91aa4480216768857d41 (diff)
downloadmeta-intel-ef380cf61f48a03d9d2232a76d11f477c4b1f376.tar.gz
emenlow: linux-yocto-dev recipe extension
Provide the emenlow BSP specific extension for the linux-yocto-dev recipe from the oecore layer. This configures the right git branches of the kernel repository for the emenlow BSP. This commit is addressing this bug: [YOCTO #3931] Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
-rw-r--r--meta-emenlow/recipes-kernel/linux/linux-yocto-dev.bbappend20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-emenlow/recipes-kernel/linux/linux-yocto-dev.bbappend b/meta-emenlow/recipes-kernel/linux/linux-yocto-dev.bbappend
new file mode 100644
index 00000000..54c4abd2
--- /dev/null
+++ b/meta-emenlow/recipes-kernel/linux/linux-yocto-dev.bbappend
@@ -0,0 +1,20 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3COMPATIBLE_MACHINE_emenlow = "emenlow"
4KMACHINE_emenlow = "emenlow"
5KBRANCH_emenlow = "standard/emenlow"
6KERNEL_FEATURES_emenlow_append = " features/drm-emgd/drm-emgd-1.16 cfg/vesafb"
7
8COMPATIBLE_MACHINE_emenlow-noemgd = "emenlow-noemgd"
9KMACHINE_emenlow-noemgd = "emenlow"
10KBRANCH_emenlow-noemgd = "standard/emenlow"
11KERNEL_FEATURES_emenlow-noemgd_append = " features/drm-gma500/drm-gma600"
12
13SRCREV_machine_emenlow = "60536206ad300ccf5b2be2c2d449f4ab27170238"
14SRCREV_meta_emenlow = "fe20c99783387dab779472ff50a88666da1c6391"
15SRCREV_emgd_emenlow = "17aacd908ed6035213a6d206cfdb2c0c9fa9e0c1"
16
17SRCREV_machine_emenlow-noemgd = "60536206ad300ccf5b2be2c2d449f4ab27170238"
18SRCREV_meta_emenlow-noemgd = "fe20c99783387dab779472ff50a88666da1c6391"
19
20SRC_URI_emenlow = "git://git.yoctoproject.org/linux-yocto-dev.git;protocol=git;nocheckout=1;branch=${KBRANCH},${KMETA},emgd-1.16;name=machine,meta,emgd"