summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDarren Hart <dvhart@linux.intel.com>2011-07-22 13:44:54 -0700
committerDarren Hart <dvhart@linux.intel.com>2011-08-11 12:57:05 -0700
commit90d7762bb322a3357c6ca90a6055dbc092cba603 (patch)
tree4a3a7212a239f50390b2ca4515492eb1f66fdc81
parent58f707b29e20c2f1712da2e0c1eedc78ea7de6c8 (diff)
downloadmeta-intel-90d7762bb322a3357c6ca90a6055dbc092cba603.tar.gz
add linux-yocto-rt_3.0 support for all meta-intel BSPs
All the BSPs build out of the preempt-rt/base branch (rather than a preempt-rt/$MACHINE branch), so separate KMACHINE and KBRANCH assignments are required for each BSP. Signed-off-by: Darren Hart <dvhart@linux.intel.com>
-rw-r--r--meta-crownbay/recipes-kernel/linux/linux-yocto-rt_3.0.bbappend9
-rw-r--r--meta-emenlow/recipes-kernel/linux/linux-yocto-rt_3.0.bbappend7
-rw-r--r--meta-fishriver/recipes-kernel/linux/linux-yocto-rt_3.0.bbappend7
-rw-r--r--meta-fri2/recipes-kernel/linux/linux-yocto-rt_3.0.bbappend7
-rw-r--r--meta-jasperforest/recipes-kernel/linux/linux-yocto-rt_3.0.bbappend7
-rw-r--r--meta-n450/recipes-kernel/linux/linux-yocto-rt_3.0.bbappend9
-rw-r--r--meta-sugarbay/recipes-kernel/linux/linux-yocto-rt_3.0.bbappend7
7 files changed, 53 insertions, 0 deletions
diff --git a/meta-crownbay/recipes-kernel/linux/linux-yocto-rt_3.0.bbappend b/meta-crownbay/recipes-kernel/linux/linux-yocto-rt_3.0.bbappend
new file mode 100644
index 00000000..c257703f
--- /dev/null
+++ b/meta-crownbay/recipes-kernel/linux/linux-yocto-rt_3.0.bbappend
@@ -0,0 +1,9 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2COMPATIBLE_MACHINE_crownbay-noemgd = "crownbay-noemgd"
3KMACHINE_crownbay-noemgd = "crownbay"
4KBRANCH_crownbay-noemgd = "yocto/standard/preempt-rt/base"
5
6KERNEL_FEATURES_append_crownbay-noemgd += " cfg/smp.scc"
7
8SRCREV_machine_pn-linux-yocto-rt_crownbay-noemgd ?= ${AUTOREV}
9SRCREV_meta_pn-linux-yocto-rt_crownbay-noemgd ?= ${AUTOREV}
diff --git a/meta-emenlow/recipes-kernel/linux/linux-yocto-rt_3.0.bbappend b/meta-emenlow/recipes-kernel/linux/linux-yocto-rt_3.0.bbappend
new file mode 100644
index 00000000..fbff72d1
--- /dev/null
+++ b/meta-emenlow/recipes-kernel/linux/linux-yocto-rt_3.0.bbappend
@@ -0,0 +1,7 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2COMPATIBLE_MACHINE_emenlow = "emenlow"
3KMACHINE_emenlow = "emenlow"
4KBRANCH_emenlow = "yocto/standard/preempt-rt/base"
5
6SRCREV_machine_pn-linux-yocto-rt_emenlow ?= ${AUTOREV}
7SRCREV_meta_pn-linux-yocto-rt_emenlow ?= ${AUTOREV}
diff --git a/meta-fishriver/recipes-kernel/linux/linux-yocto-rt_3.0.bbappend b/meta-fishriver/recipes-kernel/linux/linux-yocto-rt_3.0.bbappend
new file mode 100644
index 00000000..4b1a2e1b
--- /dev/null
+++ b/meta-fishriver/recipes-kernel/linux/linux-yocto-rt_3.0.bbappend
@@ -0,0 +1,7 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2COMPATIBLE_MACHINE_fishriver = "fishriver"
3KMACHINE_fishriver = "fishriver"
4KBRANCH_fishriver = "yocto/standard/preempt-rt/base"
5
6SRCREV_machine_pn-linux-yocto-rt_fishriver ?= ${AUTOREV}
7SRCREV_meta_pn-linux-yocto-rt_fishriver ?= ${AUTOREV}
diff --git a/meta-fri2/recipes-kernel/linux/linux-yocto-rt_3.0.bbappend b/meta-fri2/recipes-kernel/linux/linux-yocto-rt_3.0.bbappend
new file mode 100644
index 00000000..13b68a30
--- /dev/null
+++ b/meta-fri2/recipes-kernel/linux/linux-yocto-rt_3.0.bbappend
@@ -0,0 +1,7 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2COMPATIBLE_MACHINE_fri2 = "fri2"
3KMACHINE_fri2 = "fri2"
4KBRANCH_fri2 = "yocto/standard/preempt-rt/base"
5
6SRCREV_machine_pn-linux-yocto-rt_fri2 ?= ${AUTOREV}
7SRCREV_meta_pn-linux-yocto-rt_fri2 ?= ${AUTOREV}
diff --git a/meta-jasperforest/recipes-kernel/linux/linux-yocto-rt_3.0.bbappend b/meta-jasperforest/recipes-kernel/linux/linux-yocto-rt_3.0.bbappend
new file mode 100644
index 00000000..ac18db0a
--- /dev/null
+++ b/meta-jasperforest/recipes-kernel/linux/linux-yocto-rt_3.0.bbappend
@@ -0,0 +1,7 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2COMPATIBLE_MACHINE_jasperforest = "jasperforest"
3KMACHINE_jasperforest = "jasperforest"
4KBRANCH_jasperforest = "yocto/standard/preempt-rt/base"
5
6SRCREV_machine_pn-linux-yocto-rt_jasperforest ?= ${AUTOREV}
7SRCREV_meta_pn-linux-yocto-rt_jasperforest ?= ${AUTOREV}
diff --git a/meta-n450/recipes-kernel/linux/linux-yocto-rt_3.0.bbappend b/meta-n450/recipes-kernel/linux/linux-yocto-rt_3.0.bbappend
new file mode 100644
index 00000000..69e93049
--- /dev/null
+++ b/meta-n450/recipes-kernel/linux/linux-yocto-rt_3.0.bbappend
@@ -0,0 +1,9 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2COMPATIBLE_MACHINE_n450 = "n450"
3KMACHINE_n450 = "atom-pc"
4KBRANCH_n450 = "yocto/standard/preempt-rt/base"
5
6KERNEL_FEATURES_append_n450 += " cfg/smp.scc"
7
8SRCREV_machine_pn-linux-yocto-rt_n450 ?= ${AUTOREV}
9SRCREV_meta_pn-linux-yocto-rt_n450 ?= ${AUTOREV}
diff --git a/meta-sugarbay/recipes-kernel/linux/linux-yocto-rt_3.0.bbappend b/meta-sugarbay/recipes-kernel/linux/linux-yocto-rt_3.0.bbappend
new file mode 100644
index 00000000..7564367d
--- /dev/null
+++ b/meta-sugarbay/recipes-kernel/linux/linux-yocto-rt_3.0.bbappend
@@ -0,0 +1,7 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2COMPATIBLE_MACHINE_sugarbay = "sugarbay"
3KMACHINE_sugarbay = "sugarbay"
4KBRANCH_sugarbay = "yocto/standard/preempt-rt/base"
5
6SRCREV_machine_pn-linux-yocto-rt_sugarbay ?= ${AUTOREV}
7SRCREV_meta_pn-linux-yocto-rt_sugarbay ?= ${AUTOREV}