summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2013-06-04 12:30:50 +0000
committerTom Zanussi <tom.zanussi@intel.com>2013-06-12 11:13:43 -0500
commit8c8d92de6748e9661cc0bed85c15bede4ddefd77 (patch)
tree9c25a1b83c5fb3d984ce434a6a1f70914f19aaf1
parent523f0945d147e1c73276b15b5fa89cedacc0982b (diff)
downloadmeta-intel-8c8d92de6748e9661cc0bed85c15bede4ddefd77.tar.gz
lms8: new recipe to support AMT version 8
Some of the newer boards have AMT/MEI firmware of version 8. These BSPs need verion 8 of the lms package, which this recipe is providing. Also the lms binary & script is renamed to lms8 to avoid runtime clash with lms7 packages. Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
-rw-r--r--common/recipes-bsp/amt/lms8_8.0.0-7.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/common/recipes-bsp/amt/lms8_8.0.0-7.bb b/common/recipes-bsp/amt/lms8_8.0.0-7.bb
new file mode 100644
index 00000000..fbb4e457
--- /dev/null
+++ b/common/recipes-bsp/amt/lms8_8.0.0-7.bb
@@ -0,0 +1,32 @@
1DESCRIPTION = "Intel Local Manageability Service allows applications \
2to access the Intel Active Management Technology (AMT) firmware via \
3the Intel Management Engine Interface (MEI)."
4HOMEPAGE = "http://software.intel.com/en-us/articles/download-the-latest-intel-amt-open-source-drivers"
5
6LICENSE = "BSD_LMS"
7
8PR = "r0"
9BPN="lms"
10SRC_URI = "http://software.intel.com/sites/default/files/${BPN}-${PV}.tar.gz \
11 file://readlink-declaration.patch"
12
13COMPATIBLE_HOST = '(i.86|x86_64).*-linux'
14
15LIC_FILES_CHKSUM = "file://COPYING;md5=ec77c894e8a1a89fa07aed2c76680ab8"
16
17SRC_URI[md5sum] = "3cbd027a0e6e9ced8238478b24cde3c6"
18SRC_URI[sha256sum] = "7077db6f2f381e67cb37565b20c40ff0c7d3f98f014e65622a4b4b66c2b1d637"
19
20inherit autotools update-rc.d
21
22INITSCRIPT_NAME = "lms8"
23INITSCRIPT_PARAMS = "defaults"
24
25
26do_install_append () {
27 mv ${D}/${sbindir}/lms ${D}/${sbindir}/lms8
28 install -d ${D}${sysconfdir}/init.d
29 mv ${D}${sysconfdir}/rc.d/init.d/lms ${D}${sysconfdir}/init.d/${INITSCRIPT_NAME}
30 sed -i 's/^NAME=lms/NAME=lms8/' ${D}${sysconfdir}/init.d/${INITSCRIPT_NAME}
31 rmdir ${D}${datadir} || :
32}