summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKishore Bodke <kishore.k.bodke@intel.com>2012-01-06 14:24:26 -0800
committerTom Zanussi <tom.zanussi@intel.com>2012-01-09 17:55:07 -0600
commit38f2b670bc37515bcb0fa7f98e338e5242d70386 (patch)
tree479f4d33a562112973087d002cf8a3d27b1d1972
parent7c3db7010479970f3f92501349827c517de3c36a (diff)
downloadmeta-intel-38f2b670bc37515bcb0fa7f98e338e5242d70386.tar.gz
meta-cedartrail: Create new layer for cedartrail System.
This layer provides the initial version of the BSP for Cedar Trail platform. The Cedar Trail platform is based on the Cedarview processor and Tiger Point Chipset. Signed-off-by: Kishore Bodke <kishore.k.bodke@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
-rw-r--r--MAINTAINERS3
-rwxr-xr-xmeta-cedartrail/COPYING.MIT17
-rwxr-xr-xmeta-cedartrail/README111
-rwxr-xr-xmeta-cedartrail/README.sources17
-rw-r--r--meta-cedartrail/binary/.gitignore0
-rw-r--r--meta-cedartrail/conf/layer.conf10
-rw-r--r--meta-cedartrail/conf/machine/cedartrail.conf15
-rw-r--r--meta-cedartrail/recipes-bsp/formfactor/formfactor/cedartrail/machconfig3
-rw-r--r--meta-cedartrail/recipes-bsp/formfactor/formfactor_0.0.bbappend3
-rw-r--r--meta-cedartrail/recipes-core/tasks/task-core-tools.bbappend2
-rw-r--r--meta-cedartrail/recipes-graphics/xorg-xserver/xserver-xf86-config/cedartrail/xorg.conf26
-rw-r--r--meta-cedartrail/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend3
-rw-r--r--meta-cedartrail/recipes-kernel/linux/linux-yocto-rt_3.0.bbappend8
-rw-r--r--meta-cedartrail/recipes-kernel/linux/linux-yocto_3.0.bbappend8
14 files changed, 226 insertions, 0 deletions
diff --git a/MAINTAINERS b/MAINTAINERS
index 49b536ea..c915a091 100644
--- a/MAINTAINERS
+++ b/MAINTAINERS
@@ -32,6 +32,9 @@ Please keep this list in alphabetical order.
32Maintainers List (try to look for most precise areas first) 32Maintainers List (try to look for most precise areas first)
33 33
34 ----------------------------------- 34 -----------------------------------
35CEDARTRAIL
36M: Kishore Bodke <kishore.k.bodke@intel.com>
37F: meta-cedartrail/
35 38
36COMMON 39COMMON
37M: Tom Zanussi <tom.zanussi@intel.com> 40M: Tom Zanussi <tom.zanussi@intel.com>
diff --git a/meta-cedartrail/COPYING.MIT b/meta-cedartrail/COPYING.MIT
new file mode 100755
index 00000000..fb950dc6
--- /dev/null
+++ b/meta-cedartrail/COPYING.MIT
@@ -0,0 +1,17 @@
1Permission is hereby granted, free of charge, to any person obtaining a copy
2of this software and associated documentation files (the "Software"), to deal
3in the Software without restriction, including without limitation the rights
4to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
5copies of the Software, and to permit persons to whom the Software is
6furnished to do so, subject to the following conditions:
7
8The above copyright notice and this permission notice shall be included in
9all copies or substantial portions of the Software.
10
11THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
12IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
13FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
14AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
15LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
16OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
17THE SOFTWARE.
diff --git a/meta-cedartrail/README b/meta-cedartrail/README
new file mode 100755
index 00000000..295e9ff7
--- /dev/null
+++ b/meta-cedartrail/README
@@ -0,0 +1,111 @@
1This README file contains information on building the meta-cedartrail
2BSP layer, and booting the images contained in the /binary directory.
3Please see the corresponding sections below for details.
4
5Dependencies
6============
7
8This layer depends on:
9
10 URI: git://git.openembedded.org/bitbake
11 branch: master
12
13 URI: git://git.openembedded.org/openembedded-core
14 layers: meta
15 branch: master
16
17 URI: git://git.yoctoproject.org/meta-intel
18 layers: intel
19 branch: master
20
21
22Patches
23=======
24
25Please submit any patches against this BSP to the Yocto mailing list
26(yocto@yoctoproject.org) and cc: the maintainer:
27
28Maintainer: Kishore Bodke <kishore.k.bodke@intel.com>
29
30Please see the meta-intel/MAINTAINERS file for more details.
31
32Table of Contents
33=================
34
35 I. Building the meta-cedartrail BSP layer
36II. Booting the images in /binary
37
38
39I. Building the meta-cedartrail BSP layer
40=========================================
41
42In order to build an image with BSP support for a given release, you
43need to download the corresponding BSP tarball from the 'Board Support
44Package (BSP) Downloads' page of the Yocto Project website.
45
46Having done that, and assuming you extracted the BSP tarball contents
47at the top-level of your yocto build tree, you can build a cedartrail
48image by adding the location of the meta-cedartrail layer to
49bblayers.conf, along with the meta-intel layer itself (to access
50common metadata shared between BSPs) e.g.:
51
52 yocto/meta-intel \
53 yocto/meta-intel/meta-cedartrail \
54
55To enable the cedartrail layer, add the cedartrail MACHINE to local.conf:
56
57 MACHINE ?= "cedartrail"
58
59You should then be able to build a cedartrail image as such:
60
61 $ source oe-init-build-env
62 $ bitbake core-image-sato
63
64At the end of a successful build, you should have a live image that
65you can boot from a USB flash drive (see instructions on how to do
66that below, in the section 'Booting the images from /binary').
67
68As an alternative to downloading the BSP tarball, you can also work
69directly from the meta-intel git repository. For each BSP in the
70'meta-intel' repository, there are multiple branches, one
71corresponding to each major release starting with 'laverne' (0.90), in
72addition to the latest code which tracks the current master. Instead
73of extracting a BSP tarball at the top level of your yocto build tree,
74you can equivalently check out the appropriate branch from the
75meta-intel repository at the same location.
76
77
78II. Booting the images in /binary
79==================================
80
81This BSP contains bootable live images, which can be used to directly
82boot Yocto off of a USB flash drive.
83
84Under Linux, insert a USB flash drive. Assuming the USB flash drive
85takes device /dev/sdf, use dd to copy the live image to it. For
86example:
87
88# dd if=core-image-sato-cedartrail-20120105232035.hddimg of=/dev/sdf
89# sync
90# eject /dev/sdf
91
92This should give you a bootable USB flash device. Insert the device
93into a bootable USB socket on the target, and power on. This should
94result in a system booted to the Sato graphical desktop.
95
96If you want a terminal, use the arrows at the top of the UI to move to
97different pages of available applications, one of which is named
98'Terminal'. Clicking that should give you a root terminal.
99
100If you want to ssh into the system, you can use the root terminal to
101ifconfig the IP address and use that to ssh in. The root password is
102empty, so to log in type 'root' for the user name and hit 'Enter' at
103the Password prompt: and you should be in.
104
105----
106
107If you find you're getting corrupt images on the USB (it doesn't show
108the syslinux boot: prompt, or the boot: prompt contains strange
109characters), try doing this first:
110
111# dd if=/dev/zero of=/dev/sdf bs=1M count=512
diff --git a/meta-cedartrail/README.sources b/meta-cedartrail/README.sources
new file mode 100755
index 00000000..8e006fb1
--- /dev/null
+++ b/meta-cedartrail/README.sources
@@ -0,0 +1,17 @@
1The sources for the packages comprising the images shipped with this
2BSP can be found at the following location:
3
4http://downloads.yoctoproject.org/mirror/sources/
5
6The metadata used to generate the images shipped with this BSP, in
7addition to the code contained in this BSP, can be found at the
8following location:
9
10http://www.yoctoproject.org/downloads/yocto-1.1/poky-edison-6.0.tar.bz2
11
12The metadata used to generate the images shipped with this BSP, in
13addition to the code contained in this BSP, can also be found at the
14following locations:
15
16git://git.yoctoproject.org/poky.git
17git://git.yoctoproject.org/meta-intel
diff --git a/meta-cedartrail/binary/.gitignore b/meta-cedartrail/binary/.gitignore
new file mode 100644
index 00000000..e69de29b
--- /dev/null
+++ b/meta-cedartrail/binary/.gitignore
diff --git a/meta-cedartrail/conf/layer.conf b/meta-cedartrail/conf/layer.conf
new file mode 100644
index 00000000..cb4142d0
--- /dev/null
+++ b/meta-cedartrail/conf/layer.conf
@@ -0,0 +1,10 @@
1# We have a conf and classes directory, add to BBPATH
2BBPATH := "${BBPATH}:${LAYERDIR}"
3
4# We have a recipes directory, add to BBFILES
5BBFILES := "${BBFILES} ${LAYERDIR}/recipes-*/*/*.bb \
6 ${LAYERDIR}/recipes-*/*/*.bbappend"
7
8BBFILE_COLLECTIONS += "cedartrail"
9BBFILE_PATTERN_cedartrail := "^${LAYERDIR}/"
10BBFILE_PRIORITY_cedartrail = "6"
diff --git a/meta-cedartrail/conf/machine/cedartrail.conf b/meta-cedartrail/conf/machine/cedartrail.conf
new file mode 100644
index 00000000..ec84347f
--- /dev/null
+++ b/meta-cedartrail/conf/machine/cedartrail.conf
@@ -0,0 +1,15 @@
1#@TYPE: Machine
2#@NAME: Cedartrail
3
4#@DESCRIPTION: Machine configuration for Cedartrail systems
5# i.e. Cedarview processor + Tiger Point Chipset
6
7include conf/machine/include/tune-atom.inc
8require conf/machine/include/ia32-base.inc
9
10XSERVER ?= "${XSERVER_IA32_BASE} \
11 ${XSERVER_IA32_EXT} \
12 ${XSERVER_IA32_VESA} \
13 "
14
15APPEND += "video=vesafb vga=0x318"
diff --git a/meta-cedartrail/recipes-bsp/formfactor/formfactor/cedartrail/machconfig b/meta-cedartrail/recipes-bsp/formfactor/formfactor/cedartrail/machconfig
new file mode 100644
index 00000000..ffce0122
--- /dev/null
+++ b/meta-cedartrail/recipes-bsp/formfactor/formfactor/cedartrail/machconfig
@@ -0,0 +1,3 @@
1# Assume a USB mouse and keyboard are connected
2HAVE_TOUCHSCREEN=0
3HAVE_KEYBOARD=1
diff --git a/meta-cedartrail/recipes-bsp/formfactor/formfactor_0.0.bbappend b/meta-cedartrail/recipes-bsp/formfactor/formfactor_0.0.bbappend
new file mode 100644
index 00000000..54da0ffd
--- /dev/null
+++ b/meta-cedartrail/recipes-bsp/formfactor/formfactor_0.0.bbappend
@@ -0,0 +1,3 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3PRINC = "1"
diff --git a/meta-cedartrail/recipes-core/tasks/task-core-tools.bbappend b/meta-cedartrail/recipes-core/tasks/task-core-tools.bbappend
new file mode 100644
index 00000000..e972712d
--- /dev/null
+++ b/meta-cedartrail/recipes-core/tasks/task-core-tools.bbappend
@@ -0,0 +1,2 @@
1RRECOMMENDS_task-core-tools-profile_append_cedartrail = " systemtap"
2
diff --git a/meta-cedartrail/recipes-graphics/xorg-xserver/xserver-xf86-config/cedartrail/xorg.conf b/meta-cedartrail/recipes-graphics/xorg-xserver/xserver-xf86-config/cedartrail/xorg.conf
new file mode 100644
index 00000000..da4fc3c6
--- /dev/null
+++ b/meta-cedartrail/recipes-graphics/xorg-xserver/xserver-xf86-config/cedartrail/xorg.conf
@@ -0,0 +1,26 @@
1Section "Device"
2 Identifier "Generic VESA"
3 Driver "vesa"
4EndSection
5
6Section "Monitor"
7 Identifier "Generic Monitor"
8 Option "DPMS"
9EndSection
10
11Section "Screen"
12 Identifier "Default Screen"
13 Device "Generic VESA"
14 Monitor "Generic Monitor"
15 DefaultDepth 24
16EndSection
17
18Section "ServerLayout"
19 Identifier "Default Layout"
20 Screen "Default Screen"
21EndSection
22
23Section "ServerFlags"
24 Option "DontZap" "0"
25 Option "AutoAddDevices" "False"
26EndSection
diff --git a/meta-cedartrail/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend b/meta-cedartrail/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend
new file mode 100644
index 00000000..4b8d0e65
--- /dev/null
+++ b/meta-cedartrail/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend
@@ -0,0 +1,3 @@
1THISDIR := "${@os.path.dirname(bb.data.getVar('FILE', d, True))}"
2FILESPATH =. "${@base_set_filespath(["${THISDIR}/${PN}"], d)}:"
3
diff --git a/meta-cedartrail/recipes-kernel/linux/linux-yocto-rt_3.0.bbappend b/meta-cedartrail/recipes-kernel/linux/linux-yocto-rt_3.0.bbappend
new file mode 100644
index 00000000..372b1392
--- /dev/null
+++ b/meta-cedartrail/recipes-kernel/linux/linux-yocto-rt_3.0.bbappend
@@ -0,0 +1,8 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2COMPATIBLE_MACHINE_cedartrail = "cedartrail"
3KMACHINE_cedartrail = "cedartrail"
4
5# Update the following to use a different BSP branch or meta SRCREV
6#KBRANCH_cedartrail = "yocto/standard/preempt-rt/base"
7#SRCREV_machine_pn-linux-yocto-rt_cedartrail ?= XXXX
8#SRCREV_meta_pn-linux-yocto-rt_cedartrail ?= XXXX
diff --git a/meta-cedartrail/recipes-kernel/linux/linux-yocto_3.0.bbappend b/meta-cedartrail/recipes-kernel/linux/linux-yocto_3.0.bbappend
new file mode 100644
index 00000000..44cd4e89
--- /dev/null
+++ b/meta-cedartrail/recipes-kernel/linux/linux-yocto_3.0.bbappend
@@ -0,0 +1,8 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3COMPATIBLE_MACHINE_cedartrail = "cedartrail"
4KMACHINE_cedartrail = "yocto/standard/cedartrail"
5KERNEL_FEATURES_append_cedartrail += " cfg/smp.scc"
6
7SRCREV_machine_pn-linux-yocto_cedartrail ?= "153cb7313697f6638109ed6ce40009af353eeb94"
8SRCREV_meta_pn-linux-yocto_cedartrail ?= "67ce7623909cef63927fd145026aaf371cf4abf1"