summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDarren Hart <dvhart@linux.intel.com>2012-05-25 14:35:27 -0700
committerDarren Hart <dvhart@linux.intel.com>2012-05-25 15:08:18 -0700
commitedaef395dac10a1b2c405f2f5d47798d795d7687 (patch)
tree6ad8e68553a3312d59ffc06d0845d67c0202808e
parentcaa0042ec0042bb4d4f48ac2a4722af9e52469c1 (diff)
downloadmeta-intel-edaef395dac10a1b2c405f2f5d47798d795d7687.tar.gz
fri2: Add alsa-state initial state
The FRI2 has an analog and digital playback device. Enable both by default. Enable line-in capture. Signed-off-by: Darren Hart <dvhart@linux.intel.com>
-rw-r--r--meta-fri2/recipes-bsp/alsa-state/alsa-state.bbappend1
-rw-r--r--meta-fri2/recipes-bsp/alsa-state/alsa-state/fri2-noemgd/asound.state411
-rw-r--r--meta-fri2/recipes-bsp/alsa-state/alsa-state/fri2/asound.state411
3 files changed, 823 insertions, 0 deletions
diff --git a/meta-fri2/recipes-bsp/alsa-state/alsa-state.bbappend b/meta-fri2/recipes-bsp/alsa-state/alsa-state.bbappend
new file mode 100644
index 00000000..72d991c7
--- /dev/null
+++ b/meta-fri2/recipes-bsp/alsa-state/alsa-state.bbappend
@@ -0,0 +1 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
diff --git a/meta-fri2/recipes-bsp/alsa-state/alsa-state/fri2-noemgd/asound.state b/meta-fri2/recipes-bsp/alsa-state/alsa-state/fri2-noemgd/asound.state
new file mode 100644
index 00000000..8a89f0bc
--- /dev/null
+++ b/meta-fri2/recipes-bsp/alsa-state/alsa-state/fri2-noemgd/asound.state
@@ -0,0 +1,411 @@
1state.MID {
2 control.1 {
3 iface MIXER
4 name 'PCM Playback Volume'
5 value.0 24
6 value.1 24
7 comment {
8 access 'read write'
9 type INTEGER
10 count 2
11 range '0 - 30'
12 dbmin -4500
13 dbmax 0
14 dbvalue.0 -900
15 dbvalue.1 -900
16 }
17 }
18 control.2 {
19 iface MIXER
20 name 'PCM Playback Switch'
21 value.0 true
22 value.1 true
23 comment {
24 access 'read write'
25 type BOOLEAN
26 count 2
27 }
28 }
29 control.3 {
30 iface MIXER
31 name 'Headphone Playback Volume'
32 value.0 0
33 value.1 0
34 comment {
35 access 'read write'
36 type INTEGER
37 count 2
38 range '0 - 30'
39 dbmin -4500
40 dbmax 0
41 dbvalue.0 -4500
42 dbvalue.1 -4500
43 }
44 }
45 control.4 {
46 iface MIXER
47 name 'Headphone Playback Switch'
48 value.0 false
49 value.1 false
50 comment {
51 access 'read write'
52 type BOOLEAN
53 count 2
54 }
55 }
56 control.5 {
57 iface MIXER
58 name 'Rear Mic Playback Volume'
59 value.0 0
60 value.1 0
61 comment {
62 access 'read write'
63 type INTEGER
64 count 2
65 range '0 - 31'
66 dbmin -3450
67 dbmax 1200
68 dbvalue.0 -3450
69 dbvalue.1 -3450
70 }
71 }
72 control.6 {
73 iface MIXER
74 name 'Rear Mic Playback Switch'
75 value.0 false
76 value.1 false
77 comment {
78 access 'read write'
79 type BOOLEAN
80 count 2
81 }
82 }
83 control.7 {
84 iface MIXER
85 name 'Front Mic Playback Volume'
86 value.0 0
87 value.1 0
88 comment {
89 access 'read write'
90 type INTEGER
91 count 2
92 range '0 - 31'
93 dbmin -3450
94 dbmax 1200
95 dbvalue.0 -3450
96 dbvalue.1 -3450
97 }
98 }
99 control.8 {
100 iface MIXER
101 name 'Front Mic Playback Switch'
102 value.0 false
103 value.1 false
104 comment {
105 access 'read write'
106 type BOOLEAN
107 count 2
108 }
109 }
110 control.9 {
111 iface MIXER
112 name 'Line Playback Volume'
113 value.0 0
114 value.1 0
115 comment {
116 access 'read write'
117 type INTEGER
118 count 2
119 range '0 - 31'
120 dbmin -3450
121 dbmax 1200
122 dbvalue.0 -3450
123 dbvalue.1 -3450
124 }
125 }
126 control.10 {
127 iface MIXER
128 name 'Line Playback Switch'
129 value.0 false
130 value.1 false
131 comment {
132 access 'read write'
133 type BOOLEAN
134 count 2
135 }
136 }
137 control.11 {
138 iface MIXER
139 name 'CD Playback Volume'
140 value.0 0
141 value.1 0
142 comment {
143 access 'read write'
144 type INTEGER
145 count 2
146 range '0 - 31'
147 dbmin -3450
148 dbmax 1200
149 dbvalue.0 -3450
150 dbvalue.1 -3450
151 }
152 }
153 control.12 {
154 iface MIXER
155 name 'CD Playback Switch'
156 value.0 false
157 value.1 false
158 comment {
159 access 'read write'
160 type BOOLEAN
161 count 2
162 }
163 }
164 control.13 {
165 iface MIXER
166 name 'Auto-Mute Mode'
167 value Disabled
168 comment {
169 access 'read write'
170 type ENUMERATED
171 count 1
172 item.0 Disabled
173 item.1 Enabled
174 }
175 }
176 control.14 {
177 iface MIXER
178 name 'Rear Mic Boost Volume'
179 value.0 0
180 value.1 0
181 comment {
182 access 'read write'
183 type INTEGER
184 count 2
185 range '0 - 3'
186 dbmin 0
187 dbmax 3000
188 dbvalue.0 0
189 dbvalue.1 0
190 }
191 }
192 control.15 {
193 iface MIXER
194 name 'Front Mic Boost Volume'
195 value.0 0
196 value.1 0
197 comment {
198 access 'read write'
199 type INTEGER
200 count 2
201 range '0 - 3'
202 dbmin 0
203 dbmax 3000
204 dbvalue.0 0
205 dbvalue.1 0
206 }
207 }
208 control.16 {
209 iface MIXER
210 name 'Capture Switch'
211 value.0 true
212 value.1 true
213 comment {
214 access 'read write'
215 type BOOLEAN
216 count 2
217 }
218 }
219 control.17 {
220 iface MIXER
221 name 'Capture Switch'
222 index 1
223 value.0 false
224 value.1 false
225 comment {
226 access 'read write'
227 type BOOLEAN
228 count 2
229 }
230 }
231 control.18 {
232 iface MIXER
233 name 'Capture Switch'
234 index 2
235 value.0 false
236 value.1 false
237 comment {
238 access 'read write'
239 type BOOLEAN
240 count 2
241 }
242 }
243 control.19 {
244 iface MIXER
245 name 'Capture Volume'
246 value.0 25
247 value.1 25
248 comment {
249 access 'read write'
250 type INTEGER
251 count 2
252 range '0 - 31'
253 dbmin -1200
254 dbmax 3450
255 dbvalue.0 2550
256 dbvalue.1 2550
257 }
258 }
259 control.20 {
260 iface MIXER
261 name 'Capture Volume'
262 index 1
263 value.0 0
264 value.1 0
265 comment {
266 access 'read write'
267 type INTEGER
268 count 2
269 range '0 - 31'
270 dbmin -1200
271 dbmax 3450
272 dbvalue.0 -1200
273 dbvalue.1 -1200
274 }
275 }
276 control.21 {
277 iface MIXER
278 name 'Capture Volume'
279 index 2
280 value.0 0
281 value.1 0
282 comment {
283 access 'read write'
284 type INTEGER
285 count 2
286 range '0 - 31'
287 dbmin -1200
288 dbmax 3450
289 dbvalue.0 -1200
290 dbvalue.1 -1200
291 }
292 }
293 control.22 {
294 iface MIXER
295 name 'Input Source'
296 value Line
297 comment {
298 access 'read write'
299 type ENUMERATED
300 count 1
301 item.0 'Rear Mic'
302 item.1 'Front Mic'
303 item.2 Line
304 item.3 CD
305 }
306 }
307 control.23 {
308 iface MIXER
309 name 'Input Source'
310 index 1
311 value 'Rear Mic'
312 comment {
313 access 'read write'
314 type ENUMERATED
315 count 1
316 item.0 'Rear Mic'
317 item.1 'Front Mic'
318 item.2 Line
319 item.3 CD
320 }
321 }
322 control.24 {
323 iface MIXER
324 name 'Input Source'
325 index 2
326 value 'Rear Mic'
327 comment {
328 access 'read write'
329 type ENUMERATED
330 count 1
331 item.0 'Rear Mic'
332 item.1 'Front Mic'
333 item.2 Line
334 item.3 CD
335 }
336 }
337 control.25 {
338 iface MIXER
339 name 'IEC958 Playback Con Mask'
340 value '0fff000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000'
341 comment {
342 access read
343 type IEC958
344 count 1
345 }
346 }
347 control.26 {
348 iface MIXER
349 name 'IEC958 Playback Pro Mask'
350 value '0f00000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000'
351 comment {
352 access read
353 type IEC958
354 count 1
355 }
356 }
357 control.27 {
358 iface MIXER
359 name 'IEC958 Playback Default'
360 value '0400000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000'
361 comment {
362 access 'read write'
363 type IEC958
364 count 1
365 }
366 }
367 control.28 {
368 iface MIXER
369 name 'IEC958 Playback Switch'
370 value true
371 comment {
372 access 'read write'
373 type BOOLEAN
374 count 1
375 }
376 }
377 control.29 {
378 iface MIXER
379 name 'IEC958 Default PCM Playback Switch'
380 value true
381 comment {
382 access 'read write'
383 type BOOLEAN
384 count 1
385 }
386 }
387 control.30 {
388 iface MIXER
389 name 'Master Playback Volume'
390 value 24
391 comment {
392 access 'read write'
393 type INTEGER
394 count 1
395 range '0 - 30'
396 dbmin -4500
397 dbmax 0
398 dbvalue.0 -900
399 }
400 }
401 control.31 {
402 iface MIXER
403 name 'Master Playback Switch'
404 value true
405 comment {
406 access 'read write'
407 type BOOLEAN
408 count 1
409 }
410 }
411}
diff --git a/meta-fri2/recipes-bsp/alsa-state/alsa-state/fri2/asound.state b/meta-fri2/recipes-bsp/alsa-state/alsa-state/fri2/asound.state
new file mode 100644
index 00000000..8a89f0bc
--- /dev/null
+++ b/meta-fri2/recipes-bsp/alsa-state/alsa-state/fri2/asound.state
@@ -0,0 +1,411 @@
1state.MID {
2 control.1 {
3 iface MIXER
4 name 'PCM Playback Volume'
5 value.0 24
6 value.1 24
7 comment {
8 access 'read write'
9 type INTEGER
10 count 2
11 range '0 - 30'
12 dbmin -4500
13 dbmax 0
14 dbvalue.0 -900
15 dbvalue.1 -900
16 }
17 }
18 control.2 {
19 iface MIXER
20 name 'PCM Playback Switch'
21 value.0 true
22 value.1 true
23 comment {
24 access 'read write'
25 type BOOLEAN
26 count 2
27 }
28 }
29 control.3 {
30 iface MIXER
31 name 'Headphone Playback Volume'
32 value.0 0
33 value.1 0
34 comment {
35 access 'read write'
36 type INTEGER
37 count 2
38 range '0 - 30'
39 dbmin -4500
40 dbmax 0
41 dbvalue.0 -4500
42 dbvalue.1 -4500
43 }
44 }
45 control.4 {
46 iface MIXER
47 name 'Headphone Playback Switch'
48 value.0 false
49 value.1 false
50 comment {
51 access 'read write'
52 type BOOLEAN
53 count 2
54 }
55 }
56 control.5 {
57 iface MIXER
58 name 'Rear Mic Playback Volume'
59 value.0 0
60 value.1 0
61 comment {
62 access 'read write'
63 type INTEGER
64 count 2
65 range '0 - 31'
66 dbmin -3450
67 dbmax 1200
68 dbvalue.0 -3450
69 dbvalue.1 -3450
70 }
71 }
72 control.6 {
73 iface MIXER
74 name 'Rear Mic Playback Switch'
75 value.0 false
76 value.1 false
77 comment {
78 access 'read write'
79 type BOOLEAN
80 count 2
81 }
82 }
83 control.7 {
84 iface MIXER
85 name 'Front Mic Playback Volume'
86 value.0 0
87 value.1 0
88 comment {
89 access 'read write'
90 type INTEGER
91 count 2
92 range '0 - 31'
93 dbmin -3450
94 dbmax 1200
95 dbvalue.0 -3450
96 dbvalue.1 -3450
97 }
98 }
99 control.8 {
100 iface MIXER
101 name 'Front Mic Playback Switch'
102 value.0 false
103 value.1 false
104 comment {
105 access 'read write'
106 type BOOLEAN
107 count 2
108 }
109 }
110 control.9 {
111 iface MIXER
112 name 'Line Playback Volume'
113 value.0 0
114 value.1 0
115 comment {
116 access 'read write'
117 type INTEGER
118 count 2
119 range '0 - 31'
120 dbmin -3450
121 dbmax 1200
122 dbvalue.0 -3450
123 dbvalue.1 -3450
124 }
125 }
126 control.10 {
127 iface MIXER
128 name 'Line Playback Switch'
129 value.0 false
130 value.1 false
131 comment {
132 access 'read write'
133 type BOOLEAN
134 count 2
135 }
136 }
137 control.11 {
138 iface MIXER
139 name 'CD Playback Volume'
140 value.0 0
141 value.1 0
142 comment {
143 access 'read write'
144 type INTEGER
145 count 2
146 range '0 - 31'
147 dbmin -3450
148 dbmax 1200
149 dbvalue.0 -3450
150 dbvalue.1 -3450
151 }
152 }
153 control.12 {
154 iface MIXER
155 name 'CD Playback Switch'
156 value.0 false
157 value.1 false
158 comment {
159 access 'read write'
160 type BOOLEAN
161 count 2
162 }
163 }
164 control.13 {
165 iface MIXER
166 name 'Auto-Mute Mode'
167 value Disabled
168 comment {
169 access 'read write'
170 type ENUMERATED
171 count 1
172 item.0 Disabled
173 item.1 Enabled
174 }
175 }
176 control.14 {
177 iface MIXER
178 name 'Rear Mic Boost Volume'
179 value.0 0
180 value.1 0
181 comment {
182 access 'read write'
183 type INTEGER
184 count 2
185 range '0 - 3'
186 dbmin 0
187 dbmax 3000
188 dbvalue.0 0
189 dbvalue.1 0
190 }
191 }
192 control.15 {
193 iface MIXER
194 name 'Front Mic Boost Volume'
195 value.0 0
196 value.1 0
197 comment {
198 access 'read write'
199 type INTEGER
200 count 2
201 range '0 - 3'
202 dbmin 0
203 dbmax 3000
204 dbvalue.0 0
205 dbvalue.1 0
206 }
207 }
208 control.16 {
209 iface MIXER
210 name 'Capture Switch'
211 value.0 true
212 value.1 true
213 comment {
214 access 'read write'
215 type BOOLEAN
216 count 2
217 }
218 }
219 control.17 {
220 iface MIXER
221 name 'Capture Switch'
222 index 1
223 value.0 false
224 value.1 false
225 comment {
226 access 'read write'
227 type BOOLEAN
228 count 2
229 }
230 }
231 control.18 {
232 iface MIXER
233 name 'Capture Switch'
234 index 2
235 value.0 false
236 value.1 false
237 comment {
238 access 'read write'
239 type BOOLEAN
240 count 2
241 }
242 }
243 control.19 {
244 iface MIXER
245 name 'Capture Volume'
246 value.0 25
247 value.1 25
248 comment {
249 access 'read write'
250 type INTEGER
251 count 2
252 range '0 - 31'
253 dbmin -1200
254 dbmax 3450
255 dbvalue.0 2550
256 dbvalue.1 2550
257 }
258 }
259 control.20 {
260 iface MIXER
261 name 'Capture Volume'
262 index 1
263 value.0 0
264 value.1 0
265 comment {
266 access 'read write'
267 type INTEGER
268 count 2
269 range '0 - 31'
270 dbmin -1200
271 dbmax 3450
272 dbvalue.0 -1200
273 dbvalue.1 -1200
274 }
275 }
276 control.21 {
277 iface MIXER
278 name 'Capture Volume'
279 index 2
280 value.0 0
281 value.1 0
282 comment {
283 access 'read write'
284 type INTEGER
285 count 2
286 range '0 - 31'
287 dbmin -1200
288 dbmax 3450
289 dbvalue.0 -1200
290 dbvalue.1 -1200
291 }
292 }
293 control.22 {
294 iface MIXER
295 name 'Input Source'
296 value Line
297 comment {
298 access 'read write'
299 type ENUMERATED
300 count 1
301 item.0 'Rear Mic'
302 item.1 'Front Mic'
303 item.2 Line
304 item.3 CD
305 }
306 }
307 control.23 {
308 iface MIXER
309 name 'Input Source'
310 index 1
311 value 'Rear Mic'
312 comment {
313 access 'read write'
314 type ENUMERATED
315 count 1
316 item.0 'Rear Mic'
317 item.1 'Front Mic'
318 item.2 Line
319 item.3 CD
320 }
321 }
322 control.24 {
323 iface MIXER
324 name 'Input Source'
325 index 2
326 value 'Rear Mic'
327 comment {
328 access 'read write'
329 type ENUMERATED
330 count 1
331 item.0 'Rear Mic'
332 item.1 'Front Mic'
333 item.2 Line
334 item.3 CD
335 }
336 }
337 control.25 {
338 iface MIXER
339 name 'IEC958 Playback Con Mask'
340 value '0fff000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000'
341 comment {
342 access read
343 type IEC958
344 count 1
345 }
346 }
347 control.26 {
348 iface MIXER
349 name 'IEC958 Playback Pro Mask'
350 value '0f00000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000'
351 comment {
352 access read
353 type IEC958
354 count 1
355 }
356 }
357 control.27 {
358 iface MIXER
359 name 'IEC958 Playback Default'
360 value '0400000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000'
361 comment {
362 access 'read write'
363 type IEC958
364 count 1
365 }
366 }
367 control.28 {
368 iface MIXER
369 name 'IEC958 Playback Switch'
370 value true
371 comment {
372 access 'read write'
373 type BOOLEAN
374 count 1
375 }
376 }
377 control.29 {
378 iface MIXER
379 name 'IEC958 Default PCM Playback Switch'
380 value true
381 comment {
382 access 'read write'
383 type BOOLEAN
384 count 1
385 }
386 }
387 control.30 {
388 iface MIXER
389 name 'Master Playback Volume'
390 value 24
391 comment {
392 access 'read write'
393 type INTEGER
394 count 1
395 range '0 - 30'
396 dbmin -4500
397 dbmax 0
398 dbvalue.0 -900
399 }
400 }
401 control.31 {
402 iface MIXER
403 name 'Master Playback Switch'
404 value true
405 comment {
406 access 'read write'
407 type BOOLEAN
408 count 1
409 }
410 }
411}