summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-02-24 09:23:56 +0000
committerTom Zanussi <tom.zanussi@intel.com>2012-02-24 14:52:01 -0600
commitdf18b721f86f0737c0f302e49b27ea232c70e683 (patch)
tree61dd9f13867b087528122e1db2fc5a2a4ed55ada
parentf89c24addde4f5d4a634a7be6a33bee91c1f1bc4 (diff)
downloadmeta-intel-df18b721f86f0737c0f302e49b27ea232c70e683.tar.gz
meta-intel: add LAYERDEPENDS for layers needing the meta-intel common layer1.2_M3.rc11.2_M3
These layers all contain machine configuration that depends on having the meta-intel common layer enabled as well, so use LAYERDEPENDS in the layer configuration for each one to make this explicit. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
-rw-r--r--meta-cedartrail/conf/layer.conf2
-rw-r--r--meta-crownbay/conf/layer.conf2
-rw-r--r--meta-emenlow/conf/layer.conf2
-rw-r--r--meta-fishriver/conf/layer.conf2
-rw-r--r--meta-fri2/conf/layer.conf2
-rw-r--r--meta-jasperforest/conf/layer.conf2
-rw-r--r--meta-n450/conf/layer.conf2
-rw-r--r--meta-romley/conf/layer.conf2
-rw-r--r--meta-sugarbay/conf/layer.conf2
-rw-r--r--meta-sys940x/conf/layer.conf2
10 files changed, 20 insertions, 0 deletions
diff --git a/meta-cedartrail/conf/layer.conf b/meta-cedartrail/conf/layer.conf
index cb4142d0..c19c4c10 100644
--- a/meta-cedartrail/conf/layer.conf
+++ b/meta-cedartrail/conf/layer.conf
@@ -8,3 +8,5 @@ BBFILES := "${BBFILES} ${LAYERDIR}/recipes-*/*/*.bb \
8BBFILE_COLLECTIONS += "cedartrail" 8BBFILE_COLLECTIONS += "cedartrail"
9BBFILE_PATTERN_cedartrail := "^${LAYERDIR}/" 9BBFILE_PATTERN_cedartrail := "^${LAYERDIR}/"
10BBFILE_PRIORITY_cedartrail = "6" 10BBFILE_PRIORITY_cedartrail = "6"
11
12LAYERDEPENDS_cedartrail = "intel"
diff --git a/meta-crownbay/conf/layer.conf b/meta-crownbay/conf/layer.conf
index 52581e1c..cb17298f 100644
--- a/meta-crownbay/conf/layer.conf
+++ b/meta-crownbay/conf/layer.conf
@@ -8,3 +8,5 @@ BBFILES := "${BBFILES} ${LAYERDIR}/recipes-*/*/*.bb \
8BBFILE_COLLECTIONS += "crownbay" 8BBFILE_COLLECTIONS += "crownbay"
9BBFILE_PATTERN_crownbay := "^${LAYERDIR}/" 9BBFILE_PATTERN_crownbay := "^${LAYERDIR}/"
10BBFILE_PRIORITY_crownbay = "6" 10BBFILE_PRIORITY_crownbay = "6"
11
12LAYERDEPENDS_crownbay = "intel"
diff --git a/meta-emenlow/conf/layer.conf b/meta-emenlow/conf/layer.conf
index 563b9c8e..dda80c0e 100644
--- a/meta-emenlow/conf/layer.conf
+++ b/meta-emenlow/conf/layer.conf
@@ -8,3 +8,5 @@ BBFILES := "${BBFILES} ${LAYERDIR}/recipes-*/*/*.bb \
8BBFILE_COLLECTIONS += "emenlow" 8BBFILE_COLLECTIONS += "emenlow"
9BBFILE_PATTERN_emenlow := "^${LAYERDIR}/" 9BBFILE_PATTERN_emenlow := "^${LAYERDIR}/"
10BBFILE_PRIORITY_emenlow = "6" 10BBFILE_PRIORITY_emenlow = "6"
11
12LAYERDEPENDS_emenlow = "intel"
diff --git a/meta-fishriver/conf/layer.conf b/meta-fishriver/conf/layer.conf
index 9162b5ef..61e292be 100644
--- a/meta-fishriver/conf/layer.conf
+++ b/meta-fishriver/conf/layer.conf
@@ -8,3 +8,5 @@ BBFILES := "${BBFILES} ${LAYERDIR}/recipes-*/*/*.bb \
8BBFILE_COLLECTIONS += "fishriver" 8BBFILE_COLLECTIONS += "fishriver"
9BBFILE_PATTERN_fishriver := "^${LAYERDIR}/" 9BBFILE_PATTERN_fishriver := "^${LAYERDIR}/"
10BBFILE_PRIORITY_fishriver = "6" 10BBFILE_PRIORITY_fishriver = "6"
11
12LAYERDEPENDS_fishriver = "intel"
diff --git a/meta-fri2/conf/layer.conf b/meta-fri2/conf/layer.conf
index b30e776f..4d140f96 100644
--- a/meta-fri2/conf/layer.conf
+++ b/meta-fri2/conf/layer.conf
@@ -8,3 +8,5 @@ BBFILES := "${BBFILES} ${LAYERDIR}/recipes-*/*/*.bb \
8BBFILE_COLLECTIONS += "fri2" 8BBFILE_COLLECTIONS += "fri2"
9BBFILE_PATTERN_fri2 := "^${LAYERDIR}/" 9BBFILE_PATTERN_fri2 := "^${LAYERDIR}/"
10BBFILE_PRIORITY_fri2 = "6" 10BBFILE_PRIORITY_fri2 = "6"
11
12LAYERDEPENDS_fri2 = "intel"
diff --git a/meta-jasperforest/conf/layer.conf b/meta-jasperforest/conf/layer.conf
index bfd7fc3c..09f1647a 100644
--- a/meta-jasperforest/conf/layer.conf
+++ b/meta-jasperforest/conf/layer.conf
@@ -8,3 +8,5 @@ BBFILES := "${BBFILES} ${LAYERDIR}/recipes-*/*/*.bb \
8BBFILE_COLLECTIONS += "jasperforest" 8BBFILE_COLLECTIONS += "jasperforest"
9BBFILE_PATTERN_jasperforest := "^${LAYERDIR}/" 9BBFILE_PATTERN_jasperforest := "^${LAYERDIR}/"
10BBFILE_PRIORITY_jasperforest = "6" 10BBFILE_PRIORITY_jasperforest = "6"
11
12LAYERDEPENDS_jasperforest = "intel"
diff --git a/meta-n450/conf/layer.conf b/meta-n450/conf/layer.conf
index f9cc7fe0..2c905c27 100644
--- a/meta-n450/conf/layer.conf
+++ b/meta-n450/conf/layer.conf
@@ -8,3 +8,5 @@ BBFILES := "${BBFILES} ${LAYERDIR}/recipes-*/*/*.bb \
8BBFILE_COLLECTIONS += "n450" 8BBFILE_COLLECTIONS += "n450"
9BBFILE_PATTERN_n450 = "^${LAYERDIR}/" 9BBFILE_PATTERN_n450 = "^${LAYERDIR}/"
10BBFILE_PRIORITY_n450 = "6" 10BBFILE_PRIORITY_n450 = "6"
11
12LAYERDEPENDS_n450 = "intel"
diff --git a/meta-romley/conf/layer.conf b/meta-romley/conf/layer.conf
index c5eeaaba..8ce1a4db 100644
--- a/meta-romley/conf/layer.conf
+++ b/meta-romley/conf/layer.conf
@@ -8,3 +8,5 @@ BBFILES := "${BBFILES} ${LAYERDIR}/recipes-*/*/*.bb \
8BBFILE_COLLECTIONS += "romley" 8BBFILE_COLLECTIONS += "romley"
9BBFILE_PATTERN_romley := "^${LAYERDIR}/" 9BBFILE_PATTERN_romley := "^${LAYERDIR}/"
10BBFILE_PRIORITY_romley = "6" 10BBFILE_PRIORITY_romley = "6"
11
12LAYERDEPENDS_romley = "intel"
diff --git a/meta-sugarbay/conf/layer.conf b/meta-sugarbay/conf/layer.conf
index 05ef1cd3..eb8ec45e 100644
--- a/meta-sugarbay/conf/layer.conf
+++ b/meta-sugarbay/conf/layer.conf
@@ -8,3 +8,5 @@ BBFILES := "${BBFILES} ${LAYERDIR}/recipes-*/*/*.bb \
8BBFILE_COLLECTIONS += "sugarbay" 8BBFILE_COLLECTIONS += "sugarbay"
9BBFILE_PATTERN_sugarbay := "^${LAYERDIR}/" 9BBFILE_PATTERN_sugarbay := "^${LAYERDIR}/"
10BBFILE_PRIORITY_sugarbay = "6" 10BBFILE_PRIORITY_sugarbay = "6"
11
12LAYERDEPENDS_sugarbay = "intel"
diff --git a/meta-sys940x/conf/layer.conf b/meta-sys940x/conf/layer.conf
index 459c7102..5d588ade 100644
--- a/meta-sys940x/conf/layer.conf
+++ b/meta-sys940x/conf/layer.conf
@@ -8,3 +8,5 @@ BBFILES := "${BBFILES} ${LAYERDIR}/recipes-*/*/*.bb \
8BBFILE_COLLECTIONS += "sys940x" 8BBFILE_COLLECTIONS += "sys940x"
9BBFILE_PATTERN_sys940x := "^${LAYERDIR}/" 9BBFILE_PATTERN_sys940x := "^${LAYERDIR}/"
10BBFILE_PRIORITY_sys940x = "6" 10BBFILE_PRIORITY_sys940x = "6"
11
12LAYERDEPENDS_sys940x = "intel"