summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2011-08-03 16:39:14 -0400
committerSaul Wold <sgw@linux.intel.com>2011-08-24 15:37:05 -0700
commitfb15cc4e1c4be75c81acaf6a1dd33675a9142975 (patch)
treeddee96e4ce1af65015b6107849d7e1e20b7beab2
parentf222033882ca011ed870eed29124ccf67ee27590 (diff)
downloadmeta-intel-fb15cc4e1c4be75c81acaf6a1dd33675a9142975.tar.gz
meta-tlk: initial creation
Call this layer whatever you want, but when enabled it turns on BSP configuration items specific to autobuild/official binary images. Once this is enabled the uptime of any BSP will be limted to the value in the .cfg. It is currently at 2 minutes as an example, but it should be extended to a number of days going forward. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> meta-tlk: Rename and changed to 10 day limit Signed-off-by: Saul Wold <sgw@linux.intel.com>
-rw-r--r--meta-tlk/README6
-rw-r--r--meta-tlk/conf/layer.conf6
-rw-r--r--meta-tlk/recipes-kernel/linux/linux-yocto/time-limited-kernel.cfg3
-rw-r--r--meta-tlk/recipes-kernel/linux/linux-yocto_3.0.bbappend4
4 files changed, 19 insertions, 0 deletions
diff --git a/meta-tlk/README b/meta-tlk/README
new file mode 100644
index 00000000..5ff4d3bc
--- /dev/null
+++ b/meta-tlk/README
@@ -0,0 +1,6 @@
1meta-autobuilder
2===============
3
4Contains recipe modifications required to produce the official
5yocto autobuild BSPs.
6
diff --git a/meta-tlk/conf/layer.conf b/meta-tlk/conf/layer.conf
new file mode 100644
index 00000000..9af646f0
--- /dev/null
+++ b/meta-tlk/conf/layer.conf
@@ -0,0 +1,6 @@
1# We have a conf and classes directory, add to BBPATH
2BBPATH := "${BBPATH}:${LAYERDIR}"
3
4# We have a packages directory, add to BBFILES
5BBFILES := "${BBFILES} ${LAYERDIR}/recipes-*/*/*.bb \
6 ${LAYERDIR}/recipes-*/*/*.bbappend"
diff --git a/meta-tlk/recipes-kernel/linux/linux-yocto/time-limited-kernel.cfg b/meta-tlk/recipes-kernel/linux/linux-yocto/time-limited-kernel.cfg
new file mode 100644
index 00000000..44f4beaa
--- /dev/null
+++ b/meta-tlk/recipes-kernel/linux/linux-yocto/time-limited-kernel.cfg
@@ -0,0 +1,3 @@
1CONFIG_UPTIME_LIMITED_KERNEL=y
2CONFIG_UPTIME_LIMIT_DURATION=14400
3CONFIG_UPTIME_LIMIT_KERNEL_REBOOT=y
diff --git a/meta-tlk/recipes-kernel/linux/linux-yocto_3.0.bbappend b/meta-tlk/recipes-kernel/linux/linux-yocto_3.0.bbappend
new file mode 100644
index 00000000..58a6541c
--- /dev/null
+++ b/meta-tlk/recipes-kernel/linux/linux-yocto_3.0.bbappend
@@ -0,0 +1,4 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3# enable the time limited kernel configuration options
4SRC_URI += "file://time-limited-kernel.cfg"