summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2013-03-21 14:50:11 -0700
committerTom Zanussi <tom.zanussi@intel.com>2013-03-21 16:03:46 -0500
commit3c5818c96fa3c62369311b7d91d54a9154e3b888 (patch)
tree53fbf1ff5ca7e4aabbf5b11bd44e776dd59cd9bd
parent98342e9e685ac8066f7fe2517fd382127a286648 (diff)
downloadmeta-intel-danny-8.0.1.tar.gz
layer.conf: Use .= for adding to BBPATH and += to BBFILESdanny-8.0.1
Fixes parsing errors which is appearing after this commit to meta-openembedded http://cgit.openembedded.org/meta-openembedded/commit/?id=3c21a46020bd0816579648f684c41dbd6333583e This triggers exception NameError: name 'base_contains' is not defined without this change Avoid the immediate expansion operator (:=) which caused base_contains added in the previous commit to fail to expand at the time the meta-intel layer configs are parsed and replace it with one of the append operators (.= or +=) that allows for delayed variable expansion. Signed-off-by: Khem Raj <raj.khem@gmail.com> Acked-by: Tom Zanussi <tom.zanussi@intel.com> Signed-off-by: Darren Hart <dvhart@linux.intel.com> Signed-off-by: Christopher Larson <chris_larson@mentor.com>
-rw-r--r--conf/layer.conf4
-rw-r--r--meta-cedartrail/conf/layer.conf4
-rw-r--r--meta-chiefriver/conf/layer.conf4
-rw-r--r--meta-crownbay/conf/layer.conf4
-rw-r--r--meta-crystalforest/conf/layer.conf4
-rw-r--r--meta-emenlow/conf/layer.conf4
-rw-r--r--meta-fri2/conf/layer.conf4
-rw-r--r--meta-jasperforest/conf/layer.conf4
-rw-r--r--meta-n450/conf/layer.conf4
-rw-r--r--meta-romley/conf/layer.conf4
-rw-r--r--meta-sugarbay/conf/layer.conf4
-rw-r--r--meta-sys940x/conf/layer.conf4
-rw-r--r--meta-tlk/conf/layer.conf4
13 files changed, 26 insertions, 26 deletions
diff --git a/conf/layer.conf b/conf/layer.conf
index e9c2b10a..31132ab0 100644
--- a/conf/layer.conf
+++ b/conf/layer.conf
@@ -1,8 +1,8 @@
1# We have a conf and classes directory, add to BBPATH 1# We have a conf and classes directory, add to BBPATH
2BBPATH := "${BBPATH}:${LAYERDIR}" 2BBPATH .= ":${LAYERDIR}"
3 3
4# We have recipes-* directories, add to BBFILES 4# We have recipes-* directories, add to BBFILES
5BBFILES := "${BBFILES} ${LAYERDIR}/common/recipes-*/*/*.bb \ 5BBFILES += "${LAYERDIR}/common/recipes-*/*/*.bb \
6 ${LAYERDIR}/common/recipes-*/*/*.bbappend" 6 ${LAYERDIR}/common/recipes-*/*/*.bbappend"
7 7
8BBFILE_COLLECTIONS += "intel" 8BBFILE_COLLECTIONS += "intel"
diff --git a/meta-cedartrail/conf/layer.conf b/meta-cedartrail/conf/layer.conf
index c19c4c10..0166b35c 100644
--- a/meta-cedartrail/conf/layer.conf
+++ b/meta-cedartrail/conf/layer.conf
@@ -1,8 +1,8 @@
1# We have a conf and classes directory, add to BBPATH 1# We have a conf and classes directory, add to BBPATH
2BBPATH := "${BBPATH}:${LAYERDIR}" 2BBPATH .= ":${LAYERDIR}"
3 3
4# We have a recipes directory, add to BBFILES 4# We have a recipes directory, add to BBFILES
5BBFILES := "${BBFILES} ${LAYERDIR}/recipes-*/*/*.bb \ 5BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
6 ${LAYERDIR}/recipes-*/*/*.bbappend" 6 ${LAYERDIR}/recipes-*/*/*.bbappend"
7 7
8BBFILE_COLLECTIONS += "cedartrail" 8BBFILE_COLLECTIONS += "cedartrail"
diff --git a/meta-chiefriver/conf/layer.conf b/meta-chiefriver/conf/layer.conf
index 5dc3c021..6164f995 100644
--- a/meta-chiefriver/conf/layer.conf
+++ b/meta-chiefriver/conf/layer.conf
@@ -1,8 +1,8 @@
1# We have a conf and classes directory, add to BBPATH 1# We have a conf and classes directory, add to BBPATH
2BBPATH := "${BBPATH}:${LAYERDIR}" 2BBPATH .= ":${LAYERDIR}"
3 3
4# We have a recipes directory, add to BBFILES 4# We have a recipes directory, add to BBFILES
5BBFILES := "${BBFILES} ${LAYERDIR}/recipes-*/*/*.bb \ 5BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
6 ${LAYERDIR}/recipes-*/*/*.bbappend" 6 ${LAYERDIR}/recipes-*/*/*.bbappend"
7 7
8BBFILE_COLLECTIONS += "chiefriver" 8BBFILE_COLLECTIONS += "chiefriver"
diff --git a/meta-crownbay/conf/layer.conf b/meta-crownbay/conf/layer.conf
index cb17298f..e6cc2a02 100644
--- a/meta-crownbay/conf/layer.conf
+++ b/meta-crownbay/conf/layer.conf
@@ -1,8 +1,8 @@
1# We have a conf and classes directory, add to BBPATH 1# We have a conf and classes directory, add to BBPATH
2BBPATH := "${BBPATH}:${LAYERDIR}" 2BBPATH .= ":${LAYERDIR}"
3 3
4# We have a recipes directory, add to BBFILES 4# We have a recipes directory, add to BBFILES
5BBFILES := "${BBFILES} ${LAYERDIR}/recipes-*/*/*.bb \ 5BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
6 ${LAYERDIR}/recipes-*/*/*.bbappend" 6 ${LAYERDIR}/recipes-*/*/*.bbappend"
7 7
8BBFILE_COLLECTIONS += "crownbay" 8BBFILE_COLLECTIONS += "crownbay"
diff --git a/meta-crystalforest/conf/layer.conf b/meta-crystalforest/conf/layer.conf
index 6b802d63..daa2ba7c 100644
--- a/meta-crystalforest/conf/layer.conf
+++ b/meta-crystalforest/conf/layer.conf
@@ -1,8 +1,8 @@
1# We have a conf and classes directory, add to BBPATH 1# We have a conf and classes directory, add to BBPATH
2BBPATH := "${BBPATH}:${LAYERDIR}" 2BBPATH .= ":${LAYERDIR}"
3 3
4# We have a recipes directory, add to BBFILES 4# We have a recipes directory, add to BBFILES
5BBFILES := "${BBFILES} ${LAYERDIR}/recipes-*/*/*.bb \ 5BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
6 ${LAYERDIR}/recipes-*/*/*.bbappend" 6 ${LAYERDIR}/recipes-*/*/*.bbappend"
7 7
8BBFILE_COLLECTIONS += "crystalforest" 8BBFILE_COLLECTIONS += "crystalforest"
diff --git a/meta-emenlow/conf/layer.conf b/meta-emenlow/conf/layer.conf
index a49ec47f..b5832e4f 100644
--- a/meta-emenlow/conf/layer.conf
+++ b/meta-emenlow/conf/layer.conf
@@ -1,8 +1,8 @@
1# We have a conf and classes directory, add to BBPATH 1# We have a conf and classes directory, add to BBPATH
2BBPATH := "${BBPATH}:${LAYERDIR}" 2BBPATH .= ":${LAYERDIR}"
3 3
4# We have recipes-* directories, add to BBFILES 4# We have recipes-* directories, add to BBFILES
5BBFILES := "${BBFILES} ${LAYERDIR}/recipes-*/*/*.bb \ 5BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
6 ${LAYERDIR}/recipes-*/*/*.bbappend" 6 ${LAYERDIR}/recipes-*/*/*.bbappend"
7 7
8BBFILE_COLLECTIONS += "emenlow" 8BBFILE_COLLECTIONS += "emenlow"
diff --git a/meta-fri2/conf/layer.conf b/meta-fri2/conf/layer.conf
index 4d140f96..0bb29a13 100644
--- a/meta-fri2/conf/layer.conf
+++ b/meta-fri2/conf/layer.conf
@@ -1,8 +1,8 @@
1# We have a conf and classes directory, add to BBPATH 1# We have a conf and classes directory, add to BBPATH
2BBPATH := "${BBPATH}:${LAYERDIR}" 2BBPATH .= ":${LAYERDIR}"
3 3
4# We have a recipes directory, add to BBFILES 4# We have a recipes directory, add to BBFILES
5BBFILES := "${BBFILES} ${LAYERDIR}/recipes-*/*/*.bb \ 5BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
6 ${LAYERDIR}/recipes-*/*/*.bbappend" 6 ${LAYERDIR}/recipes-*/*/*.bbappend"
7 7
8BBFILE_COLLECTIONS += "fri2" 8BBFILE_COLLECTIONS += "fri2"
diff --git a/meta-jasperforest/conf/layer.conf b/meta-jasperforest/conf/layer.conf
index 09f1647a..b539733c 100644
--- a/meta-jasperforest/conf/layer.conf
+++ b/meta-jasperforest/conf/layer.conf
@@ -1,8 +1,8 @@
1# We have a conf and classes directory, add to BBPATH 1# We have a conf and classes directory, add to BBPATH
2BBPATH := "${BBPATH}:${LAYERDIR}" 2BBPATH .= ":${LAYERDIR}"
3 3
4# We have a recipes directory, add to BBFILES 4# We have a recipes directory, add to BBFILES
5BBFILES := "${BBFILES} ${LAYERDIR}/recipes-*/*/*.bb \ 5BBFILES .= "${LAYERDIR}/recipes-*/*/*.bb \
6 ${LAYERDIR}/recipes-*/*/*.bbappend" 6 ${LAYERDIR}/recipes-*/*/*.bbappend"
7 7
8BBFILE_COLLECTIONS += "jasperforest" 8BBFILE_COLLECTIONS += "jasperforest"
diff --git a/meta-n450/conf/layer.conf b/meta-n450/conf/layer.conf
index 4481121f..ee53e543 100644
--- a/meta-n450/conf/layer.conf
+++ b/meta-n450/conf/layer.conf
@@ -1,8 +1,8 @@
1# We have a conf and classes directory, add to BBPATH 1# We have a conf and classes directory, add to BBPATH
2BBPATH := "${BBPATH}:${LAYERDIR}" 2BBPATH .= ":${LAYERDIR}"
3 3
4# We have recipes-* directories, add to BBFILES 4# We have recipes-* directories, add to BBFILES
5BBFILES := "${BBFILES} ${LAYERDIR}/recipes-*/*/*.bb \ 5BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
6 ${LAYERDIR}/recipes-*/*/*.bbappend" 6 ${LAYERDIR}/recipes-*/*/*.bbappend"
7 7
8BBFILE_COLLECTIONS += "n450" 8BBFILE_COLLECTIONS += "n450"
diff --git a/meta-romley/conf/layer.conf b/meta-romley/conf/layer.conf
index 8ce1a4db..7b6a5bc3 100644
--- a/meta-romley/conf/layer.conf
+++ b/meta-romley/conf/layer.conf
@@ -1,8 +1,8 @@
1# We have a conf and classes directory, add to BBPATH 1# We have a conf and classes directory, add to BBPATH
2BBPATH := "${BBPATH}:${LAYERDIR}" 2BBPATH .= ":${LAYERDIR}"
3 3
4# We have a recipes directory, add to BBFILES 4# We have a recipes directory, add to BBFILES
5BBFILES := "${BBFILES} ${LAYERDIR}/recipes-*/*/*.bb \ 5BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
6 ${LAYERDIR}/recipes-*/*/*.bbappend" 6 ${LAYERDIR}/recipes-*/*/*.bbappend"
7 7
8BBFILE_COLLECTIONS += "romley" 8BBFILE_COLLECTIONS += "romley"
diff --git a/meta-sugarbay/conf/layer.conf b/meta-sugarbay/conf/layer.conf
index eb8ec45e..9576330b 100644
--- a/meta-sugarbay/conf/layer.conf
+++ b/meta-sugarbay/conf/layer.conf
@@ -1,8 +1,8 @@
1# We have a conf and classes directory, add to BBPATH 1# We have a conf and classes directory, add to BBPATH
2BBPATH := "${BBPATH}:${LAYERDIR}" 2BBPATH .= ":${LAYERDIR}"
3 3
4# We have a recipes directory, add to BBFILES 4# We have a recipes directory, add to BBFILES
5BBFILES := "${BBFILES} ${LAYERDIR}/recipes-*/*/*.bb \ 5BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
6 ${LAYERDIR}/recipes-*/*/*.bbappend" 6 ${LAYERDIR}/recipes-*/*/*.bbappend"
7 7
8BBFILE_COLLECTIONS += "sugarbay" 8BBFILE_COLLECTIONS += "sugarbay"
diff --git a/meta-sys940x/conf/layer.conf b/meta-sys940x/conf/layer.conf
index 5d588ade..b14be6db 100644
--- a/meta-sys940x/conf/layer.conf
+++ b/meta-sys940x/conf/layer.conf
@@ -1,8 +1,8 @@
1# We have a conf and classes directory, add to BBPATH 1# We have a conf and classes directory, add to BBPATH
2BBPATH := "${BBPATH}:${LAYERDIR}" 2BBPATH .= ":${LAYERDIR}"
3 3
4# We have a recipes directory, add to BBFILES 4# We have a recipes directory, add to BBFILES
5BBFILES := "${BBFILES} ${LAYERDIR}/recipes-*/*/*.bb \ 5BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
6 ${LAYERDIR}/recipes-*/*/*.bbappend" 6 ${LAYERDIR}/recipes-*/*/*.bbappend"
7 7
8BBFILE_COLLECTIONS += "sys940x" 8BBFILE_COLLECTIONS += "sys940x"
diff --git a/meta-tlk/conf/layer.conf b/meta-tlk/conf/layer.conf
index fc0da613..38b0e0c2 100644
--- a/meta-tlk/conf/layer.conf
+++ b/meta-tlk/conf/layer.conf
@@ -1,6 +1,6 @@
1# We have a conf and classes directory, add to BBPATH 1# We have a conf and classes directory, add to BBPATH
2BBPATH := "${BBPATH}:${LAYERDIR}" 2BBPATH .= ":${LAYERDIR}"
3 3
4# We have recipes-* directories, add to BBFILES 4# We have recipes-* directories, add to BBFILES
5BBFILES := "${BBFILES} ${LAYERDIR}/recipes-*/*/*.bb \ 5BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
6 ${LAYERDIR}/recipes-*/*/*.bbappend" 6 ${LAYERDIR}/recipes-*/*/*.bbappend"