summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2012-11-21 12:36:54 -0800
committerTom Zanussi <tom.zanussi@linux.intel.com>2013-02-12 10:09:46 -0600
commitd3f491276519fa30fb2ce9dbdd3dd2591fa27558 (patch)
tree8c788ac7e616147c2e48740f80968f65838caa46
parent9f29ad7b9a7e2107a64407f9ce424823fb23156d (diff)
downloadmeta-intel-d3f491276519fa30fb2ce9dbdd3dd2591fa27558.tar.gz
mesa-dri_8.0.4.bbappend: Remove tabs from python code
check for xserver to be non-empty before using it fixed errors like ERROR: Failed to parse recipe: /b/kraj/yocto/poky/meta/recipes-graphics/mesa/mesa-dri_8.0.4.bb ERROR: Error executing a python function in <code>: AttributeError: 'NoneType' object has no attribute 'split' Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
-rw-r--r--common/recipes-graphics/mesa/mesa-dri_8.0.4.bbappend8
1 files changed, 4 insertions, 4 deletions
diff --git a/common/recipes-graphics/mesa/mesa-dri_8.0.4.bbappend b/common/recipes-graphics/mesa/mesa-dri_8.0.4.bbappend
index 6bfa9686..b92831d3 100644
--- a/common/recipes-graphics/mesa/mesa-dri_8.0.4.bbappend
+++ b/common/recipes-graphics/mesa/mesa-dri_8.0.4.bbappend
@@ -6,13 +6,13 @@
6python __anonymous () { 6python __anonymous () {
7 import re 7 import re
8 xserver = d.getVar('XSERVER', True) 8 xserver = d.getVar('XSERVER', True)
9 if 'emgd-driver-bin' in xserver.split(' '): 9 if xserver and 'emgd-driver-bin' in xserver.split(' '):
10 extra_oeconf = d.getVar('EXTRA_OECONF', True).split() 10 extra_oeconf = d.getVar('EXTRA_OECONF', True).split()
11 take_out = ["--enable-egl", "--enable-gles1", "--enable-gles2"] 11 take_out = ["--enable-egl", "--enable-gles1", "--enable-gles2"]
12 put_in = ["--disable-egl", "--disable-gles1", "--disable-gles2"] 12 put_in = ["--disable-egl", "--disable-gles1", "--disable-gles2"]
13 pattern = re.compile("--with-egl-platforms") 13 pattern = re.compile("--with-egl-platforms")
14 new_extra_oeconf = [ ] 14 new_extra_oeconf = [ ]
15 for i in extra_oeconf: 15 for i in extra_oeconf:
16 if ( i not in take_out ) and ( not pattern.match(i)): 16 if ( i not in take_out ) and ( not pattern.match(i)):
17 new_extra_oeconf.append(i) 17 new_extra_oeconf.append(i)
18 for i in put_in: 18 for i in put_in: