summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2012-09-05 17:06:20 -0700
committerTom Zanussi <tom.zanussi@intel.com>2012-09-20 07:47:01 -0500
commit83f7e08dfadb73904c258b8b6a14a91482e69672 (patch)
tree87328b8e42ccb94b729164693bb5d1dc7d41adf2
parent001b3945636bdf10245a2887751b38852cefe5db (diff)
downloadmeta-intel-83f7e08dfadb73904c258b8b6a14a91482e69672.tar.gz
emgd-driver-bin: Fix package naming issue
emgd-driver-bin is generating rpm package with name libegl1. This name clashes with a package with sanme name from mesa-dri recipe. This name clash blocks installation of emgd user land binaries in the image. And due to missing emgd user land components X fails to start on BSPs like crownbay. Fix this problem by specifying package names in the recipe with the PKG_ vars. This fixes bug: [YOCTO #3063] Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
-rw-r--r--common/recipes-graphics/xorg-driver/emgd-driver-bin_1.14.bb8
1 files changed, 7 insertions, 1 deletions
diff --git a/common/recipes-graphics/xorg-driver/emgd-driver-bin_1.14.bb b/common/recipes-graphics/xorg-driver/emgd-driver-bin_1.14.bb
index b1ba1b84..2464c386 100644
--- a/common/recipes-graphics/xorg-driver/emgd-driver-bin_1.14.bb
+++ b/common/recipes-graphics/xorg-driver/emgd-driver-bin_1.14.bb
@@ -7,7 +7,7 @@ to LICENSE_FLAGS_WHITELIST += \"License_emgd-driver-bin_1.14\" to your \
7local.conf in order to enable it in a build." 7local.conf in order to enable it in a build."
8LICENSE = "Intel-binary-only" 8LICENSE = "Intel-binary-only"
9LICENSE_FLAGS = "license_${PN}_${PV}" 9LICENSE_FLAGS = "license_${PN}_${PV}"
10PR = "r1" 10PR = "r2"
11 11
12EMGD_LIC_DIR = "IEMGD_HEAD_Linux/License" 12EMGD_LIC_DIR = "IEMGD_HEAD_Linux/License"
13EMGD_RPM_DIR = "IEMGD_HEAD_Linux/MeeGo1.2" 13EMGD_RPM_DIR = "IEMGD_HEAD_Linux/MeeGo1.2"
@@ -23,6 +23,12 @@ SRC_URI = "https://edc.intel.com/Download.aspx?id=6190;downloadfilename=LIN_IEMG
23SRC_URI[md5sum] = "733a7f237ffce21238ce2c9956df4fd6" 23SRC_URI[md5sum] = "733a7f237ffce21238ce2c9956df4fd6"
24SRC_URI[sha256sum] = "bcdc333b5edbda7c746a83ef821ded4a0ca55ead30980e4e3680cdb6469f45a2" 24SRC_URI[sha256sum] = "bcdc333b5edbda7c746a83ef821ded4a0ca55ead30980e4e3680cdb6469f45a2"
25 25
26# make sure generated rpm packages get non conflicting names
27PKG_${PN} = "emgd-driver"
28PKG_${PN}-dev = "emgd-driver-dev"
29PKG_${PN}-dbg = "emgd-driver-dbg"
30PKG_${PN}-doc = "emgd-driver-doc"
31
26# These are closed binaries generated elsewhere so don't check ldflags 32# These are closed binaries generated elsewhere so don't check ldflags
27INSANE_SKIP_${PN} = "ldflags" 33INSANE_SKIP_${PN} = "ldflags"
28 34