summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Zanussi <tom.zanussi@intel.com>2011-08-16 15:59:55 -0500
committerTom Zanussi <tom.zanussi@intel.com>2011-08-25 12:19:30 -0500
commit7658dbaa94638f86bab45f5763565370e8854853 (patch)
treeb2a6285d1f12d8c9a8ff6359d1a19306235ea26a
parent51baa983b3505dcd0084611d6181a125e91ee063 (diff)
downloadmeta-intel-7658dbaa94638f86bab45f5763565370e8854853.tar.gz
meta-fri2: add EMGD 1.8 capabilities to fri2
This patch essentially adds a new EMGD-capable 'fri2' machine to meta-fri2. The current version with vesa graphics will become fri2-noemgd; fri2 will become the version with EMGD graphics. This patch does the fri2->fri2-noemgd renaming and adds the new files for fri2, and updates the necessary .bbappends to support both fri2 and fri2-noemgd. Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
-rw-r--r--meta-fri2/conf/machine/fri2-noemgd.conf36
-rw-r--r--meta-fri2/conf/machine/fri2.conf5
-rw-r--r--meta-fri2/recipes-bsp/formfactor/formfactor/fri2-noemgd/machconfig3
-rw-r--r--meta-fri2/recipes-core/tasks/task-core-tools.bbappend1
-rw-r--r--meta-fri2/recipes-graphics/xorg-xserver/xserver-xf86-config/fri2-noemgd/xorg.conf26
-rw-r--r--meta-fri2/recipes-graphics/xorg-xserver/xserver-xf86-config/fri2/xorg.conf48
-rw-r--r--meta-fri2/recipes-kernel/linux/linux-yocto_3.0.bbappend13
7 files changed, 116 insertions, 16 deletions
diff --git a/meta-fri2/conf/machine/fri2-noemgd.conf b/meta-fri2/conf/machine/fri2-noemgd.conf
new file mode 100644
index 00000000..a8715294
--- /dev/null
+++ b/meta-fri2/conf/machine/fri2-noemgd.conf
@@ -0,0 +1,36 @@
1#@TYPE: Machine
2#@NAME: fri2
3
4#@DESCRIPTION: Machine configuration for Fish River Island II systems
5# i.e. E660 + EG20T
6
7include conf/machine/include/tune-atom.inc
8
9MACHINE_FEATURES = "kernel26 screen keyboard pci usbhost ext2 ext3 x86 \
10 acpi serial usbgadget wifi 3g"
11
12KERNEL_IMAGETYPE = "bzImage"
13
14PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto"
15PREFERRED_VERSION_linux-yocto ?= "3.0%"
16
17PREFERRED_PROVIDER_linux-libc-headers ?= "linux-libc-headers-yocto"
18PREFERRED_PROVIDER_virtual/libx11 ?= "libx11-trim"
19PREFERRED_PROVIDER_virtual/libgl ?= "mesa-dri"
20PREFERRED_PROVIDER_virtual/xserver ?= "xserver-xf86-dri-lite"
21PREFERRED_PROVIDER_virtual/xserver-xf86 ?= "xserver-xf86-dri-lite"
22XSERVER ?= "xserver-xf86-dri-lite \
23 xf86-input-mouse \
24 xf86-input-keyboard \
25 xf86-input-evdev \
26 xf86-input-synaptics \
27 xf86-video-vesa"
28
29SERIAL_CONSOLE = "115200 ttyS0"
30
31MACHINE_EXTRA_RRECOMMENDS = "kernel-modules eee-acpi-scripts"
32
33IMAGE_FSTYPES ?= "ext3 cpio.gz live"
34
35GLIBC_ADDONS = "nptl"
36GLIBC_EXTRA_OECONF = "--with-tls"
diff --git a/meta-fri2/conf/machine/fri2.conf b/meta-fri2/conf/machine/fri2.conf
index a8715294..4b81fab0 100644
--- a/meta-fri2/conf/machine/fri2.conf
+++ b/meta-fri2/conf/machine/fri2.conf
@@ -24,7 +24,10 @@ XSERVER ?= "xserver-xf86-dri-lite \
24 xf86-input-keyboard \ 24 xf86-input-keyboard \
25 xf86-input-evdev \ 25 xf86-input-evdev \
26 xf86-input-synaptics \ 26 xf86-input-synaptics \
27 xf86-video-vesa" 27 emgd-driver-bin"
28
29PREFERRED_VERSION_xserver-xf86-dri-lite ?= "1.9.3"
30PREFERRED_VERSION_emgd-driver-bin ?= "1.8"
28 31
29SERIAL_CONSOLE = "115200 ttyS0" 32SERIAL_CONSOLE = "115200 ttyS0"
30 33
diff --git a/meta-fri2/recipes-bsp/formfactor/formfactor/fri2-noemgd/machconfig b/meta-fri2/recipes-bsp/formfactor/formfactor/fri2-noemgd/machconfig
new file mode 100644
index 00000000..ffce0122
--- /dev/null
+++ b/meta-fri2/recipes-bsp/formfactor/formfactor/fri2-noemgd/machconfig
@@ -0,0 +1,3 @@
1# Assume a USB mouse and keyboard are connected
2HAVE_TOUCHSCREEN=0
3HAVE_KEYBOARD=1
diff --git a/meta-fri2/recipes-core/tasks/task-core-tools.bbappend b/meta-fri2/recipes-core/tasks/task-core-tools.bbappend
index 5accb2e9..aa50c91b 100644
--- a/meta-fri2/recipes-core/tasks/task-core-tools.bbappend
+++ b/meta-fri2/recipes-core/tasks/task-core-tools.bbappend
@@ -1,2 +1,3 @@
1RRECOMMENDS_task-core-tools-profile_append_fri2 = " systemtap" 1RRECOMMENDS_task-core-tools-profile_append_fri2 = " systemtap"
2RRECOMMENDS_task-core-tools-profile_append_fri2-noemgd = " systemtap"
2 3
diff --git a/meta-fri2/recipes-graphics/xorg-xserver/xserver-xf86-config/fri2-noemgd/xorg.conf b/meta-fri2/recipes-graphics/xorg-xserver/xserver-xf86-config/fri2-noemgd/xorg.conf
new file mode 100644
index 00000000..da4fc3c6
--- /dev/null
+++ b/meta-fri2/recipes-graphics/xorg-xserver/xserver-xf86-config/fri2-noemgd/xorg.conf
@@ -0,0 +1,26 @@
1Section "Device"
2 Identifier "Generic VESA"
3 Driver "vesa"
4EndSection
5
6Section "Monitor"
7 Identifier "Generic Monitor"
8 Option "DPMS"
9EndSection
10
11Section "Screen"
12 Identifier "Default Screen"
13 Device "Generic VESA"
14 Monitor "Generic Monitor"
15 DefaultDepth 24
16EndSection
17
18Section "ServerLayout"
19 Identifier "Default Layout"
20 Screen "Default Screen"
21EndSection
22
23Section "ServerFlags"
24 Option "DontZap" "0"
25 Option "AutoAddDevices" "False"
26EndSection
diff --git a/meta-fri2/recipes-graphics/xorg-xserver/xserver-xf86-config/fri2/xorg.conf b/meta-fri2/recipes-graphics/xorg-xserver/xserver-xf86-config/fri2/xorg.conf
index da4fc3c6..fce58f89 100644
--- a/meta-fri2/recipes-graphics/xorg-xserver/xserver-xf86-config/fri2/xorg.conf
+++ b/meta-fri2/recipes-graphics/xorg-xserver/xserver-xf86-config/fri2/xorg.conf
@@ -1,23 +1,45 @@
1Section "Device" 1##
2 Identifier "Generic VESA" 2## X Config options generated from CED
3 Driver "vesa" 3## x11 conf skeleton
4EndSection 4## DriverVer=
5##
5 6
6Section "Monitor" 7Section "Screen"
7 Identifier "Generic Monitor" 8 Identifier "Screen0"
8 Option "DPMS" 9 Device "IntelEMGD-0"
10 Monitor "Monitor0"
11 SubSection "Display"
12 EndSubSection
9EndSection 13EndSection
10 14
11Section "Screen" 15# Primary (First/only) display
12 Identifier "Default Screen" 16Section "Device"
13 Device "Generic VESA" 17 Identifier "IntelEMGD-0"
14 Monitor "Generic Monitor" 18 Driver "emgd"
15 DefaultDepth 24 19 VendorName "Intel(R) DEG"
20 BoardName "Embedded Graphics"
21 BusID "0:2:0"
22 Screen 0
23 Option "PcfVersion" "1792"
24 Option "ConfigId" "1"
25 Option "ALL/1/name" "e6xx"
26 Option "ALL/1/General/PortOrder" "40000"
27 Option "ALL/1/General/DisplayConfig" "1"
28 Option "ALL/1/General/DisplayDetect" "1"
29 Option "ALL/1/General/TuningWA" "1"
30 Option "ALL/1/Port/4/General/name" "lvds"
31 Option "ALL/1/Port/4/General/EdidAvail" "3"
32 Option "ALL/1/Port/4/General/EdidNotAvail" "1"
33 Option "ALL/1/Port/4/General/Rotation" "0"
34 Option "ALL/1/Port/4/General/Edid" "0"
16EndSection 35EndSection
17 36
18Section "ServerLayout" 37Section "ServerLayout"
19 Identifier "Default Layout" 38 Identifier "Default Layout"
20 Screen "Default Screen" 39 Screen 0 "Screen0" 0 0
40 # InputDevice "Mouse0" "CorePointer"
41 # InputDevice "Keyboard0" "CoreKeyboard"
42 # InputDevice "DevInputMice" "SendCoreEvents"
21EndSection 43EndSection
22 44
23Section "ServerFlags" 45Section "ServerFlags"
diff --git a/meta-fri2/recipes-kernel/linux/linux-yocto_3.0.bbappend b/meta-fri2/recipes-kernel/linux/linux-yocto_3.0.bbappend
index 739e7991..0719ded7 100644
--- a/meta-fri2/recipes-kernel/linux/linux-yocto_3.0.bbappend
+++ b/meta-fri2/recipes-kernel/linux/linux-yocto_3.0.bbappend
@@ -1,6 +1,15 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
2COMPATIBLE_MACHINE_fri2 = "fri2" 3COMPATIBLE_MACHINE_fri2 = "fri2"
3KMACHINE_fri2 = "yocto/standard/fri2" 4KMACHINE_fri2 = "yocto/standard/fri2"
5KERNEL_FEATURES_append_fri2 += " cfg/smp.scc"
6
7COMPATIBLE_MACHINE_fri2-noemgd = "fri2-noemgd"
8KMACHINE_fri2-noemgd = "yocto/standard/fri2"
9KERNEL_FEATURES_append_fri2-noemgd += " cfg/smp.scc"
10
11SRCREV_machine_pn-linux-yocto_fri2 ?= "f1167dd736c4a4aea834b853d73c51f9863151b4"
12SRCREV_meta_pn-linux-yocto_fri2 ?= "5b535279e61197cb194bb2dfceb8b7a04128387c"
4 13
5SRCREV_machine_pn-linux-yocto_fri2 ?= "493b09ef2c7124f977421a40955750743a5293d3" 14SRCREV_machine_pn-linux-yocto_fri2-noemgd ?= "f1167dd736c4a4aea834b853d73c51f9863151b4"
6SRCREV_meta_pn-linux-yocto_fri2 ?= "d588bdafc0d9b4d2386144b7d76a1d379e2d16c0" 15SRCREV_meta_pn-linux-yocto_fri2-noemgd ?= "5b535279e61197cb194bb2dfceb8b7a04128387c"