summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOng Boon Leong <boon.leong.ong@intel.com>2013-09-25 14:03:06 +0800
committerElizabeth Flanagan <elizabeth.flanagan@intel.com>2013-10-01 15:22:03 -0700
commit682ffeeafa42f6a6f9f3c95eb40d828a2e53dfea (patch)
treee7986dec6887a14e4e184e16072f7bff55c513af
parent67b58a79279ad1beaf8dc0c68fb411f1d440abe4 (diff)
downloadmeta-intel-1.5_M5.rc6.tar.gz
common: Remove obsolete QAT-related recipes1.5_M5.rc6
Remove openssl-qat-module and zlib-qat-module recipes and any references to them from meta-intel. This is to remove recipes for obsolete and unmaintained software ingredients related to QAT. Signed-off-by Ong Boon Leong <boon.leong.ong@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
-rw-r--r--common/recipes-connectivity/openssl-qat-module/openssl-qat-module.bb58
-rw-r--r--common/recipes-connectivity/openssl-qat-module/openssl-qat-module/openssl_qat_module.patch43
-rw-r--r--common/recipes-core/zlib-qat-module/zlib-qat-module.bb52
-rw-r--r--common/recipes-core/zlib-qat-module/zlib-qat-module/zlib_qat_module.patch43
-rw-r--r--meta-crystalforest/README19
-rw-r--r--meta-crystalforest/conf/machine/crystalforest-gladden.conf1
-rw-r--r--meta-crystalforest/conf/machine/crystalforest-server.conf1
7 files changed, 0 insertions, 217 deletions
diff --git a/common/recipes-connectivity/openssl-qat-module/openssl-qat-module.bb b/common/recipes-connectivity/openssl-qat-module/openssl-qat-module.bb
deleted file mode 100644
index 8b7ffb0c..00000000
--- a/common/recipes-connectivity/openssl-qat-module/openssl-qat-module.bb
+++ /dev/null
@@ -1,58 +0,0 @@
1SUMMARY = "libcrypto* (OpenSSL*) QAT_MEM Memory Management Module \
2for Intel Quick Assist Technology"
3DESCRIPTION = "This software adds an engine that accelerates some of \
4the libcrypto algorithms via the Intel QuickAssist Technology \
5implemented on Intel Communications Chipset 89xx Series based platforms."
6
7HOMEPAGE = "http://www.openssl.org/"
8SECTION = "libs/network"
9
10LICENSE = "openssl & GPLv2 & BSD"
11LIC_FILES_CHKSUM = "file://${WORKDIR}/openssl-${PV}/LICENSE;md5=f9a8f968107345e0b75aa8c2ecaa7ec8 \
12 file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6 \
13 file://${COMMON_LICENSE_DIR}/BSD;md5=3775480a712fc46a69647678acb234cb"
14
15PV = "1.0.1"
16PR = "r0"
17
18OPENSSL_QAT_VERSION = "0.4.0-012"
19
20SRC_URI = "http://www.openssl.org/source/openssl-${PV}.tar.gz;name=openssl \
21 http://downloadmirror.intel.com/19368/eng/libcrypto-openssl-${PV}-qat.L.${OPENSSL_QAT_VERSION}.tar.gz;name=libcrypto \
22 file://openssl_qat_module.patch"
23
24SRC_URI[openssl.md5sum]="134f168bc2a8333f19f81d684841710b"
25SRC_URI[openssl.sha256sum]="4d9f0a594a9a89b28e1a04a9504c04104f6508ee27ad1e0efdd17a7a6dbbeeee"
26
27SRC_URI[libcrypto.md5sum] = "e4e131fa56d3aa1a52b5bdb9f8fe5a69"
28SRC_URI[libcrypto.sha256sum] = "19a80ae6e78548934295d312148e4254c18dabd25e2fd72de5796d8ac15b1cfb"
29
30COMPATIBLE_HOST = "(x86_64.*|i.86.*)-linux"
31
32S = "${WORKDIR}/openssl-${PV}/engines/qat_engine/qat_mem"
33
34export KERNEL_SOURCE_ROOT = "${STAGING_KERNEL_DIR}"
35inherit module
36
37do_patch() {
38 cd ${WORKDIR}/openssl-${PV}
39 patch -p2 < ${WORKDIR}/libcrypto-openssl-${PV}-qat.L.${OPENSSL_QAT_VERSION}.patch
40
41 cd ${WORKDIR}
42 patch -p1 <${WORKDIR}/openssl_qat_module.patch
43}
44
45do_compile() {
46 cd ${S}
47 oe_runmake KERNEL_CC="${KERNEL_CC}"
48}
49
50do_install_append() {
51 install -m 0755 -d ${D}${bindir} \
52 ${D}${includedir}/engines/qat_engine/qat_mem
53
54 install -m 0755 ${S}/qat_mem_test ${D}${bindir}
55 install -m 0750 ${S}/*.h ${D}${includedir}/engines/qat_engine/qat_mem/
56}
57
58FILES_${PN} += "${bindir}/qat_mem_test"
diff --git a/common/recipes-connectivity/openssl-qat-module/openssl-qat-module/openssl_qat_module.patch b/common/recipes-connectivity/openssl-qat-module/openssl-qat-module/openssl_qat_module.patch
deleted file mode 100644
index dfed3c08..00000000
--- a/common/recipes-connectivity/openssl-qat-module/openssl-qat-module/openssl_qat_module.patch
+++ /dev/null
@@ -1,43 +0,0 @@
1Index: openssl-qat-module-1.0.1-r0/openssl-1.0.1/engines/qat_engine/qat_mem/Makefile
2===================================================================
3--- openssl-qat-module-1.0.1-r0.orig/openssl-1.0.1/engines/qat_engine/qat_mem/Makefile 2012-10-17 13:31:27.932376960 -0700
4+++ openssl-qat-module-1.0.1-r0/openssl-1.0.1/engines/qat_engine/qat_mem/Makefile 2012-10-17 13:35:40.396389410 -0700
5@@ -9,13 +9,9 @@
6 MODULENAME := qat_mem
7 ### should not need to change stuff below ######################
8
9-
10-KDIR := /lib/modules/$(shell uname -r)/build
11-#KDIR := /exports/linux-2.6.12.2/
12+KDIR := $(KERNEL_SOURCE_ROOT)
13 PWD := $(shell pwd)
14-
15-CC := gcc -Wall -imacros /usr/src/kernels/$(shell uname -r)/include/linux/autoconf.h
16-
17+CC := $(KERNEL_CC) -Wall -imacros $(KERNEL_SOURCE_ROOT)/include/generated/autoconf.h
18 ifeq ($(KERNELRELEASE),)
19 all: $(MODULENAME)_test
20 all:
21@@ -23,20 +19,15 @@
22 else
23 obj-m := $(MODULENAME).o
24 endif
25-
26 $(MODULENAME)_test: $(MODULENAME)_test.c
27 $(CC) -g -o $(MODULENAME)_test $(MODULENAME)_test.c
28-
29-
30+modules_install:
31+ $(MAKE) -C $(KDIR) SUBDIRS=$(PWD) modules_install
32 load:
33 insmod ./$(MODULENAME).ko
34-
35 unload:
36 rmmod $(MODULENAME)
37-
38 test: all
39 ./$(MODULENAME)_test.sh
40-
41 clean:
42 rm -f *.o *.ko Modules.symvers *.mod.c .*.cmd $(MODULENAME)_test
43-
diff --git a/common/recipes-core/zlib-qat-module/zlib-qat-module.bb b/common/recipes-core/zlib-qat-module/zlib-qat-module.bb
deleted file mode 100644
index 5ade06eb..00000000
--- a/common/recipes-core/zlib-qat-module/zlib-qat-module.bb
+++ /dev/null
@@ -1,52 +0,0 @@
1SUMMARY="Zlib QAT_MEM Memory Management Module for Intel Quick Assist \
2Technology"
3DESCRIPTION="This software acelerates the data compression algorithm \
4in the zlib software library via the Intel QuickAssist Technology \
5implemented on Intel Communications Chipset 89xx Series based platforms."
6
7HOMEPAGE = "http://zlib.net/"
8SECTION = "libs"
9LICENSE = "Zlib & GPLv2 & BSD"
10
11LIC_FILES_CHKSUM = "file://${WORKDIR}/zlib-${PV}/zlib.h;beginline=4;endline=23;md5=94d1b5a40dadd127f3351471727e66a9 \
12 file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6 \
13 file://${COMMON_LICENSE_DIR}/BSD;md5=3775480a712fc46a69647678acb234cb"
14PV = "1.2.7"
15ZLIB_QAT_VERSION = "0.4.0-011"
16
17PR="r0"
18
19SRC_URI = "http://www.zlib.net/zlib-${PV}.tar.gz;name=zlib \
20 http://downloadmirror.intel.com/20294/eng/zlib-${PV}-qat.L.${ZLIB_QAT_VERSION}.tar.gz;name=zlib_qat \
21 file://zlib_qat_module.patch"
22
23SRC_URI[zlib.md5sum]="60df6a37c56e7c1366cca812414f7b85"
24SRC_URI[zlib.sha256sum]="fa9c9c8638efb8cb8ef5e4dd5453e455751e1c530b1595eed466e1be9b7e26c5"
25
26SRC_URI[zlib_qat.md5sum]="88e4140f98d2f9e170bf473f20e1a8d4"
27SRC_URI[zlib_qat.sha256sum]="3c360878127f3930e64640ef5a5822719a5059143326bb4c396645ae37b704a6"
28
29S = "${WORKDIR}/zlib-${PV}/contrib/qat/qat_mem"
30
31inherit module
32export KERNEL_SOURCE_ROOT = "${STAGING_KERNEL_DIR}"
33
34do_patch() {
35 cd ${WORKDIR}/zlib-${PV}
36 patch -p0 < ${WORKDIR}/zlib-${PV}-qat.L.${ZLIB_QAT_VERSION}.patch
37
38 cd ${WORKDIR}
39 patch -p1 < ${WORKDIR}/zlib_qat_module.patch
40}
41
42do_compile() {
43 cd ${S}
44 oe_runmake KERNEL_CC="${KERNEL_CC}"
45}
46
47do_install_append() {
48 install -m 0755 -d ${D}${bindir}
49 install -m 0755 ${S}/qat_mem_test ${D}${bindir}
50}
51
52FILES_${PN} += "${bindir}/qat_mem_test"
diff --git a/common/recipes-core/zlib-qat-module/zlib-qat-module/zlib_qat_module.patch b/common/recipes-core/zlib-qat-module/zlib-qat-module/zlib_qat_module.patch
deleted file mode 100644
index a30f8b05..00000000
--- a/common/recipes-core/zlib-qat-module/zlib-qat-module/zlib_qat_module.patch
+++ /dev/null
@@ -1,43 +0,0 @@
1Index: zlib-qat-module-1.2.7-r0/zlib-1.2.7/contrib/qat/qat_mem/Makefile
2===================================================================
3--- zlib-qat-module-1.2.7-r0.orig/zlib-1.2.7/contrib/qat/qat_mem/Makefile 2012-10-16 13:53:10.258938722 -0700
4+++ zlib-qat-module-1.2.7-r0/zlib-1.2.7/contrib/qat/qat_mem/Makefile 2012-10-16 13:59:18.174944864 -0700
5@@ -59,13 +59,10 @@
6 #
7 #
8 #########################################################################
9-
10 MODULENAME := qat_mem
11-KDIR := /lib/modules/$(shell uname -r)/build
12+KDIR := $(KERNEL_SOURCE_ROOT)
13 PWD := $(shell pwd)
14-
15-CC := gcc -Wall -imacros /usr/src/kernels/$(shell uname -r)/include/linux/autoconf.h
16-
17+CC := $(KERNEL_CC) -Wall -imacros $(KERNEL_SOURCE_ROOT)/include/generated/autoconf.h
18 ifeq ($(KERNELRELEASE),)
19 all: $(MODULENAME)_test
20 all:
21@@ -73,20 +70,15 @@
22 else
23 obj-m := $(MODULENAME).o
24 endif
25-
26+modules_install:
27+ $(MAKE) -C $(KDIR) SUBDIRS=$(PWD) modules_install
28 $(MODULENAME)_test: $(MODULENAME)_test.c
29 $(CC) -g -o $(MODULENAME)_test $(MODULENAME)_test.c
30-
31-
32 load:
33 insmod ./$(MODULENAME).ko
34-
35 unload:
36 rmmod $(MODULENAME)
37-
38 test: all
39 ./$(MODULENAME)_test
40-
41 clean:
42 rm -f *.o *.ko Module.symvers modules.order *.mod.c .*.cmd $(MODULENAME)_test
43-
diff --git a/meta-crystalforest/README b/meta-crystalforest/README
index 06d80630..03468868 100644
--- a/meta-crystalforest/README
+++ b/meta-crystalforest/README
@@ -165,25 +165,6 @@ contact your Intel Field Sales Representative or visit Intel Embedded Design
165Center (www.intel.com/p/en_US/embedded/designcenter) for instructions on how 165Center (www.intel.com/p/en_US/embedded/designcenter) for instructions on how
166to locate and use these recipes. 166to locate and use these recipes.
167 167
168IV. Enabling libcrypto kernel module for QuickAssist Technology
169===============================================================
170
171Since the Kernel Module names of Libcrypto and Zlib for QuickAssist
172Technology recipes are same, enabling both causes the build to fail.
173
174Please see Bug #4126 for more description.
175
176By default Crystal Forest builds zlib-qat-module.
177For enabling the libcrypto kernel module recipe, do the following:
178
179Crystal Forest Gladden:
180Edit meta-intel/meta-crystalforest/conf/machine/crystalforest-gladden.conf
181and replace zlib-qat-module with openssl-qat-module in MACHINE_EXTRA_RRECOMMENDS
182
183Crystal Forest Server:
184Edit meta-intel/meta-crystalforest/conf/machine/crystalforest-server.conf
185and replace zlib-qat-module with openssl-qat-module in MACHINE_EXTRA_RRECOMMENDS
186
187---- 168----
188 169
189If you find you're getting corrupt images on the USB (it doesn't show 170If you find you're getting corrupt images on the USB (it doesn't show
diff --git a/meta-crystalforest/conf/machine/crystalforest-gladden.conf b/meta-crystalforest/conf/machine/crystalforest-gladden.conf
index 2615d7a6..b18f72da 100644
--- a/meta-crystalforest/conf/machine/crystalforest-gladden.conf
+++ b/meta-crystalforest/conf/machine/crystalforest-gladden.conf
@@ -21,7 +21,6 @@ XSERVER ?= "${XSERVER_IA32_BASE} \
21 " 21 "
22MACHINE_EXTRA_RRECOMMENDS += "calgary-corpus \ 22MACHINE_EXTRA_RRECOMMENDS += "calgary-corpus \
23 canterbury-corpus \ 23 canterbury-corpus \
24 zlib-qat-module \
25 " 24 "
26#This Kernel Option is required for Intel Quick Assist Technology Software. 25#This Kernel Option is required for Intel Quick Assist Technology Software.
27APPEND += "acpi_enforce_resources=lax" 26APPEND += "acpi_enforce_resources=lax"
diff --git a/meta-crystalforest/conf/machine/crystalforest-server.conf b/meta-crystalforest/conf/machine/crystalforest-server.conf
index 443ac056..2dfcc3b8 100644
--- a/meta-crystalforest/conf/machine/crystalforest-server.conf
+++ b/meta-crystalforest/conf/machine/crystalforest-server.conf
@@ -21,7 +21,6 @@ XSERVER ?= "${XSERVER_IA32_BASE} \
21 " 21 "
22MACHINE_EXTRA_RRECOMMENDS += "calgary-corpus \ 22MACHINE_EXTRA_RRECOMMENDS += "calgary-corpus \
23 canterbury-corpus \ 23 canterbury-corpus \
24 zlib-qat-module \
25 " 24 "
26#This Kernel Option is required for Intel Quick Assist Technology Software. 25#This Kernel Option is required for Intel Quick Assist Technology Software.
27APPEND += "acpi_enforce_resources=lax" 26APPEND += "acpi_enforce_resources=lax"