summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDarren Hart <dvhart@linux.intel.com>2014-02-11 15:44:25 -0800
committerDarren Hart <dvhart@linux.intel.com>2014-03-12 14:51:00 -0700
commitbf3ae602ad3f18f673fa6d268634fa4af8d4b2c9 (patch)
tree7b36ea33e4e4ace2062d5d1f166b2aa789669f7c
parent46fd4b45c71d674e08037f9d6a2efceb7a963951 (diff)
downloadmeta-intel-bf3ae602ad3f18f673fa6d268634fa4af8d4b2c9.tar.gz
linux-yocto-rt: Add intel-common linux-yocto-rt 3.10 bbappend
Create the bbappend to build intel-common -rt linux-yocto 3.10 kernels for all intel-common BSPs. Signed-off-by: Darren Hart <dvhart@linux.intel.com>
-rw-r--r--common/recipes-kernel/linux/linux-yocto-rt_3.10.bbappend19
1 files changed, 19 insertions, 0 deletions
diff --git a/common/recipes-kernel/linux/linux-yocto-rt_3.10.bbappend b/common/recipes-kernel/linux/linux-yocto-rt_3.10.bbappend
new file mode 100644
index 00000000..cfb41930
--- /dev/null
+++ b/common/recipes-kernel/linux/linux-yocto-rt_3.10.bbappend
@@ -0,0 +1,19 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3KERNEL_FEATURES_INTEL_COMMON = ""
4
5#LINUX_VERSION_core2-32-intel-common = "3.10"
6COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
7#SRCREV_meta_core2-32-intel-common = "${AUTOREV}"
8#SRCREV_machine_core2-32-intel-common = "${AUTOREV}"
9KMACHINE_core2-32-intel-common = "intel-core2-32"
10KBRANCH_core2-32-intel-common = "standard/preempt-rt/base"
11KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
12
13#LINUX_VERSION_corei7-64-intel-common = "3.10"
14COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}"
15#SRCREV_meta_corei7-64-intel-common = "${AUTOREV}"
16#SRCREV_machine_corei7-64-intel-common = "${AUTOREV}"
17KMACHINE_intel-corei7-64-intel-common = "intel-corei7-64"
18KBRANCH_intel-corei7-64-intel-common = "standard/preempt-rt/base"
19KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"