summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDarren Hart <dvhart@linux.intel.com>2014-02-03 13:28:19 -0800
committerDarren Hart <dvhart@linux.intel.com>2014-02-05 20:42:00 -0800
commitb71ee00687bfe4093da110d8fd11967a5f229ce9 (patch)
tree2496f96e216fe5f5fe7050c8263a26eb1a15a8d1
parent370cd0aef28c90cad09b1175c8fc2188fb93bd21 (diff)
downloadmeta-intel-b71ee00687bfe4093da110d8fd11967a5f229ce9.tar.gz
linux-yocto-dev: Update for intel-common BSPs
The intel-core* BSPs now have their own BSP description in linux-yocto. Update the recipe accordingly. All the existing BSPs (with the exception of the emgd variants) are now supported across these two BSPs. For machines that derive from the intel-common-pkgarch, allow the common linux-yocto-dev recipe to build for them by specifying $MACHINE for the common machine overrides (core2-32-intel-common and corei7-64-intel-common). Signed-off-by: Darren Hart <dvhart@linux.intel.com>
-rw-r--r--common/recipes-kernel/linux/linux-yocto-dev.bbappend31
1 files changed, 15 insertions, 16 deletions
diff --git a/common/recipes-kernel/linux/linux-yocto-dev.bbappend b/common/recipes-kernel/linux/linux-yocto-dev.bbappend
index abe4e693..083cb114 100644
--- a/common/recipes-kernel/linux/linux-yocto-dev.bbappend
+++ b/common/recipes-kernel/linux/linux-yocto-dev.bbappend
@@ -1,20 +1,19 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3#LINUX_VERSION = "3.10.19" 3KERNEL_FEATURES_INTEL_COMMON = ""
4 4
5SRCREV_meta = "0580cffb6f760a22c056f8ada43a60c444a4ca3e" 5#LINUX_VERSION_core2-32-intel-common = "3.13"
6SRCREV_machine = "7446bf268c69a88faef816be7a1efc35b1f96b9b" 6COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
7#SRCREV_meta_core2-32-intel-common = "${AUTOREV}"
8#SRCREV_machine_core2-32-intel-common = "${AUTOREV}"
9KMACHINE_core2-32-intel-common = "intel-core2-32"
10KBRANCH_core2-32-intel-common = "standard/base"
11KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
7 12
8COMPATIBLE_MACHINE_intel-core2-32 = "intel-core2-32" 13#LINUX_VERSION_corei7-64-intel-common = "3.13"
9KMACHINE_intel-core2-32 = "common-pc" 14COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}"
10KBRANCH_intel-core2-32 = "standard/base" 15#SRCREV_meta_corei7-64-intel-common = "${AUTOREV}"
11KERNEL_FEATURES_append_intel-core2-32 = " cfg/vesafb" 16#SRCREV_machine_corei7-64-intel-common = "${AUTOREV}"
12#SRCREV_meta_intel-core2-32 = "d9cd83c0292bd4e2a6754a96761027252e726a42" 17KMACHINE_intel-corei7-64-intel-common = "intel-corei7-64"
13#SRCREV_machine_intel-core2-32 = "a9ec82e355130160f9094e670bd5be0022a84194" 18KBRANCH_intel-corei7-64-intel-common = "standard/base"
14 19KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
15COMPATIBLE_MACHINE_intel-corei7-64 = "intel-corei7-64"
16KMACHINE_intel-corei7-64 = "common-pc-64"
17KBRANCH_intel-corei7-64 = "standard/base"
18KERNEL_FEATURES_append_intel-corei7-64 = " cfg/vesafb"
19#SRCREV_meta_intel-corei7-64 = "d9cd83c0292bd4e2a6754a96761027252e726a42"
20#SRCREV_machine_intel-corei7-64 = "a9ec82e355130160f9094e670bd5be0022a84194"