summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDarren Hart <dvhart@linux.intel.com>2014-03-17 08:17:20 -0700
committerDarren Hart <dvhart@linux.intel.com>2014-03-17 16:23:10 -0700
commit626bc169369eaef6bc640a3fb895fde22aa1ae2c (patch)
tree3fad4f1a28ca7b03b0abd6af91fb25d6f6ca2ed5
parentbbbfb9e751d50810baf197f492489dce6ba834da (diff)
downloadmeta-intel-626bc169369eaef6bc640a3fb895fde22aa1ae2c.tar.gz
linux-yocto-rt: Add missing 3.10 rt bbappends
The following commit: Update linux-yocto-rt 3.8 to 3.10 46fd4b45c71d674e08037f9d6a2efceb7a963951 Failed to add the new 3.10 recipes, resulting in build failures for machines not taking advantage of the intel-common-pkgarch. Add the linux-yocto-rt bbappend to those BSPs. Signed-off-by: Darren Hart <dvhart@linux.intel.com>
-rw-r--r--meta-chiefriver/recipes-kernel/linux/linux-yocto-rt_3.10.bbappend9
-rw-r--r--meta-emenlow/recipes-kernel/linux/linux-yocto-rt_3.10.bbappend9
-rw-r--r--meta-fri2/recipes-kernel/linux/linux-yocto-rt_3.10.bbappend15
-rw-r--r--meta-sys940x/recipes-kernel/linux/linux-yocto-rt_3.10.bbappend16
4 files changed, 49 insertions, 0 deletions
diff --git a/meta-chiefriver/recipes-kernel/linux/linux-yocto-rt_3.10.bbappend b/meta-chiefriver/recipes-kernel/linux/linux-yocto-rt_3.10.bbappend
new file mode 100644
index 00000000..bee7e549
--- /dev/null
+++ b/meta-chiefriver/recipes-kernel/linux/linux-yocto-rt_3.10.bbappend
@@ -0,0 +1,9 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3COMPATIBLE_MACHINE_chiefriver = "chiefriver"
4KMACHINE_chiefriver = "chiefriver"
5
6# Update the following to use a different BSP branch or meta SRCREV
7#KBRANCH_chiefriver = "standard/preempt-rt/base"
8#SRCREV_machine_pn-linux-yocto-rt_chiefriver ?= "XXX"
9#SRCREV_meta_pn-linux-yocto-rt_chiefriver ?= "XXX"
diff --git a/meta-emenlow/recipes-kernel/linux/linux-yocto-rt_3.10.bbappend b/meta-emenlow/recipes-kernel/linux/linux-yocto-rt_3.10.bbappend
new file mode 100644
index 00000000..6ffc05c1
--- /dev/null
+++ b/meta-emenlow/recipes-kernel/linux/linux-yocto-rt_3.10.bbappend
@@ -0,0 +1,9 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3COMPATIBLE_MACHINE_emenlow = "emenlow"
4KMACHINE_emenlow = "emenlow"
5
6# Update the following to use a different BSP branch or meta SRCREV
7#KBRANCH_emenlow = "standard/preempt-rt/base"
8#SRCREV_machine_pn-linux-yocto-rt_emenlow ?= XXXX
9#SRCREV_meta_pn-linux-yocto-rt_emenlow ?= XXXX
diff --git a/meta-fri2/recipes-kernel/linux/linux-yocto-rt_3.10.bbappend b/meta-fri2/recipes-kernel/linux/linux-yocto-rt_3.10.bbappend
new file mode 100644
index 00000000..22baa9aa
--- /dev/null
+++ b/meta-fri2/recipes-kernel/linux/linux-yocto-rt_3.10.bbappend
@@ -0,0 +1,15 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3COMPATIBLE_MACHINE_fri2 = "fri2"
4KMACHINE_fri2 = "fri2"
5KBRANCH_fri2 = "standard/preempt-rt/fri2"
6SRCREV_machine_pn-linux-yocto-rt_fri2 ?= "6df6580e4a54308346d4ebaaa433932842ac8783"
7#SRCREV_meta_pn-linux-yocto-rt_fri2 ?= "XXX"
8
9COMPATIBLE_MACHINE_fri2-noemgd = "fri2-noemgd"
10KMACHINE_fri2-noemgd = "fri2"
11KBRANCH_fri2-noemgd = "standard/preempt-rt/fri2"
12SRCREV_machine_pn-linux-yocto-rt_fri2-noemgd ?= "6df6580e4a54308346d4ebaaa433932842ac8783"
13#SRCREV_meta_pn-linux-yocto-rt_fri2-noemgd ?= "XXX"
14
15module_autoload_iwlwifi = "iwlwifi"
diff --git a/meta-sys940x/recipes-kernel/linux/linux-yocto-rt_3.10.bbappend b/meta-sys940x/recipes-kernel/linux/linux-yocto-rt_3.10.bbappend
new file mode 100644
index 00000000..cc680cec
--- /dev/null
+++ b/meta-sys940x/recipes-kernel/linux/linux-yocto-rt_3.10.bbappend
@@ -0,0 +1,16 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3COMPATIBLE_MACHINE_sys940x = "sys940x"
4KMACHINE_sys940x = "sys940x"
5
6COMPATIBLE_MACHINE_sys940x-noemgd = "sys940x-noemgd"
7KMACHINE_sys940x-noemgd = "sys940x"
8
9# Update the following to use a different BSP branch or meta SRCREV
10#KBRANCH_sys940x = "standard/preempt-rt/base"
11#SRCREV_machine_pn-linux-yocto-rt_sys940x ?= "XXX"
12#SRCREV_meta_pn-linux-yocto-rt_sys940x ?= "XXX"
13
14#KBRANCH_sys940x-noemgd = "standard/preempt-rt/base"
15#SRCREV_machine_pn-linux-yocto-rt_sys940x-noemgd ?= "XXX"
16#SRCREV_meta_pn-linux-yocto-rt_sys940x-noemgd ?= "XXX"