summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDarren Hart <dvhart@linux.intel.com>2014-01-24 13:28:33 -0800
committerDarren Hart <dvhart@linux.intel.com>2014-01-27 16:56:14 -0800
commit19aef8f203a043059fc5a4b5a73a7ed6e27ef13e (patch)
tree1183ad1ab87945ab840e0e8b42fda399ff11447e
parent6923f42926238c582698aee5c018a4dab02a74be (diff)
downloadmeta-intel-19aef8f203a043059fc5a4b5a73a7ed6e27ef13e.tar.gz
nuc: Set PACKAGE_ARCH to MACHINE_ARCH explicitly
The new intel-common.inc sets the default of the PACKAGE_ARCH for the linux-yocto kernel recipes to DEFAULTTUNE_kernel. Revert the existing recipes to MACHINE_ARCH until they can be removed in favor of a more unified mechanism. Signed-off-by: Darren Hart <dvhart@linux.intel.com>
-rw-r--r--meta-nuc/recipes-kernel/linux/linux-yocto-dev.bbappend2
-rw-r--r--meta-nuc/recipes-kernel/linux/linux-yocto_3.10.bbappend2
-rw-r--r--meta-nuc/recipes-kernel/linux/linux-yocto_3.4.bbappend2
-rw-r--r--meta-nuc/recipes-kernel/linux/linux-yocto_3.8.bbappend2
4 files changed, 8 insertions, 0 deletions
diff --git a/meta-nuc/recipes-kernel/linux/linux-yocto-dev.bbappend b/meta-nuc/recipes-kernel/linux/linux-yocto-dev.bbappend
index 8a6eb573..e46debc8 100644
--- a/meta-nuc/recipes-kernel/linux/linux-yocto-dev.bbappend
+++ b/meta-nuc/recipes-kernel/linux/linux-yocto-dev.bbappend
@@ -1,5 +1,7 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3PACKAGE_ARCH_nuc = "${MACHINE_ARCH}"
4
3COMPATIBLE_MACHINE_nuc = "nuc" 5COMPATIBLE_MACHINE_nuc = "nuc"
4KMACHINE_nuc = "chiefriver" 6KMACHINE_nuc = "chiefriver"
5KBRANCH_nuc = "standard/common-pc-64/chiefriver" 7KBRANCH_nuc = "standard/common-pc-64/chiefriver"
diff --git a/meta-nuc/recipes-kernel/linux/linux-yocto_3.10.bbappend b/meta-nuc/recipes-kernel/linux/linux-yocto_3.10.bbappend
index 28beeea6..426c0370 100644
--- a/meta-nuc/recipes-kernel/linux/linux-yocto_3.10.bbappend
+++ b/meta-nuc/recipes-kernel/linux/linux-yocto_3.10.bbappend
@@ -1,5 +1,7 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3PACKAGE_ARCH_nuc = "${MACHINE_ARCH}"
4
3COMPATIBLE_MACHINE_nuc = "nuc" 5COMPATIBLE_MACHINE_nuc = "nuc"
4KMACHINE_nuc = "chiefriver" 6KMACHINE_nuc = "chiefriver"
5KBRANCH_nuc = "standard/common-pc-64/chiefriver" 7KBRANCH_nuc = "standard/common-pc-64/chiefriver"
diff --git a/meta-nuc/recipes-kernel/linux/linux-yocto_3.4.bbappend b/meta-nuc/recipes-kernel/linux/linux-yocto_3.4.bbappend
index 68f4d073..8f34a013 100644
--- a/meta-nuc/recipes-kernel/linux/linux-yocto_3.4.bbappend
+++ b/meta-nuc/recipes-kernel/linux/linux-yocto_3.4.bbappend
@@ -1,5 +1,7 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3PACKAGE_ARCH_nuc = "${MACHINE_ARCH}"
4
3COMPATIBLE_MACHINE_nuc = "nuc" 5COMPATIBLE_MACHINE_nuc = "nuc"
4KMACHINE_nuc = "chiefriver" 6KMACHINE_nuc = "chiefriver"
5KBRANCH_nuc = "standard/common-pc-64/chiefriver" 7KBRANCH_nuc = "standard/common-pc-64/chiefriver"
diff --git a/meta-nuc/recipes-kernel/linux/linux-yocto_3.8.bbappend b/meta-nuc/recipes-kernel/linux/linux-yocto_3.8.bbappend
index 53e41ed9..975f1b8f 100644
--- a/meta-nuc/recipes-kernel/linux/linux-yocto_3.8.bbappend
+++ b/meta-nuc/recipes-kernel/linux/linux-yocto_3.8.bbappend
@@ -1,5 +1,7 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3PACKAGE_ARCH_nuc = "${MACHINE_ARCH}"
4
3COMPATIBLE_MACHINE_nuc = "nuc" 5COMPATIBLE_MACHINE_nuc = "nuc"
4KMACHINE_nuc = "chiefriver" 6KMACHINE_nuc = "chiefriver"
5KBRANCH_nuc = "standard/common-pc-64/chiefriver" 7KBRANCH_nuc = "standard/common-pc-64/chiefriver"