summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Dudau <adrian.dudau@enea.com>2014-03-31 16:24:10 +0200
committerGeorge Nita <george.nita@enea.com>2014-04-01 08:22:10 +0300
commitaccc04b57bb68da4542bcecd49d95dcb03efd909 (patch)
tree93acc017b70b3afcf950aefb37c4f9d07b1e6918
parent385480881105643d83277023ce74df8c1b4a9c9e (diff)
downloadmeta-intel-accc04b57bb68da4542bcecd49d95dcb03efd909.tar.gz
Revert "linux-yocto: Remove redundant recipes"
This commit renders the romley-ivb unbootable. Reverting it is NOT A FIX, it's just a workaround. We should have a proper fix for this at a later time. This reverts commit 09d485dcce6ed4b654abc0c8a630f1d36bc1a7d6. [LXCR-2923] Signed-off-by: Adrian Dudau <adrian.dudau@enea.com> Signed-off-by: George Nita <george.nita@enea.com>
-rw-r--r--common/recipes-kernel/linux/linux-yocto-dev.bbappend8
-rw-r--r--common/recipes-kernel/linux/linux-yocto_3.10.bbappend8
-rw-r--r--meta-crystalforest/recipes-kernel/linux/linux-yocto_3.10.bbappend20
-rw-r--r--meta-isg/meta-haswell-wc/recipes-kernel/linux/linux-yocto_3.10.bbappend16
-rw-r--r--meta-jasperforest/recipes-kernel/linux/linux-yocto-dev.bbappend10
-rw-r--r--meta-jasperforest/recipes-kernel/linux/linux-yocto_3.10.bbappend12
-rw-r--r--meta-romley/recipes-kernel/linux/linux-yocto_3.10.bbappend21
-rw-r--r--meta-sugarbay/recipes-kernel/linux/linux-yocto-dev.bbappend15
-rw-r--r--meta-sugarbay/recipes-kernel/linux/linux-yocto_3.10.bbappend13
9 files changed, 109 insertions, 14 deletions
diff --git a/common/recipes-kernel/linux/linux-yocto-dev.bbappend b/common/recipes-kernel/linux/linux-yocto-dev.bbappend
index f01933fe..45b6873a 100644
--- a/common/recipes-kernel/linux/linux-yocto-dev.bbappend
+++ b/common/recipes-kernel/linux/linux-yocto-dev.bbappend
@@ -1,6 +1,6 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3KERNEL_FEATURES_INTEL_COMMON += "features/amt/mei/mei.scc" 3KERNEL_FEATURES_INTEL_COMMON = ""
4 4
5LINUX_VERSION_core2-32-intel-common = "3.14-rc8" 5LINUX_VERSION_core2-32-intel-common = "3.14-rc8"
6COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}" 6COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
@@ -17,9 +17,3 @@ SRCREV_machine_corei7-64-intel-common = "fecc3fd7d31bd93766ff4f0431fecdbbfa4c3a7
17KMACHINE_intel-corei7-64-intel-common = "intel-corei7-64" 17KMACHINE_intel-corei7-64-intel-common = "intel-corei7-64"
18KBRANCH_intel-corei7-64-intel-common = "standard/base" 18KBRANCH_intel-corei7-64-intel-common = "standard/base"
19KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" 19KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
20
21# For Crystalforest and Romley
22module_autoload_uio = "uio"
23
24# For FRI2
25module_autoload_iwlwifi = "iwlwifi"
diff --git a/common/recipes-kernel/linux/linux-yocto_3.10.bbappend b/common/recipes-kernel/linux/linux-yocto_3.10.bbappend
index 650919f6..8843e085 100644
--- a/common/recipes-kernel/linux/linux-yocto_3.10.bbappend
+++ b/common/recipes-kernel/linux/linux-yocto_3.10.bbappend
@@ -1,6 +1,6 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3KERNEL_FEATURES_INTEL_COMMON += "features/amt/mei/mei.scc" 3KERNEL_FEATURES_INTEL_COMMON = ""
4 4
5LINUX_VERSION_core2-32-intel-common = "3.10.33" 5LINUX_VERSION_core2-32-intel-common = "3.10.33"
6COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}" 6COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
@@ -17,9 +17,3 @@ SRCREV_machine_corei7-64-intel-common = "21df0c8486e129a4087970a07b423c533ae05de
17KMACHINE_intel-corei7-64-intel-common = "intel-corei7-64" 17KMACHINE_intel-corei7-64-intel-common = "intel-corei7-64"
18KBRANCH_intel-corei7-64-intel-common = "standard/base" 18KBRANCH_intel-corei7-64-intel-common = "standard/base"
19KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" 19KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
20
21# For Crystalforest and Romley
22module_autoload_uio = "uio"
23
24# For FRI2
25module_autoload_iwlwifi = "iwlwifi"
diff --git a/meta-crystalforest/recipes-kernel/linux/linux-yocto_3.10.bbappend b/meta-crystalforest/recipes-kernel/linux/linux-yocto_3.10.bbappend
new file mode 100644
index 00000000..51551ef4
--- /dev/null
+++ b/meta-crystalforest/recipes-kernel/linux/linux-yocto_3.10.bbappend
@@ -0,0 +1,20 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3
4COMPATIBLE_MACHINE_crystalforest-gladden = "crystalforest-gladden"
5KMACHINE_crystalforest-gladden = "crystalforest"
6KBRANCH_crystalforest-gladden = "standard/common-pc-64/crystalforest"
7
8SRCREV_machine_pn-linux-yocto_crystalforest-gladden ?= "c03195ed6e3066494e3fb4be69154a57066e845b"
9SRCREV_meta_pn-linux-yocto_crystalforest-gladden ?= "f1c9080cd27f99700fa59b5375d1ddd0afe625ad"
10
11COMPATIBLE_MACHINE_crystalforest-server = "crystalforest-server"
12KMACHINE_crystalforest-server = "crystalforest"
13KBRANCH_crystalforest-server = "standard/common-pc-64/crystalforest"
14
15SRCREV_machine_pn-linux-yocto_crystalforest-server ?= "a9ec82e355130160f9094e670bd5be0022a84194"
16SRCREV_meta_pn-linux-yocto_crystalforest-server ?= "d9cd83c0292bd4e2a6754a96761027252e726a42"
17
18LINUX_VERSION = "3.10.19"
19
20module_autoload_uio = "uio"
diff --git a/meta-isg/meta-haswell-wc/recipes-kernel/linux/linux-yocto_3.10.bbappend b/meta-isg/meta-haswell-wc/recipes-kernel/linux/linux-yocto_3.10.bbappend
new file mode 100644
index 00000000..0a12121c
--- /dev/null
+++ b/meta-isg/meta-haswell-wc/recipes-kernel/linux/linux-yocto_3.10.bbappend
@@ -0,0 +1,16 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3KMETA = "meta"
4
5COMPATIBLE_MACHINE_haswell-wc = "haswell-wc"
6KMACHINE_haswell-wc = "haswell-wc"
7KBRANCH_haswell-wc = "standard/common-pc-64/base"
8
9KERNEL_FEATURES_haswell-wc += "features/amt/mei"
10
11LINUX_VERSION = "3.10.19"
12
13SRCREV_machine_haswell-wc = "a9ec82e355130160f9094e670bd5be0022a84194"
14SRCREV_meta_haswell-wc = "d9cd83c0292bd4e2a6754a96761027252e726a42"
15
16SRC_URI_haswell-wc = "git://git.yoctoproject.org/linux-yocto-3.10.git;protocol=git;nocheckout=1;branch=${KBRANCH},${KMETA};name=machine,meta"
diff --git a/meta-jasperforest/recipes-kernel/linux/linux-yocto-dev.bbappend b/meta-jasperforest/recipes-kernel/linux/linux-yocto-dev.bbappend
new file mode 100644
index 00000000..5d6f92fd
--- /dev/null
+++ b/meta-jasperforest/recipes-kernel/linux/linux-yocto-dev.bbappend
@@ -0,0 +1,10 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3
4COMPATIBLE_MACHINE_jasperforest = "jasperforest"
5
6KMACHINE_jasperforest = "jasperforest"
7KBRANCH_jasperforest = "standard/common-pc-64/jasperforest"
8
9SRCREV_machine_jasperforest = "60536206ad300ccf5b2be2c2d449f4ab27170238"
10SRCREV_meta_jasperforest = "fe20c99783387dab779472ff50a88666da1c6391"
diff --git a/meta-jasperforest/recipes-kernel/linux/linux-yocto_3.10.bbappend b/meta-jasperforest/recipes-kernel/linux/linux-yocto_3.10.bbappend
new file mode 100644
index 00000000..45ab6b96
--- /dev/null
+++ b/meta-jasperforest/recipes-kernel/linux/linux-yocto_3.10.bbappend
@@ -0,0 +1,12 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3
4COMPATIBLE_MACHINE_jasperforest = "jasperforest"
5
6KMACHINE_jasperforest = "jasperforest"
7KBRANCH_jasperforest = "standard/common-pc-64/jasperforest"
8
9LINUX_VERSION = "3.10.19"
10
11SRCREV_meta_jasperforest = "d9cd83c0292bd4e2a6754a96761027252e726a42"
12SRCREV_machine_jasperforest = "a9ec82e355130160f9094e670bd5be0022a84194"
diff --git a/meta-romley/recipes-kernel/linux/linux-yocto_3.10.bbappend b/meta-romley/recipes-kernel/linux/linux-yocto_3.10.bbappend
new file mode 100644
index 00000000..6fc0682d
--- /dev/null
+++ b/meta-romley/recipes-kernel/linux/linux-yocto_3.10.bbappend
@@ -0,0 +1,21 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3
4COMPATIBLE_MACHINE_romley = "romley"
5
6KMACHINE_romley = "romley"
7KBRANCH_romley = "standard/common-pc-64/romley"
8
9SRCREV_machine_pn-linux-yocto_romley ?= "c03195ed6e3066494e3fb4be69154a57066e845b"
10SRCREV_meta_pn-linux-yocto_romley ?= "f1c9080cd27f99700fa59b5375d1ddd0afe625ad"
11
12COMPATIBLE_MACHINE_romley-ivb = "romley-ivb"
13KMACHINE_romley-ivb = "romley"
14KBRANCH_romley-ivb = "standard/common-pc-64/romley"
15
16SRCREV_machine_pn-linux-yocto_romley-ivb ?= "a9ec82e355130160f9094e670bd5be0022a84194"
17SRCREV_meta_pn-linux-yocto_romley-ivb ?= "d9cd83c0292bd4e2a6754a96761027252e726a42"
18
19LINUX_VERSION = "3.10.19"
20
21module_autoload_uio = "uio"
diff --git a/meta-sugarbay/recipes-kernel/linux/linux-yocto-dev.bbappend b/meta-sugarbay/recipes-kernel/linux/linux-yocto-dev.bbappend
new file mode 100644
index 00000000..f09fbf60
--- /dev/null
+++ b/meta-sugarbay/recipes-kernel/linux/linux-yocto-dev.bbappend
@@ -0,0 +1,15 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3
4COMPATIBLE_MACHINE_sugarbay = "sugarbay"
5
6KMACHINE_sugarbay = "sugarbay"
7KBRANCH_sugarbay = "standard/common-pc-64/sugarbay"
8
9LINUX_VERSION = "3.12.0"
10
11SRCREV_meta_sugarbay = "75feecae0382601045f508bcce104b3d4af1923d"
12SRCREV_machine_sugarbay = "1f274173a8335dc27daabd9d9fe2e19a8b3978d1"
13
14SRCREV_machine_sugarbay = "60536206ad300ccf5b2be2c2d449f4ab27170238"
15SRCREV_meta_sugarbay = "fe20c99783387dab779472ff50a88666da1c6391"
diff --git a/meta-sugarbay/recipes-kernel/linux/linux-yocto_3.10.bbappend b/meta-sugarbay/recipes-kernel/linux/linux-yocto_3.10.bbappend
new file mode 100644
index 00000000..8811fca5
--- /dev/null
+++ b/meta-sugarbay/recipes-kernel/linux/linux-yocto_3.10.bbappend
@@ -0,0 +1,13 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3
4COMPATIBLE_MACHINE_sugarbay = "sugarbay"
5
6KMACHINE_sugarbay = "sugarbay"
7KBRANCH_sugarbay = "standard/common-pc-64/sugarbay"
8KERNEL_FEATURES_append_sugarbay = " features/media/media-usb-webcams.scc"
9
10LINUX_VERSION = "3.10.19"
11
12SRCREV_meta_sugarbay = "d9cd83c0292bd4e2a6754a96761027252e726a42"
13SRCREV_machine_sugarbay = "a9ec82e355130160f9094e670bd5be0022a84194"