summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDarren Hart <dvhart@linux.intel.com>2014-03-25 14:04:21 -0700
committerDarren Hart <dvhart@linux.intel.com>2014-03-25 14:04:21 -0700
commita1491bc54b60a1c622a9060756fd9b145bc01378 (patch)
tree9d902aa8fdb3fcc121e076c2dcebbc0fe7e7702f
parentf122b5a10114416c55d015305fdd011d86e71353 (diff)
downloadmeta-intel-a1491bc54b60a1c622a9060756fd9b145bc01378.tar.gz
linux-yocto-dev: Specify SRC_REVs for intel-core* machines
The automatic SRCREV AUTOREV anonymous python in linux-yocto-dev.bb will only trigger on the PREFERRED_PROVIDER_virtual/kernel being linux-yocto-dev if it is set in local.conf, or a similar file parsed prior to itself. Since these two machines currently specify linux-yocto-dev in the machine configuration, the AUTOREV doesn't trigger - and we do not want AUTOREV specified in the recipe itself to avoid breakage in the event of no network access. This is a bizarre little corner case as machines typically do not specify linux-yocto-dev. For the time being, fix the do_fetch failure by specifying SRCREVs for the two intel-core* machines. Users who want AUTOREV can specify THAT in their local.conf. This way it doesn't break out of the box. Signed-off-by: Darren Hart <dvhart@linux.intel.com>
-rw-r--r--common/recipes-kernel/linux/linux-yocto-dev.bbappend12
1 files changed, 6 insertions, 6 deletions
diff --git a/common/recipes-kernel/linux/linux-yocto-dev.bbappend b/common/recipes-kernel/linux/linux-yocto-dev.bbappend
index 56bcecc2..f01933fe 100644
--- a/common/recipes-kernel/linux/linux-yocto-dev.bbappend
+++ b/common/recipes-kernel/linux/linux-yocto-dev.bbappend
@@ -2,18 +2,18 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3KERNEL_FEATURES_INTEL_COMMON += "features/amt/mei/mei.scc" 3KERNEL_FEATURES_INTEL_COMMON += "features/amt/mei/mei.scc"
4 4
5#LINUX_VERSION_core2-32-intel-common = "3.13" 5LINUX_VERSION_core2-32-intel-common = "3.14-rc8"
6COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}" 6COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
7#SRCREV_meta_core2-32-intel-common = "${AUTOREV}" 7SRCREV_meta_core2-32-intel-common = "3689f99f4d2a051e8d3ff72345a67d4d04a88020"
8#SRCREV_machine_core2-32-intel-common = "${AUTOREV}" 8SRCREV_machine_core2-32-intel-common = "fecc3fd7d31bd93766ff4f0431fecdbbfa4c3a7c"
9KMACHINE_core2-32-intel-common = "intel-core2-32" 9KMACHINE_core2-32-intel-common = "intel-core2-32"
10KBRANCH_core2-32-intel-common = "standard/base" 10KBRANCH_core2-32-intel-common = "standard/base"
11KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" 11KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
12 12
13#LINUX_VERSION_corei7-64-intel-common = "3.13" 13LINUX_VERSION_corei7-64-intel-common = "3.14-rc8"
14COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}" 14COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}"
15#SRCREV_meta_corei7-64-intel-common = "${AUTOREV}" 15SRCREV_meta_corei7-64-intel-common = "3689f99f4d2a051e8d3ff72345a67d4d04a88020"
16#SRCREV_machine_corei7-64-intel-common = "${AUTOREV}" 16SRCREV_machine_corei7-64-intel-common = "fecc3fd7d31bd93766ff4f0431fecdbbfa4c3a7c"
17KMACHINE_intel-corei7-64-intel-common = "intel-corei7-64" 17KMACHINE_intel-corei7-64-intel-common = "intel-corei7-64"
18KBRANCH_intel-corei7-64-intel-common = "standard/base" 18KBRANCH_intel-corei7-64-intel-common = "standard/base"
19KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" 19KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"