summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2014-04-01 14:59:56 -0700
committerTom Zanussi <tom.zanussi@intel.com>2014-04-04 08:57:49 -0500
commit46ac8a922c7165813c91b64ec0588d30b0887e2e (patch)
tree175b13fefccd9012faef3d477a79ae96d83bb07e
parent2b717f47ba15c4baadc173522897c20752ed7a51 (diff)
downloadmeta-intel-46ac8a922c7165813c91b64ec0588d30b0887e2e.tar.gz
linux-yocto_3.14: common recipe for meta-intel BSPs
Extend the linux-yocto_3.14 recipe from poky layer to meta-intel layer. This kernel recipe is shared by multiple BSPs from the meta-intel layer. Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
-rw-r--r--common/recipes-kernel/linux/linux-yocto_3.14.bbappend26
1 files changed, 26 insertions, 0 deletions
diff --git a/common/recipes-kernel/linux/linux-yocto_3.14.bbappend b/common/recipes-kernel/linux/linux-yocto_3.14.bbappend
new file mode 100644
index 00000000..0add0803
--- /dev/null
+++ b/common/recipes-kernel/linux/linux-yocto_3.14.bbappend
@@ -0,0 +1,26 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3# For NUC
4KERNEL_FEATURES_INTEL_COMMON += "features/amt/mei/mei.scc"
5
6LINUX_VERSION_core2-32-intel-common = "3.14.0"
7COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
8SRCREV_meta_core2-32-intel-common = "fc8c30398dbc3cdea787a1042242d4aab689d0ae"
9SRCREV_machine_core2-32-intel-common = "0143c6ebb4a2d63b241df5f608b19f483f7eb9e0"
10KMACHINE_core2-32-intel-common = "intel-core2-32"
11KBRANCH_core2-32-intel-common = "standard/base"
12KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
13
14LINUX_VERSION_corei7-64-intel-common = "3.14.0"
15COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}"
16SRCREV_meta_corei7-64-intel-common = "fc8c30398dbc3cdea787a1042242d4aab689d0ae"
17SRCREV_machine_corei7-64-intel-common = "0143c6ebb4a2d63b241df5f608b19f483f7eb9e0"
18KMACHINE_intel-corei7-64-intel-common = "intel-corei7-64"
19KBRANCH_intel-corei7-64-intel-common = "standard/base"
20KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
21
22# For Crystalforest and Romley
23module_autoload_uio = "uio"
24
25# For FRI2, NUC
26module_autoload_iwlwifi = "iwlwifi"