summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2013-03-04 11:42:30 -0800
committerTom Zanussi <tom.zanussi@intel.com>2013-03-06 15:36:16 -0600
commitb9617591ab3d6fbd74e058de3d6fa1954bb034d5 (patch)
tree750dfe0eeccebf3212a69350b75eac3a387f2631
parent530251f114ee26d865ede90b5f1eba6ab3098abf (diff)
downloadmeta-intel-b9617591ab3d6fbd74e058de3d6fa1954bb034d5.tar.gz
sys940x: linux-yocto_3.8 recipe extension
Provide the sys940x BSP specific extension for the linux-yocto_3.8 recipe from the oecore layer. This configures the right git branches of the kernel repository for the sys940x BSP. Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
-rw-r--r--meta-sys940x/recipes-kernel/linux/linux-yocto_3.8.bbappend22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-sys940x/recipes-kernel/linux/linux-yocto_3.8.bbappend b/meta-sys940x/recipes-kernel/linux/linux-yocto_3.8.bbappend
new file mode 100644
index 00000000..7bb50c32
--- /dev/null
+++ b/meta-sys940x/recipes-kernel/linux/linux-yocto_3.8.bbappend
@@ -0,0 +1,22 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3KMETA = "meta"
4
5COMPATIBLE_MACHINE_sys940x = "sys940x"
6KMACHINE_sys940x = "sys940x"
7KBRANCH_sys940x = "standard/sys940x"
8KERNEL_FEATURES_sys940x = " features/drm-emgd/drm-emgd-1.16"
9
10COMPATIBLE_MACHINE_sys940x-noemgd = "sys940x-noemgd"
11KMACHINE_sys940x-noemgd = "sys940x"
12KBRANCH_sys940x-noemgd = "standard/sys940x"
13KERNEL_FEATURES_sys940x-noemgd = " cfg/vesafb"
14
15SRCREV_meta_sys940x = "c2ed0f16fdec628242a682897d5d86df4547cf24"
16SRCREV_machine_sys940x = "b170394a475b96ecc92cbc9e4b002bed0a9f69c5"
17SRCREV_emgd_sys940x = "caea08c988e0f41103bbe18eafca20348f95da02"
18
19SRCREV_meta_sys940x-noemgd = "c2ed0f16fdec628242a682897d5d86df4547cf24"
20SRCREV_machine_sys940x-noemgd = "b170394a475b96ecc92cbc9e4b002bed0a9f69c5"
21
22SRC_URI_sys940x = "git://git.yoctoproject.org/linux-yocto-3.8.git;protocol=git;nocheckout=1;branch=${KBRANCH},${KMETA},emgd-1.16;name=machine,meta,emgd"