summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2013-01-11 09:33:23 -0800
committerTom Zanussi <tom.zanussi@intel.com>2013-01-19 12:54:19 -0600
commit8e200220c256c522d115e3ef9ea0a39416bc8c8d (patch)
tree64f7df5e8dd379f50dde957999a158b6b1e41300
parentb21c9ea929c4ab39dbb24b4225df94dbbb21e19f (diff)
downloadmeta-intel-8e200220c256c522d115e3ef9ea0a39416bc8c8d.tar.gz
fri2: specify graphics driver as a kernel feature
This change avoids addition of emgd source code in the noemgd bsp kernels. This configures the fri2 BSP kernel with EMGD graphics driver and fri2-noemgd BSP kernel with VESA graphics driver. The VESA FB support is kept for both BSPs for boot time splash screen support. This addresses the bug/feature request: [YOCTO #2268] Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
-rw-r--r--meta-fri2/recipes-kernel/linux/linux-yocto_3.4.bbappend2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-fri2/recipes-kernel/linux/linux-yocto_3.4.bbappend b/meta-fri2/recipes-kernel/linux/linux-yocto_3.4.bbappend
index 814d08e2..25431a15 100644
--- a/meta-fri2/recipes-kernel/linux/linux-yocto_3.4.bbappend
+++ b/meta-fri2/recipes-kernel/linux/linux-yocto_3.4.bbappend
@@ -3,12 +3,14 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
3COMPATIBLE_MACHINE_fri2 = "fri2" 3COMPATIBLE_MACHINE_fri2 = "fri2"
4KMACHINE_fri2 = "fri2" 4KMACHINE_fri2 = "fri2"
5KBRANCH_fri2 = "standard/fri2" 5KBRANCH_fri2 = "standard/fri2"
6KERNEL_FEATURES_fri2_append = " features/drm-emgd cfg/vesfb"
6SRCREV_machine_pn-linux-yocto_fri2 ?= "${AUTOREV}" 7SRCREV_machine_pn-linux-yocto_fri2 ?= "${AUTOREV}"
7SRCREV_meta_pn-linux-yocto_fri2 ?= "${AUTOREV}" 8SRCREV_meta_pn-linux-yocto_fri2 ?= "${AUTOREV}"
8 9
9COMPATIBLE_MACHINE_fri2-noemgd = "fri2-noemgd" 10COMPATIBLE_MACHINE_fri2-noemgd = "fri2-noemgd"
10KMACHINE_fri2-noemgd = "fri2" 11KMACHINE_fri2-noemgd = "fri2"
11KBRANCH_fri2-noemgd = "standard/fri2" 12KBRANCH_fri2-noemgd = "standard/fri2"
13KERNEL_FEATURES_fri2_append = " cfg/vesafb"
12SRCREV_machine_pn-linux-yocto_fri2-noemgd ?= "${AUTOREV}" 14SRCREV_machine_pn-linux-yocto_fri2-noemgd ?= "${AUTOREV}"
13SRCREV_meta_pn-linux-yocto_fri2-noemgd ?= "${AUTOREV}" 15SRCREV_meta_pn-linux-yocto_fri2-noemgd ?= "${AUTOREV}"
14 16