summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2013-01-10 18:30:57 -0800
committerTom Zanussi <tom.zanussi@intel.com>2013-01-19 12:53:25 -0600
commit4a7cea9dc33da7266032006fbac971562b0365cb (patch)
treed79e8d40af7d279fdbaf75f31870181f88ccc3d5
parentdd6c3d3b19503e8b25e7e5c67e441ffe726426af (diff)
downloadmeta-intel-4a7cea9dc33da7266032006fbac971562b0365cb.tar.gz
crownbay: specify graphics driver as a kernel feature
This change avoids addition of emgd source code in the noemgd bsp kernels. This configures the crownbay BSP kernel with EMGD graphics driver and crownbay-noemgd BSP kernel with just the VESA graphics driver. The VESA FB support is kept for both BSPs for boot time splash screen support. This addresses the bug/feature request: [YOCTO #2268] Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
-rw-r--r--meta-crownbay/recipes-kernel/linux/linux-yocto_3.4.bbappend2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-crownbay/recipes-kernel/linux/linux-yocto_3.4.bbappend b/meta-crownbay/recipes-kernel/linux/linux-yocto_3.4.bbappend
index f00b56ee..f189f5ba 100644
--- a/meta-crownbay/recipes-kernel/linux/linux-yocto_3.4.bbappend
+++ b/meta-crownbay/recipes-kernel/linux/linux-yocto_3.4.bbappend
@@ -3,10 +3,12 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
3COMPATIBLE_MACHINE_crownbay = "crownbay" 3COMPATIBLE_MACHINE_crownbay = "crownbay"
4KMACHINE_crownbay = "crownbay" 4KMACHINE_crownbay = "crownbay"
5KBRANCH_crownbay = "standard/crownbay" 5KBRANCH_crownbay = "standard/crownbay"
6KERNEL_FEATURES_crownbay_append = " features/drm-emgd cfg/vesafb"
6 7
7COMPATIBLE_MACHINE_crownbay-noemgd = "crownbay-noemgd" 8COMPATIBLE_MACHINE_crownbay-noemgd = "crownbay-noemgd"
8KMACHINE_crownbay-noemgd = "crownbay" 9KMACHINE_crownbay-noemgd = "crownbay"
9KBRANCH_crownbay-noemgd = "standard/crownbay" 10KBRANCH_crownbay-noemgd = "standard/crownbay"
11KERNEL_FEATURES_crownbay-noemgd_append = " cfg/vesafb"
10 12
11SRCREV_machine_pn-linux-yocto_crownbay ?= "${AUTOREV}" 13SRCREV_machine_pn-linux-yocto_crownbay ?= "${AUTOREV}"
12SRCREV_meta_pn-linux-yocto_crownbay ?= "${AUTOREV}" 14SRCREV_meta_pn-linux-yocto_crownbay ?= "${AUTOREV}"