summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2013-01-16 14:51:03 -0800
committerTom Zanussi <tom.zanussi@intel.com>2013-01-19 16:18:34 -0600
commit01c6f60ae68b98968c8425493bfe7608fdf41bcc (patch)
tree5d4ff882c479b6fbd90728f5473f85a1912bb698
parent417825f175d9f5c4a1b25d309323c6d809c98047 (diff)
downloadmeta-intel-01c6f60ae68b98968c8425493bfe7608fdf41bcc.tar.gz
emenlow-noemgd: create a new BSP
This is based on the gma500/gma600 kernel driver and the modesetting X driver for poulsbo graphics. The gma500 driver needs soft cursor in X. Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
-rw-r--r--meta-emenlow/conf/machine/emenlow-noemgd.conf16
-rw-r--r--meta-emenlow/recipes-bsp/formfactor/formfactor/emenlow-noemgd/machconfig3
-rw-r--r--meta-emenlow/recipes-graphics/xorg-xserver/xserver-xf86-config/emenlow-noemgd/xorg.conf27
-rw-r--r--meta-emenlow/recipes-kernel/linux/linux-yocto_3.4.bbappend11
4 files changed, 57 insertions, 0 deletions
diff --git a/meta-emenlow/conf/machine/emenlow-noemgd.conf b/meta-emenlow/conf/machine/emenlow-noemgd.conf
new file mode 100644
index 00000000..9a995c12
--- /dev/null
+++ b/meta-emenlow/conf/machine/emenlow-noemgd.conf
@@ -0,0 +1,16 @@
1#@TYPE: Machine
2#@NAME: emenlow-noemgd
3
4#@WEBTITLE: Intel Atom Z5xx Processor With Intel US15W Controller Hub (eMenlow) with open source graphics
5
6#@DESCRIPTION: Machine configuration for eMenlow based systems, like the Webs-2120 box, without the Intel-proprietary graphics bits
7
8PREFERRED_VERSION_linux-yocto ?= "3.4%"
9
10require conf/machine/include/tune-atom.inc
11require conf/machine/include/ia32-base.inc
12
13XSERVER ?= "${XSERVER_IA32_BASE} \
14 ${XSERVER_IA32_EXT} \
15 ${XSERVER_IA32_MODESETTING} \
16 "
diff --git a/meta-emenlow/recipes-bsp/formfactor/formfactor/emenlow-noemgd/machconfig b/meta-emenlow/recipes-bsp/formfactor/formfactor/emenlow-noemgd/machconfig
new file mode 100644
index 00000000..ffce0122
--- /dev/null
+++ b/meta-emenlow/recipes-bsp/formfactor/formfactor/emenlow-noemgd/machconfig
@@ -0,0 +1,3 @@
1# Assume a USB mouse and keyboard are connected
2HAVE_TOUCHSCREEN=0
3HAVE_KEYBOARD=1
diff --git a/meta-emenlow/recipes-graphics/xorg-xserver/xserver-xf86-config/emenlow-noemgd/xorg.conf b/meta-emenlow/recipes-graphics/xorg-xserver/xserver-xf86-config/emenlow-noemgd/xorg.conf
new file mode 100644
index 00000000..aa6f32b4
--- /dev/null
+++ b/meta-emenlow/recipes-graphics/xorg-xserver/xserver-xf86-config/emenlow-noemgd/xorg.conf
@@ -0,0 +1,27 @@
1Section "Device"
2 Identifier "gma500"
3 Driver "modesetting"
4 Option "SWCursor" "ON"
5EndSection
6
7Section "Monitor"
8 Identifier "Generic Monitor"
9 Option "DPMS"
10EndSection
11
12Section "Screen"
13 Identifier "Default Screen"
14 Device "gma500"
15 Monitor "Generic Monitor"
16 DefaultDepth 24
17EndSection
18
19Section "ServerLayout"
20 Identifier "Default Layout"
21 Screen "Default Screen"
22EndSection
23
24Section "ServerFlags"
25 Option "DontZap" "0"
26 Option "AutoAddDevices" "False"
27EndSection
diff --git a/meta-emenlow/recipes-kernel/linux/linux-yocto_3.4.bbappend b/meta-emenlow/recipes-kernel/linux/linux-yocto_3.4.bbappend
index d0306bc7..d3700240 100644
--- a/meta-emenlow/recipes-kernel/linux/linux-yocto_3.4.bbappend
+++ b/meta-emenlow/recipes-kernel/linux/linux-yocto_3.4.bbappend
@@ -5,5 +5,16 @@ KMACHINE_emenlow = "emenlow"
5KBRANCH_emenlow = "standard/emenlow" 5KBRANCH_emenlow = "standard/emenlow"
6KERNEL_FEATURES_emenlow_append = " features/drm-emgd cfg/vesafb" 6KERNEL_FEATURES_emenlow_append = " features/drm-emgd cfg/vesafb"
7 7
8COMPATIBLE_MACHINE_emenlow-noemgd = "emenlow-noemgd"
9KMACHINE_emenlow-noemgd = "emenlow"
10KBRANCH_emenlow-noemgd = "standard/emenlow"
11KERNEL_FEATURES_emenlow-noemgd_append = " features/drm-gma500/drm-gma600"
12
8SRCREV_machine_pn-linux-yocto_emenlow ?= "${AUTOREV}" 13SRCREV_machine_pn-linux-yocto_emenlow ?= "${AUTOREV}"
9SRCREV_meta_pn-linux-yocto_emenlow ?= "${AUTOREV}" 14SRCREV_meta_pn-linux-yocto_emenlow ?= "${AUTOREV}"
15SRCREV_emgd_pn-linux-yocto_emenlow ?= "${AUTOREV}"
16
17SRCREV_machine_pn-linux-yocto_emenlow-noemgd ?= "${AUTOREV}"
18SRCREV_meta_pn-linux-yocto_emenlow-noemgd ?= "${AUTOREV}"
19
20SRC_URI_emenlow = "git://git.yoctoproject.org/linux-yocto-3.4.git;protocol=git;nocheckout=1;branch=${KBRANCH},${KMETA},emgd-1.14;name=machine,meta,emgd"