diff options
author | Saul Wold <sgw@linux.intel.com> | 2017-04-17 08:54:05 -0700 |
---|---|---|
committer | Saul Wold <sgw@linux.intel.com> | 2017-04-17 10:11:00 -0700 |
commit | c7e6889290901f4878f4bfc2180743d0870e55ba (patch) | |
tree | 113a7ba43b13111fda8fccf291502dbe1a1116d8 | |
parent | ce7112153464c3500e1eb6b8b890218f27170e31 (diff) | |
download | meta-intel-c7e6889290901f4878f4bfc2180743d0870e55ba.tar.gz |
core-image-rt: Add yocto-intel-rt based recipes
These recipes depend on using an RT kernel, since the name in oe-core
is hard-coded to linux-yocto-rt, we need to replicate those recipes here
or come up with an additional variable to check.
Signed-off-by: Saul Wold <sgw@linux.intel.com>
-rw-r--r-- | common/recipes-rt/images/core-image-rt-sdk.bb | 20 | ||||
-rw-r--r-- | common/recipes-rt/images/core-image-rt.bb | 17 |
2 files changed, 37 insertions, 0 deletions
diff --git a/common/recipes-rt/images/core-image-rt-sdk.bb b/common/recipes-rt/images/core-image-rt-sdk.bb new file mode 100644 index 00000000..6b43a872 --- /dev/null +++ b/common/recipes-rt/images/core-image-rt-sdk.bb | |||
@@ -0,0 +1,20 @@ | |||
1 | require recipes-core/images/core-image-minimal.bb | ||
2 | |||
3 | # Skip processing of this recipe if linux-intel-rt is not explicitly specified as the | ||
4 | # PREFERRED_PROVIDER for virtual/kernel. This avoids errors when trying | ||
5 | # to build multiple virtual/kernel providers. | ||
6 | python () { | ||
7 | if d.getVar("PREFERRED_PROVIDER_virtual/kernel") != "linux-intel-rt": | ||
8 | raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-intel-rt to enable it") | ||
9 | } | ||
10 | |||
11 | DESCRIPTION = "Small image capable of booting a device with a test suite and \ | ||
12 | tools for real-time use. It includes the full meta-toolchain, development \ | ||
13 | headers and libraries to form a standalone SDK." | ||
14 | DEPENDS = "linux-intel-rt" | ||
15 | |||
16 | IMAGE_FEATURES += "dev-pkgs tools-sdk tools-debug eclipse-debug tools-profile tools-testapps debug-tweaks" | ||
17 | |||
18 | IMAGE_INSTALL += "rt-tests hwlatdetect kernel-dev" | ||
19 | |||
20 | LICENSE = "MIT" | ||
diff --git a/common/recipes-rt/images/core-image-rt.bb b/common/recipes-rt/images/core-image-rt.bb new file mode 100644 index 00000000..4db0a579 --- /dev/null +++ b/common/recipes-rt/images/core-image-rt.bb | |||
@@ -0,0 +1,17 @@ | |||
1 | require recipes-core/images/core-image-minimal.bb | ||
2 | |||
3 | # Skip processing of this recipe if linux-intel-rt is not explicitly specified as the | ||
4 | # PREFERRED_PROVIDER for virtual/kernel. This avoids errors when trying | ||
5 | # to build multiple virtual/kernel providers. | ||
6 | python () { | ||
7 | if d.getVar("PREFERRED_PROVIDER_virtual/kernel") != "linux-intel-rt": | ||
8 | raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-intel-rt to enable it") | ||
9 | } | ||
10 | |||
11 | DESCRIPTION = "A small image just capable of allowing a device to boot plus a \ | ||
12 | real-time test suite and tools appropriate for real-time use." | ||
13 | DEPENDS = "linux-intel-rt" | ||
14 | |||
15 | IMAGE_INSTALL += "rt-tests hwlatdetect" | ||
16 | |||
17 | LICENSE = "MIT" | ||