diff options
author | Anuj Mittal <anuj.mittal@intel.com> | 2018-11-24 11:30:46 +0800 |
---|---|---|
committer | Anuj Mittal <anuj.mittal@intel.com> | 2018-12-05 14:42:27 +0800 |
commit | 13ae1339c24a5d431274bdd324048f1043045ae5 (patch) | |
tree | 6141b8f56c85dae757c370e5811930e0635714cc | |
parent | f7a9272983abac3a5269286f8d214765f49af656 (diff) | |
download | meta-intel-13ae1339c24a5d431274bdd324048f1043045ae5.tar.gz |
linux-intel/4.19: add recipe
Builds 4.19/base from linux-intel-lts.
Include a patch from linux-yocto 4.18 to detect ncurses correctly when
cross-compiling and move the older patch to version specific recipes
from inc.
In addition to intel-common kernel configs from yocto-kernel-cache, this
also includes security.scc feature which enables a set of configs with
the aim of reducing the kernel attack surface and/or of performing
additional checks and validation of commonly used structures in kernel.
Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
5 files changed, 76 insertions, 2 deletions
diff --git a/recipes-kernel/linux/linux-intel.inc b/recipes-kernel/linux/linux-intel.inc index 2525c70d..f2ba0d13 100644 --- a/recipes-kernel/linux/linux-intel.inc +++ b/recipes-kernel/linux/linux-intel.inc | |||
@@ -7,7 +7,6 @@ KERNEL_CONFIG_URI ?= "git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;n | |||
7 | 7 | ||
8 | SRC_URI = " \ | 8 | SRC_URI = " \ |
9 | git://github.com/intel/linux-intel-lts.git;protocol=https;name=machine;branch=${KBRANCH}; \ | 9 | git://github.com/intel/linux-intel-lts.git;protocol=https;name=machine;branch=${KBRANCH}; \ |
10 | file://0001-menuconfig-check-lxdiaglog.sh-Allow-specification-of.patch \ | ||
11 | ${KERNEL_CONFIG_URI} \ | 10 | ${KERNEL_CONFIG_URI} \ |
12 | " | 11 | " |
13 | 12 | ||
diff --git a/recipes-kernel/linux/linux-intel/0001-menuconfig-mconf-cfg-Allow-specification-of-ncurses-.patch b/recipes-kernel/linux/linux-intel/0001-menuconfig-mconf-cfg-Allow-specification-of-ncurses-.patch new file mode 100644 index 00000000..3dc71ff2 --- /dev/null +++ b/recipes-kernel/linux/linux-intel/0001-menuconfig-mconf-cfg-Allow-specification-of-ncurses-.patch | |||
@@ -0,0 +1,48 @@ | |||
1 | From bebd63730a433ba62549a80114a9851328aa8897 Mon Sep 17 00:00:00 2001 | ||
2 | From: Bruce Ashfield <bruce.ashfield@windriver.com> | ||
3 | Date: Mon, 2 Jul 2018 23:10:28 -0400 | ||
4 | Subject: [PATCH] menuconfig,mconf-cfg: Allow specification of ncurses location | ||
5 | |||
6 | In some cross build environments such as the Yocto Project build | ||
7 | environment it provides an ncurses library that is compiled | ||
8 | differently than the host's version. This causes display corruption | ||
9 | problems when the host's curses includes are used instead of the | ||
10 | includes from the provided compiler are overridden. There is a second | ||
11 | case where there is no curses libraries at all on the host system and | ||
12 | menuconfig will just fail entirely. | ||
13 | |||
14 | The solution is simply to allow an override variable in | ||
15 | check-lxdialog.sh for environments such as the Yocto Project. Adding | ||
16 | a CROSS_CURSES_LIB and CROSS_CURSES_INC solves the issue and allowing | ||
17 | compiling and linking against the right headers and libraries. | ||
18 | |||
19 | Signed-off-by: Jason Wessel <jason.wessel@windriver.com> | ||
20 | cc: Michal Marek <mmarek@suse.cz> | ||
21 | cc: linux-kbuild@vger.kernel.org | ||
22 | Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> | ||
23 | --- | ||
24 | scripts/kconfig/mconf-cfg.sh | 8 ++++++++ | ||
25 | 1 file changed, 8 insertions(+) | ||
26 | |||
27 | diff --git a/scripts/kconfig/mconf-cfg.sh b/scripts/kconfig/mconf-cfg.sh | ||
28 | index c812872d7f9d..42d20819025c 100755 | ||
29 | --- a/scripts/kconfig/mconf-cfg.sh | ||
30 | +++ b/scripts/kconfig/mconf-cfg.sh | ||
31 | @@ -4,6 +4,14 @@ | ||
32 | PKG="ncursesw" | ||
33 | PKG2="ncurses" | ||
34 | |||
35 | +if [ "$CROSS_CURSES_LIB" != "" ]; then | ||
36 | + echo libs=\'$CROSS_CURSES_LIB\' | ||
37 | + if [ x"$CROSS_CURSES_INC" != x ]; then | ||
38 | + echo cflags=\'$CROSS_CURSES_INC\' | ||
39 | + fi | ||
40 | + exit 0 | ||
41 | +fi | ||
42 | + | ||
43 | if [ -n "$(command -v pkg-config)" ]; then | ||
44 | if pkg-config --exists $PKG; then | ||
45 | echo cflags=\"$(pkg-config --cflags $PKG)\" | ||
46 | -- | ||
47 | 2.17.1 | ||
48 | |||
diff --git a/recipes-kernel/linux/linux-intel_4.14.bb b/recipes-kernel/linux/linux-intel_4.14.bb index c678e955..d371c1ee 100644 --- a/recipes-kernel/linux/linux-intel_4.14.bb +++ b/recipes-kernel/linux/linux-intel_4.14.bb | |||
@@ -4,7 +4,9 @@ KBRANCH = "4.14/base" | |||
4 | KMETA_BRANCH = "yocto-4.14" | 4 | KMETA_BRANCH = "yocto-4.14" |
5 | 5 | ||
6 | # Fix for 32-bit perf issue. Remove when patch is backported to 4.14. | 6 | # Fix for 32-bit perf issue. Remove when patch is backported to 4.14. |
7 | SRC_URI_append = " file://0001-perf-x86-32-explicitly-include-errno.h.patch" | 7 | SRC_URI_append = " file://0001-perf-x86-32-explicitly-include-errno.h.patch \ |
8 | file://0001-menuconfig-check-lxdiaglog.sh-Allow-specification-of.patch \ | ||
9 | " | ||
8 | 10 | ||
9 | DEPENDS += "elfutils-native openssl-native util-linux-native" | 11 | DEPENDS += "elfutils-native openssl-native util-linux-native" |
10 | 12 | ||
diff --git a/recipes-kernel/linux/linux-intel_4.19.bb b/recipes-kernel/linux/linux-intel_4.19.bb new file mode 100644 index 00000000..02353d26 --- /dev/null +++ b/recipes-kernel/linux/linux-intel_4.19.bb | |||
@@ -0,0 +1,21 @@ | |||
1 | require linux-intel.inc | ||
2 | |||
3 | KBRANCH = "4.19/base" | ||
4 | KMETA_BRANCH = "yocto-4.19" | ||
5 | |||
6 | LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814" | ||
7 | |||
8 | SRC_URI_append = " file://0001-menuconfig-mconf-cfg-Allow-specification-of-ncurses-.patch" | ||
9 | |||
10 | DEPENDS += "elfutils-native openssl-native util-linux-native" | ||
11 | |||
12 | LINUX_VERSION ?= "4.19.0" | ||
13 | SRCREV_machine ?= "a13be70e5ba050d848fc4005add46ca89bb8e6e6" | ||
14 | SRCREV_meta ?= "26bfb042ebb6e4816c5a8ce85d97a55e763430c7" | ||
15 | |||
16 | # For Crystalforest and Romley | ||
17 | KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " uio" | ||
18 | KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " uio" | ||
19 | |||
20 | # Functionality flags | ||
21 | KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc features/security/security.scc" | ||
diff --git a/recipes-kernel/linux/linux-intel_4.9.bb b/recipes-kernel/linux/linux-intel_4.9.bb index e2f1eaad..30db4d34 100644 --- a/recipes-kernel/linux/linux-intel_4.9.bb +++ b/recipes-kernel/linux/linux-intel_4.9.bb | |||
@@ -4,6 +4,10 @@ require linux-intel.inc | |||
4 | KBRANCH = "4.9/yocto/base" | 4 | KBRANCH = "4.9/yocto/base" |
5 | KMETA_BRANCH = "yocto-4.9" | 5 | KMETA_BRANCH = "yocto-4.9" |
6 | 6 | ||
7 | SRC_URI_append = " \ | ||
8 | file://0001-menuconfig-check-lxdiaglog.sh-Allow-specification-of.patch \ | ||
9 | " | ||
10 | |||
7 | LINUX_VERSION ?= "4.9.134" | 11 | LINUX_VERSION ?= "4.9.134" |
8 | SRCREV_machine ?= "33c9f20d1f40e87af4ccaf55c0fabb89b068d6ab" | 12 | SRCREV_machine ?= "33c9f20d1f40e87af4ccaf55c0fabb89b068d6ab" |
9 | SRCREV_meta ?= "f9e90afd4e47920e990dacb73cd6508917ca5422" | 13 | SRCREV_meta ?= "f9e90afd4e47920e990dacb73cd6508917ca5422" |