summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Zanussi <tom.zanussi@intel.com>2011-11-26 14:22:10 -0600
committerTom Zanussi <tom.zanussi@intel.com>2011-12-01 22:20:24 -0600
commita5e14b926154ea2b737b469e9ade918bbf59af5e (patch)
tree3f70c648448734c088642c28f136c0ade1778c3f
parent95baa601e71fc493fcf428c7331a087816416475 (diff)
downloadmeta-intel-a5e14b926154ea2b737b469e9ade918bbf59af5e.tar.gz
libva: new recipe for video acceleration
This adds the libva_1.0.10 recipe based on the poky-contrib recipe by Yu Ke (commit msg copied below). The original recipe was in meta/recipes-graphics; this patch moves it to meta-intel/recipes-multimedia since it's multimedia- and Intel-specific. The original commit messages (indented): libva: add new recpies libva libva is a library implementation of "Video Acceleration (VA) API for Linux". libva enables and provides access to graphics hardware (GPU) acceleration for video processing on Linux and UNIX, includes video decoding, video encoding, subpicture blending and rendering. This patch add the libva recipes. Signed-off-by: Yu Ke <ke.yu@intel.com> libva: install some missing .so files Signed-off-by: Dexuan Cui <dexuan.cui@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
-rw-r--r--common/recipes-multimedia/libva/libva_1.0.10.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/common/recipes-multimedia/libva/libva_1.0.10.bb b/common/recipes-multimedia/libva/libva_1.0.10.bb
new file mode 100644
index 00000000..0cd0444d
--- /dev/null
+++ b/common/recipes-multimedia/libva/libva_1.0.10.bb
@@ -0,0 +1,38 @@
1SUMMARY = "Video Acceleration (VA) API for Linux"
2DESCRIPTION = "Video Acceleration API (VA API) is a library (libVA) \
3and API specification which enables and provides access to graphics \
4hardware (GPU) acceleration for video processing on Linux and UNIX \
5based operating systems. Accelerated processing includes video \
6decoding, video encoding, subpicture blending and rendering. The \
7specification was originally designed by Intel for its GMA (Graphics \
8Media Accelerator) series of GPU hardware, the API is however not \
9limited to GPUs or Intel specific hardware, as other hardware and \
10manufacturers can also freely use this API for hardware accelerated \
11video decoding."
12
13HOMEPAGE = "http://www.freedesktop.org/wiki/Software/vaapi"
14BUGTRACKER = "https://bugs.freedesktop.org"
15
16SECTION = "x11"
17LICENSE = "MIT"
18LIC_FILES_CHKSUM = "file://COPYING;md5=2e48940f94acb0af582e5ef03537800f"
19
20PR = "r1"
21
22DEPENDS = "libxext libxfixes libdrm"
23
24SRC_URI = "http://cgit.freedesktop.org/libva/snapshot/libva-${PV}.tar.bz2"
25
26SRC_URI[md5sum] = "959de03d47654adab855e10bff614df3"
27SRC_URI[sha256sum] = "05f757f0043dce9f753d354d15e0cb772b1240cc9d29d26bbb5526285a203693"
28
29inherit autotools pkgconfig
30
31LEAD_SONAME = "libva.so"
32
33PACKAGES =+ "${PN}-x11 ${PN}-tpi ${PN}-glx ${PN}-egl"
34RDEPENDS_${PN} =+ "${PN}-x11 ${PN}-tpi ${PN}-glx ${PN}-egl"
35FILES_${PN}-x11 =+ "${libdir}/libva-x11.*"
36FILES_${PN}-tpi =+ "${libdir}/libva-tpi.*"
37FILES_${PN}-glx =+ "${libdir}/libva-glx.*"
38FILES_${PN}-egl =+ "${libdir}/libva-egl.*"