summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Zanussi <tom.zanussi@intel.com>2011-03-30 17:34:44 -0500
committerTom Zanussi <tom.zanussi@intel.com>2011-03-30 17:34:44 -0500
commit95fd3fd97769526f766fd1ec95c8235cb8e203d5 (patch)
tree8784466213241ab48b94cb126c912a2016e2db27
parent4e208833a999c5585043c12cc21fc481f462c236 (diff)
downloadmeta-intel-95fd3fd97769526f766fd1ec95c8235cb8e203d5.tar.gz
meta-fishriver: new layer for Fish River Island (Z530/EG20T) systems
This layer provides support for Z530 + EG20T Intel systems. Currently it supports only vesa graphics, which will be upgraded shortly. Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
-rw-r--r--meta-fishriver/COPYING.MIT17
-rw-r--r--meta-fishriver/README94
-rw-r--r--meta-fishriver/binary/.gitignore0
-rw-r--r--meta-fishriver/conf/layer.conf10
-rw-r--r--meta-fishriver/conf/machine/fishriver.conf46
-rw-r--r--meta-fishriver/recipes-bsp/formfactor/formfactor/fishriver/machconfig3
-rw-r--r--meta-fishriver/recipes-bsp/formfactor/formfactor_0.0.bbappend3
-rw-r--r--meta-fishriver/recipes-graphics/xorg-xserver/xserver-xf86-config/fishriver/xorg.conf26
-rw-r--r--meta-fishriver/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend3
-rw-r--r--meta-fishriver/recipes-kernel/linux/linux-yocto_git.bbappend4
10 files changed, 206 insertions, 0 deletions
diff --git a/meta-fishriver/COPYING.MIT b/meta-fishriver/COPYING.MIT
new file mode 100644
index 00000000..fb950dc6
--- /dev/null
+++ b/meta-fishriver/COPYING.MIT
@@ -0,0 +1,17 @@
1Permission is hereby granted, free of charge, to any person obtaining a copy
2of this software and associated documentation files (the "Software"), to deal
3in the Software without restriction, including without limitation the rights
4to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
5copies of the Software, and to permit persons to whom the Software is
6furnished to do so, subject to the following conditions:
7
8The above copyright notice and this permission notice shall be included in
9all copies or substantial portions of the Software.
10
11THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
12IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
13FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
14AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
15LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
16OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
17THE SOFTWARE.
diff --git a/meta-fishriver/README b/meta-fishriver/README
new file mode 100644
index 00000000..57b49264
--- /dev/null
+++ b/meta-fishriver/README
@@ -0,0 +1,94 @@
1This README file contains information on building the meta-fishriver
2BSP layer, and booting the images contained in the /binary directory.
3Please see the corresponding sections below for details.
4
5
6Table of Contents
7=================
8
9 I. Special notes on the meta-fishriver BSP layer
10 II. Building the meta-fishriver BSP layer
11III. Booting the images in /binary
12
13
14I. Special notes on the meta-fishriver BSP layer
15================================================
16
17The meta-fishriver layer currently and temporarily uses the crownbay
18kernel branch. This will change once we have new patches and/or
19config changes for:
20
21- Zigbee
22- wifi
23- upstream gma500
24- EMGD?
25
26
27II. Building the meta-fishriver BSP layer
28=========================================
29
30For each BSP in the 'meta-intel' repository, there are multiple
31branches, one corresponding to each major release starting with
32'laverne' (0.90), in addition to the latest code which tracks the
33current master.
34
35In order to build an image with BSP support for a given release, you
36need to check out the 'meta-intel' branch corresponding to the release
37you're building against e.g. to build for laverne (0.90), check out
38the 'laverne' branch of both poky and 'meta-intel'.
39
40Having done that, and assuming you cloned the 'meta-intel' repository
41at the top-level of your yocto build tree, you can build a fishriver
42image by adding the location of the meta-fishriver layer to
43bblayers.conf e.g.:
44
45 yocto/meta-intel/meta-fishriver \
46
47To enable the fishriver layer, add the fishriver MACHINE to local.conf:
48
49 MACHINE ?= "fishriver"
50
51You should then be able to build a fishriver image as such:
52
53 $ source poky-init-build-env
54 $ bitbake poky-image-sato-live
55
56At the end of a successful build, you should have a live image that
57you can boot from a USB flash drive (see instructions on how to do
58that below, in the section 'Booting the images from /binary').
59
60
61III. Booting the images in /binary
62==================================
63
64This BSP contains bootable live images, which can be used to directly
65boot Yocto off of a USB flash drive.
66
67Under Linux, insert a USB flash drive. Assuming the USB flash drive
68takes device /dev/sdf, use dd to copy the live image to it. For
69example:
70
71# dd if=poky-image-sato-live-fishriver-20101207053738.hddimg of=/dev/sdf
72# sync
73# eject /dev/sdf
74
75This should give you a bootable USB flash device. Insert the device
76into a bootable USB socket on the target, and power on. This should
77result in a system booted to the Sato graphical desktop.
78
79If you want a terminal, use the arrows at the top of the UI to move to
80different pages of available applications, one of which is named
81'Terminal'. Clicking that should give you a root terminal.
82
83If you want to ssh into the system, you can use the root terminal to
84ifconfig the IP address and use that to ssh in. The root password is
85empty, so to log in type 'root' for the user name and hit 'Enter' at
86the Password prompt: and you should be in.
87
88----
89
90If you find you're getting corrupt images on the USB (it doesn't show
91the syslinux boot: prompt, or the boot: prompt contains strange
92characters), try doing this first:
93
94# dd if=/dev/zero of=/dev/sdf bs=1M count=512
diff --git a/meta-fishriver/binary/.gitignore b/meta-fishriver/binary/.gitignore
new file mode 100644
index 00000000..e69de29b
--- /dev/null
+++ b/meta-fishriver/binary/.gitignore
diff --git a/meta-fishriver/conf/layer.conf b/meta-fishriver/conf/layer.conf
new file mode 100644
index 00000000..595bbe32
--- /dev/null
+++ b/meta-fishriver/conf/layer.conf
@@ -0,0 +1,10 @@
1# We have a conf and classes directory, add to BBPATH
2BBPATH := "${BBPATH}:${LAYERDIR}"
3
4# We have a recipes directory, add to BBFILES
5BBFILES := "${BBFILES} ${LAYERDIR}/recipes-*/*/*.bb \
6 ${LAYERDIR}/recipes-*/*/*.bbappend"
7
8BBFILE_COLLECTIONS_fishriver += "fishriver"
9BBFILE_PATTERN_fishriver := "^${LAYERDIR}/"
10BBFILE_PRIORITY_fishriver = "6"
diff --git a/meta-fishriver/conf/machine/fishriver.conf b/meta-fishriver/conf/machine/fishriver.conf
new file mode 100644
index 00000000..64c194b0
--- /dev/null
+++ b/meta-fishriver/conf/machine/fishriver.conf
@@ -0,0 +1,46 @@
1#@TYPE: Machine
2#@NAME: fishriver
3
4#@DESCRIPTION: Machine configuration for Fish River Island systems
5# i.e. Z530/E660 + EG20T
6
7TARGET_ARCH = "i586"
8PACKAGE_EXTRA_ARCHS = "x86 atom"
9
10include conf/machine/include/tune-atom.inc
11
12BASE_PACKAGE_ARCH="atom"
13
14MACHINE_FEATURES = "kernel26 screen keyboard pci usbhost ext2 ext3 x86 \
15 acpi serial usbgadget"
16
17KERNEL_IMAGETYPE = "bzImage"
18
19PREFERRED_PROVIDER_virtual/kernel = "linux-yocto"
20PREFERRED_PROVIDER_linux-libc-headers ?= "linux-libc-headers-yocto"
21PREFERRED_PROVIDER_virtual/libx11 ?= "libx11-trim"
22PREFERRED_PROVIDER_virtual/libgl ?= "mesa-dri"
23PREFERRED_PROVIDER_virtual/xserver ?= "xserver-xf86-dri-lite"
24PREFERRED_PROVIDER_virtual/xserver-xf86 ?= "xserver-xf86-dri-lite"
25XSERVER ?= "xserver-xf86-dri-lite \
26 xf86-input-mouse \
27 xf86-input-keyboard \
28 xf86-input-evdev \
29 xf86-input-synaptics \
30 xf86-video-vesa"
31
32SERIAL_CONSOLE = "115200 ttyS0"
33
34MACHINE_EXTRA_RRECOMMENDS = "kernel-modules eee-acpi-scripts"
35
36GUI_MACHINE_CLASS = "bigscreen"
37
38IMAGE_ROOTFS_SIZE_ext3 = "1000000"
39
40IMAGE_FSTYPES ?= "ext3 cpio.gz"
41
42GLIBC_ADDONS = "nptl"
43GLIBC_EXTRA_OECONF = "--with-tls"
44
45SRCREV_machine_pn-linux-yocto_fishriver ?= "86bd1278bbf11589d87639df17d2f5f42db97b60"
46SRCREV_meta_pn-linux-yocto_fishriver ?= "51c761795b078bf3c80104ed6e73b3d995067384"
diff --git a/meta-fishriver/recipes-bsp/formfactor/formfactor/fishriver/machconfig b/meta-fishriver/recipes-bsp/formfactor/formfactor/fishriver/machconfig
new file mode 100644
index 00000000..ffce0122
--- /dev/null
+++ b/meta-fishriver/recipes-bsp/formfactor/formfactor/fishriver/machconfig
@@ -0,0 +1,3 @@
1# Assume a USB mouse and keyboard are connected
2HAVE_TOUCHSCREEN=0
3HAVE_KEYBOARD=1
diff --git a/meta-fishriver/recipes-bsp/formfactor/formfactor_0.0.bbappend b/meta-fishriver/recipes-bsp/formfactor/formfactor_0.0.bbappend
new file mode 100644
index 00000000..4a41d487
--- /dev/null
+++ b/meta-fishriver/recipes-bsp/formfactor/formfactor_0.0.bbappend
@@ -0,0 +1,3 @@
1FILESEXTRAPATHS := "${THISDIR}/${PN}"
2
3PRINC = "1"
diff --git a/meta-fishriver/recipes-graphics/xorg-xserver/xserver-xf86-config/fishriver/xorg.conf b/meta-fishriver/recipes-graphics/xorg-xserver/xserver-xf86-config/fishriver/xorg.conf
new file mode 100644
index 00000000..da4fc3c6
--- /dev/null
+++ b/meta-fishriver/recipes-graphics/xorg-xserver/xserver-xf86-config/fishriver/xorg.conf
@@ -0,0 +1,26 @@
1Section "Device"
2 Identifier "Generic VESA"
3 Driver "vesa"
4EndSection
5
6Section "Monitor"
7 Identifier "Generic Monitor"
8 Option "DPMS"
9EndSection
10
11Section "Screen"
12 Identifier "Default Screen"
13 Device "Generic VESA"
14 Monitor "Generic Monitor"
15 DefaultDepth 24
16EndSection
17
18Section "ServerLayout"
19 Identifier "Default Layout"
20 Screen "Default Screen"
21EndSection
22
23Section "ServerFlags"
24 Option "DontZap" "0"
25 Option "AutoAddDevices" "False"
26EndSection
diff --git a/meta-fishriver/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend b/meta-fishriver/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend
new file mode 100644
index 00000000..4b8d0e65
--- /dev/null
+++ b/meta-fishriver/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend
@@ -0,0 +1,3 @@
1THISDIR := "${@os.path.dirname(bb.data.getVar('FILE', d, True))}"
2FILESPATH =. "${@base_set_filespath(["${THISDIR}/${PN}"], d)}:"
3
diff --git a/meta-fishriver/recipes-kernel/linux/linux-yocto_git.bbappend b/meta-fishriver/recipes-kernel/linux/linux-yocto_git.bbappend
new file mode 100644
index 00000000..549d0857
--- /dev/null
+++ b/meta-fishriver/recipes-kernel/linux/linux-yocto_git.bbappend
@@ -0,0 +1,4 @@
1FILESEXTRAPATHS := "${THISDIR}/${PN}"
2COMPATIBLE_MACHINE_fishriver = "fishriver"
3# zzzz /yocto/standard/crownbay->fishriver
4KMACHINE_fishriver = "yocto/standard/crownbay"