summaryrefslogtreecommitdiffstats
path: root/meta-qat/conf/layer.conf
diff options
context:
space:
mode:
Diffstat (limited to 'meta-qat/conf/layer.conf')
-rw-r--r--meta-qat/conf/layer.conf20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-qat/conf/layer.conf b/meta-qat/conf/layer.conf
new file mode 100644
index 0000000..2e3aa84
--- /dev/null
+++ b/meta-qat/conf/layer.conf
@@ -0,0 +1,20 @@
1# We have a conf and classes directory, add to BBPATH
2BBPATH .= ":${LAYERDIR}"
3
4# We have recipes-* directories, add to BBFILES
5BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
6 ${LAYERDIR}/recipes-*/*/*.bbappend"
7
8BBFILE_COLLECTIONS += "intel-qat"
9BBFILE_PATTERN_intel-qat := "^${LAYERDIR}/"
10BBFILE_PRIORITY_intel-qat = "5"
11
12LAYERDEPENDS_intel-qat = "core intel"
13
14# This should only be incremented on significant changes that will
15# cause compatibility issues with other layers
16LAYERVERSION_intel-qat = "1"
17LAYERSERIES_COMPAT_intel-qat = "rocko"
18
19
20require ${LAYERDIR}/conf/include/maintainers.inc