summaryrefslogtreecommitdiffstats
path: root/conf/layer.conf
diff options
context:
space:
mode:
Diffstat (limited to 'conf/layer.conf')
-rw-r--r--conf/layer.conf24
1 files changed, 24 insertions, 0 deletions
diff --git a/conf/layer.conf b/conf/layer.conf
new file mode 100644
index 0000000..53f831e
--- /dev/null
+++ b/conf/layer.conf
@@ -0,0 +1,24 @@
1# We have a conf and classes directory, add to BBPATH
2BBPATH .= ":${LAYERDIR}:${LAYERDIR}/common"
3
4# We have recipes-* directories, add to BBFILES
5BBFILES += "${LAYERDIR}/common/recipes-*/*/*.bb \
6 ${LAYERDIR}/common/recipes-*/*/*.bbappend"
7
8BBFILE_COLLECTIONS += "intel"
9BBFILE_PATTERN_intel := "^${LAYERDIR}/common/"
10BBFILE_PRIORITY_intel = "5"
11
12# Additional license directories.
13LICENSE_PATH += "${LAYERDIR}/common/custom-licenses"
14
15LAYERDEPENDS_intel = "core"
16LAYERRECOMMENDS_intel = "dpdk intel-qat"
17
18# This should only be incremented on significant changes that will
19# cause compatibility issues with other layers
20LAYERVERSION_intel = "4"
21LAYERSERIES_COMPAT_intel = "rocko"
22
23
24require ${LAYERDIR}/conf/include/maintainers.inc