summaryrefslogtreecommitdiffstats
path: root/recipes-support/32b-env/32b-env_1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-support/32b-env/32b-env_1.0.bb')
-rw-r--r--recipes-support/32b-env/32b-env_1.0.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes-support/32b-env/32b-env_1.0.bb b/recipes-support/32b-env/32b-env_1.0.bb
new file mode 100644
index 0000000..44142d5
--- /dev/null
+++ b/recipes-support/32b-env/32b-env_1.0.bb
@@ -0,0 +1,23 @@
1SUMMARY = "A simple set of shell scripts used for enabling support for \
2dynamic linked 32b application on hierofalcon boards."
3DESCRIPTION = "The 32b-env package installs the set_32b_env_chroot.sh \
4and set_32b_env_qemu.sh shell scripts which enables support for dynamic \
5linked 32b application on hierofalcon boards until the multilib support \
6will be available for armv8 architecture."
7
8SRC_URI = "file://set_32b_env_chroot.sh \
9 file://set_32b_env_qemu.sh"
10
11LICENSE = "MIT"
12LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690"
13
14do_install () {
15 install -d ${D}${bindir}/
16 install -m 755 ${WORKDIR}/set_32b_env_chroot.sh ${D}${bindir}/
17 install -m 755 ${WORKDIR}/set_32b_env_qemu.sh ${D}${bindir}/
18}
19
20do_patch[noexec] = "1"
21do_configure[noexec] = "1"
22do_compile[noexec] = "1"
23do_build[noexec] = "1"