summaryrefslogtreecommitdiffstats
path: root/conf
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:42:49 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:42:49 +0200
commit635d320abfa6dc3c0e1d00e3ceae567dd0e55a5b (patch)
treedcd42fafb9189d3be13ef3d95f9ce6f4f5cfa267 /conf
downloadmeta-hierofalcon-635d320abfa6dc3c0e1d00e3ceae567dd0e55a5b.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'conf')
-rw-r--r--conf/layer.conf12
-rw-r--r--conf/machine/hierofalcon-be.conf6
-rw-r--r--conf/machine/hierofalcon.conf5
-rw-r--r--conf/machine/hierofalcon.inc22
4 files changed, 45 insertions, 0 deletions
diff --git a/conf/layer.conf b/conf/layer.conf
new file mode 100644
index 0000000..f945f53
--- /dev/null
+++ b/conf/layer.conf
@@ -0,0 +1,12 @@
1# We have a packages directory, add to BBFILES
2BBPATH .= ":${LAYERDIR}"
3
4BBFILES += "${LAYERDIR}/recipes-*/*/*.bb*"
5BBFILES += "${LAYERDIR}/images/*.bb*"
6
7BBFILE_COLLECTIONS += "hierofalcon"
8BBFILE_PATTERN_hierofalcon := "^${LAYERDIR}/"
9BBFILE_PRIORITY_hierofalcon = "6"
10
11BB_ENV_EXTRAWHITE := "KSRC USRC"
12BB_DANGLINGAPPENDS_WARNONLY = "yes"
diff --git a/conf/machine/hierofalcon-be.conf b/conf/machine/hierofalcon-be.conf
new file mode 100644
index 0000000..bbb9c93
--- /dev/null
+++ b/conf/machine/hierofalcon-be.conf
@@ -0,0 +1,6 @@
1DEFAULTTUNE ?= "aarch64_be"
2TRANSLATED_TARGET_ARCH = "aarch64-be"
3
4require conf/machine/hierofalcon.inc
5
6PREFERRED_VERSION_linux-hierofalcon = "3.19%"
diff --git a/conf/machine/hierofalcon.conf b/conf/machine/hierofalcon.conf
new file mode 100644
index 0000000..5adc66b
--- /dev/null
+++ b/conf/machine/hierofalcon.conf
@@ -0,0 +1,5 @@
1DEFAULTTUNE ?= "aarch64"
2
3require conf/machine/hierofalcon.inc
4
5PREFERRED_VERSION_linux-hierofalcon = "4.1%"
diff --git a/conf/machine/hierofalcon.inc b/conf/machine/hierofalcon.inc
new file mode 100644
index 0000000..9f7e23e
--- /dev/null
+++ b/conf/machine/hierofalcon.inc
@@ -0,0 +1,22 @@
1#@TYPE: Machine
2#@NAME: AMD Hierofalcon
3#@DESCRIPTION: Cortex-A57
4
5require conf/machine/include/arm64/arch-armv8.inc
6
7PREFERRED_PROVIDER_virtual/kernel ?= "linux-hierofalcon"
8
9MACHINE_FEATURES = "pci ext2 ext3 serial"
10
11RDEPENDS_kernel-base = "kernel-image"
12
13KERNEL_IMAGETYPE = "Image"
14
15SERIAL_CONSOLES = "115200;ttyAMA0"
16
17IMAGE_FSTYPES += "ext2.gz tar.gz"
18
19# we do not want to have getty running since we do not have a
20# graphical display attached and therefore do not need virtual
21# terminal functionality
22USE_VT = "0"