summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSona Sarmadi <sona.sarmadi@enea.com>2016-01-05 13:27:22 +0100
committerTudor Florea <tudor.florea@enea.com>2016-01-05 14:53:15 +0100
commita7516bc90a45e8f16f9a83e0abbb420447150984 (patch)
tree197f8bdd83fde1b83baea5cb23cba3c60b970f6f
parenta63ce710f8d26ad6732602a743ff346a656efb27 (diff)
downloadmeta-hierofalcon-a7516bc90a45e8f16f9a83e0abbb420447150984.tar.gz
kernel-ipv4: CVE-2015-3636
Fixes a use-after-free bug which can lead to kernel arbitrary execution in Linux kernel. References: https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2015-3636 http://www.openwall.com/lists/oss-security/2015/05/02/5 Upstream fix: https://git.kernel.org/cgit/linux/kernel/git/stable/linux-stable.git/ patch/?id=e13f6f2b39c4d91371c0ede88b136f364a6ffd6d Signed-off-by: Sona Sarmadi <sona.sarmadi@enea.com> Signed-off-by: Tudor Florea <tudor.florea@enea.com>
-rw-r--r--recipes-kernel/linux/linux-hierofalcon-3.19/ipv4-CVE-2015-3636.patch39
-rw-r--r--recipes-kernel/linux/linux-hierofalcon_3.19.bb1
2 files changed, 40 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-hierofalcon-3.19/ipv4-CVE-2015-3636.patch b/recipes-kernel/linux/linux-hierofalcon-3.19/ipv4-CVE-2015-3636.patch
new file mode 100644
index 0000000..1d50153
--- /dev/null
+++ b/recipes-kernel/linux/linux-hierofalcon-3.19/ipv4-CVE-2015-3636.patch
@@ -0,0 +1,39 @@
1From e13f6f2b39c4d91371c0ede88b136f364a6ffd6d Mon Sep 17 00:00:00 2001
2From: "David S. Miller" <davem@davemloft.net>
3Date: Fri, 1 May 2015 22:02:47 -0400
4Subject: ipv4: Missing sk_nulls_node_init() in ping_unhash().
5
6[ Upstream commit a134f083e79fb4c3d0a925691e732c56911b4326 ]
7
8If we don't do that, then the poison value is left in the ->pprev
9backlink.
10
11This can cause crashes if we do a disconnect, followed by a connect().
12
13Fixes CVE-2015-3636.
14Upstream-Status: Backport
15
16Tested-by: Linus Torvalds <torvalds@linux-foundation.org>
17Reported-by: Wen Xu <hotdog3645@gmail.com>
18Signed-off-by: David S. Miller <davem@davemloft.net>
19Signed-off-by: Sasha Levin <sasha.levin@oracle.com>
20Signed-off-by: Sona Sarmadi <sona.sarmadi@enea.com>
21---
22 net/ipv4/ping.c | 1 +
23 1 file changed, 1 insertion(+)
24
25diff --git a/net/ipv4/ping.c b/net/ipv4/ping.c
26index a5c49d6..64f4edb 100644
27--- a/net/ipv4/ping.c
28+++ b/net/ipv4/ping.c
29@@ -158,6 +158,7 @@ void ping_unhash(struct sock *sk)
30 if (sk_hashed(sk)) {
31 write_lock_bh(&ping_table.lock);
32 hlist_nulls_del(&sk->sk_nulls_node);
33+ sk_nulls_node_init(&sk->sk_nulls_node);
34 sock_put(sk);
35 isk->inet_num = 0;
36 isk->inet_sport = 0;
37--
38cgit v0.11.2
39
diff --git a/recipes-kernel/linux/linux-hierofalcon_3.19.bb b/recipes-kernel/linux/linux-hierofalcon_3.19.bb
index 82ad305..895a08c 100644
--- a/recipes-kernel/linux/linux-hierofalcon_3.19.bb
+++ b/recipes-kernel/linux/linux-hierofalcon_3.19.bb
@@ -26,6 +26,7 @@ SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.19;branch="standard/qemuarm6
26 file://md-CVE-2015-5697.patch \ 26 file://md-CVE-2015-5697.patch \
27 file://vhost-CVE-2015-6252.patch \ 27 file://vhost-CVE-2015-6252.patch \
28 file://ipv6-CVE-2015-2922.patch \ 28 file://ipv6-CVE-2015-2922.patch \
29 file://ipv4-CVE-2015-3636.patch \
29 " 30 "
30 31
31S = "${WORKDIR}/git" 32S = "${WORKDIR}/git"