diff options
Diffstat (limited to 'recipes-support')
-rw-r--r-- | recipes-support/gnupg/gnupg-1.4.7/fix-ustar-check-issue.patch | 38 | ||||
-rw-r--r-- | recipes-support/gnupg/gnupg_1.4.7.bb | 10 |
2 files changed, 44 insertions, 4 deletions
diff --git a/recipes-support/gnupg/gnupg-1.4.7/fix-ustar-check-issue.patch b/recipes-support/gnupg/gnupg-1.4.7/fix-ustar-check-issue.patch new file mode 100644 index 0000000..eb4cc9f --- /dev/null +++ b/recipes-support/gnupg/gnupg-1.4.7/fix-ustar-check-issue.patch | |||
@@ -0,0 +1,38 @@ | |||
1 | Remove the code for ustar format detection because it is not applicable | ||
2 | for cross-complie platform. | ||
3 | |||
4 | Upstream Status: Inappropriate [embedded specific] | ||
5 | |||
6 | Signed-off-by: Wenlin Kang <wenlin.kang@windriver.com> | ||
7 | Signed-off-by: Yi Zhao <yi.zhao@windriver.com> | ||
8 | --- | ||
9 | m4/tar-ustar.m4 | 13 +++++++++---- | ||
10 | 1 file changed, 9 insertions(+), 4 deletions(-) | ||
11 | |||
12 | diff --git a/m4/tar-ustar.m4 b/m4/tar-ustar.m4 | ||
13 | index 4ae9e63..f6e57c2 100644 | ||
14 | --- a/m4/tar-ustar.m4 | ||
15 | +++ b/m4/tar-ustar.m4 | ||
16 | @@ -26,10 +26,15 @@ AC_DEFUN([GNUPG_CHECK_USTAR], | ||
17 | |||
18 | if test x$_mytar != x ; then | ||
19 | AC_MSG_CHECKING([whether $_mytar speaks USTAR]) | ||
20 | - echo hithere > conftest.txt | ||
21 | - $_mytar -cf - conftest.txt | (dd skip=257 bs=1 count=5 2>/dev/null || cat) | grep ustar > /dev/null | ||
22 | - _tar_bad=$? | ||
23 | - rm conftest.txt | ||
24 | + | ||
25 | + # Here, we ignore the check code, because it isn't indeed applicable for | ||
26 | + # cross-compile platform. | ||
27 | + # Now our tar support ustar, so we say directly yes, but once the tar is changed, | ||
28 | + # you should check whether it suppport ustar, and please reference the follow command: | ||
29 | + # echo hithere > conftest.txt | ||
30 | + # tar -cf - conftest.txt | (dd skip=257 bs=1 count=5 2>/dev/null || cat) | grep ustar > /dev/null | ||
31 | + | ||
32 | + _tar_bad=0 | ||
33 | |||
34 | if test x$_tar_bad = x0 ; then | ||
35 | AC_MSG_RESULT([yes]) | ||
36 | -- | ||
37 | 1.9.1 | ||
38 | |||
diff --git a/recipes-support/gnupg/gnupg_1.4.7.bb b/recipes-support/gnupg/gnupg_1.4.7.bb index 6ccffd5..85636ab 100644 --- a/recipes-support/gnupg/gnupg_1.4.7.bb +++ b/recipes-support/gnupg/gnupg_1.4.7.bb | |||
@@ -18,6 +18,7 @@ SRC_URI = "${GNUPG_MIRROR}/gnupg/gnupg-${PV}.tar.bz2 \ | |||
18 | file://CVE-2013-4351.patch \ | 18 | file://CVE-2013-4351.patch \ |
19 | file://CVE-2013-4576.patch \ | 19 | file://CVE-2013-4576.patch \ |
20 | file://CVE-2013-4242.patch \ | 20 | file://CVE-2013-4242.patch \ |
21 | file://fix-ustar-check-issue.patch \ | ||
21 | " | 22 | " |
22 | 23 | ||
23 | SRC_URI[md5sum] = "b06a141cca5cd1a55bbdd25ab833303c" | 24 | SRC_URI[md5sum] = "b06a141cca5cd1a55bbdd25ab833303c" |
@@ -74,12 +75,13 @@ inherit autotools gettext texinfo | |||
74 | # --disable-regex do not handle regular expressions in trust sigs | 75 | # --disable-regex do not handle regular expressions in trust sigs |
75 | 76 | ||
76 | EXTRA_OECONF = "--disable-ldap \ | 77 | EXTRA_OECONF = "--disable-ldap \ |
77 | --with-zlib=${STAGING_LIBDIR}/.. \ | 78 | --with-zlib=${STAGING_LIBDIR}/.. \ |
78 | --with-bzip2=${STAGING_LIBDIR}/.. \ | 79 | --with-bzip2=${STAGING_LIBDIR}/.. \ |
79 | --disable-selinux-support \ | 80 | --disable-selinux-support \ |
80 | --with-readline=${STAGING_LIBDIR}/.. \ | 81 | --with-readline=${STAGING_LIBDIR}/.. \ |
81 | ac_cv_sys_symbol_underscore=no \ | 82 | ac_cv_sys_symbol_underscore=no \ |
82 | " | 83 | ac_cv_path_TAR=${base_bindir}/tar \ |
84 | " | ||
83 | 85 | ||
84 | # Force gcc's traditional handling of inline to avoid issues with gcc 5 | 86 | # Force gcc's traditional handling of inline to avoid issues with gcc 5 |
85 | CFLAGS += "-fgnu89-inline" | 87 | CFLAGS += "-fgnu89-inline" |