summaryrefslogtreecommitdiffstats
path: root/recipes-support/shared-mime-info/shared-mime-info
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-support/shared-mime-info/shared-mime-info')
-rw-r--r--recipes-support/shared-mime-info/shared-mime-info/install-data-hook.patch25
-rw-r--r--recipes-support/shared-mime-info/shared-mime-info/parallelmake.patch33
2 files changed, 58 insertions, 0 deletions
diff --git a/recipes-support/shared-mime-info/shared-mime-info/install-data-hook.patch b/recipes-support/shared-mime-info/shared-mime-info/install-data-hook.patch
new file mode 100644
index 0000000..262ff75
--- /dev/null
+++ b/recipes-support/shared-mime-info/shared-mime-info/install-data-hook.patch
@@ -0,0 +1,25 @@
1fix shared-mime-info build race condition
2
3The definition of install-data-hook in Makefile.am leads
4to multiple, overlapping, executions of install-binPROGRAMS
5target. We modify the definition to avoid that.
6
7Upstream-Status: Pending
8
9Signed-off-by: Joe Slater <jslater@windriver.com>
10
11Index: shared-mime-info-1.9/Makefile.am
12===================================================================
13--- shared-mime-info-1.9.orig/Makefile.am
14+++ shared-mime-info-1.9/Makefile.am
15@@ -50,7 +50,9 @@ else
16 update_mime_database="$(top_builddir)/update-mime-database$(EXEEXT)"
17 endif
18
19-install-data-hook: install-binPROGRAMS
20+# do NOT make this dependent on anything!
21+#
22+install-data-hook:
23 if ENABLE_UPDATE_MIMEDB
24 $(update_mime_database) -V "$(DESTDIR)$(datadir)/mime"
25 endif
diff --git a/recipes-support/shared-mime-info/shared-mime-info/parallelmake.patch b/recipes-support/shared-mime-info/shared-mime-info/parallelmake.patch
new file mode 100644
index 0000000..fea34a5
--- /dev/null
+++ b/recipes-support/shared-mime-info/shared-mime-info/parallelmake.patch
@@ -0,0 +1,33 @@
1The Makefile used by shared-mime-info is one big race with the SUBDIRS
2option and the dependency specifically calling make all combining to
3create multiple make instances all of which may try and build targets
4like update-mime-database.
5
6This patch removes those options meaning make can correctly identify
7dependencies and stop itself racing itself.
8
9RP 10/10/2011
10
11Upstream-Status: Pending
12Signed-off-by: Constantin Musca <constantinx.musca@intel.com>
13
14Index: shared-mime-info-1.9/Makefile.am
15===================================================================
16--- shared-mime-info-1.9.orig/Makefile.am
17+++ shared-mime-info-1.9/Makefile.am
18@@ -1,5 +1,3 @@
19-SUBDIRS=. po
20-
21 AM_CPPFLAGS = $(ALL_CFLAGS)
22
23 packagesdir = $(datadir)/mime/packages
24@@ -81,8 +79,7 @@ endif
25
26 all: $(defaultmakedeps)
27
28-create-pot:
29- $(AM_V_GEN) $(MAKE) -C po shared-mime-info.pot
30+create-pot: po
31
32 local-test: create-pot freedesktop.org.xml update-mime-database$(EXEEXT)
33 if CROSS_COMPILING