summaryrefslogtreecommitdiffstats
path: root/recipes-support/nettle/nettle-2.7.1
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-support/nettle/nettle-2.7.1')
-rw-r--r--recipes-support/nettle/nettle-2.7.1/CVE-2015-8803_8805.patch59
-rw-r--r--recipes-support/nettle/nettle-2.7.1/CVE-2015-8804.patch26
-rw-r--r--recipes-support/nettle/nettle-2.7.1/check-header-files-of-openssl-only-if-enable_.patch6
3 files changed, 55 insertions, 36 deletions
diff --git a/recipes-support/nettle/nettle-2.7.1/CVE-2015-8803_8805.patch b/recipes-support/nettle/nettle-2.7.1/CVE-2015-8803_8805.patch
index a956f42..988f39e 100644
--- a/recipes-support/nettle/nettle-2.7.1/CVE-2015-8803_8805.patch
+++ b/recipes-support/nettle/nettle-2.7.1/CVE-2015-8803_8805.patch
@@ -1,3 +1,8 @@
1From f21b9f7b21067fa3630607cdc1663141b2735ae5 Mon Sep 17 00:00:00 2001
2From: Armin Kuster <akuster@mvista.com>
3Date: Thu, 2 Mar 2017 12:24:31 +0000
4Subject: [PATCH] Create meta-gplv2 from files from OE-Core
5
1Upstream-Status: Backport 6Upstream-Status: Backport
2https://git.lysator.liu.se/nettle/nettle/commit/c71d2c9d20eeebb985e3872e4550137209e3ce4d 7https://git.lysator.liu.se/nettle/nettle/commit/c71d2c9d20eeebb985e3872e4550137209e3ce4d
3 8
@@ -8,14 +13,36 @@ Same fix for both.
8 13
9Signed-off-by: Armin Kuster <akuster@mvista.com> 14Signed-off-by: Armin Kuster <akuster@mvista.com>
10 15
11Index: nettle-2.7.1/ecc-256.c 16---
12=================================================================== 17 ChangeLog | 6 ++++++
13--- nettle-2.7.1.orig/ecc-256.c 18 ecc-256.c | 23 ++++++++++++++++++-----
14+++ nettle-2.7.1/ecc-256.c 19 2 files changed, 24 insertions(+), 5 deletions(-)
15@@ -96,9 +96,19 @@ ecc_256_modp (const struct ecc_curve *ec 20
21diff --git a/ChangeLog b/ChangeLog
22index 7b7854d..abdd974 100644
23--- a/ChangeLog
24+++ b/ChangeLog
25@@ -1,3 +1,9 @@
26+2015-12-10 Niels Möller <nisse@lysator.liu.se>
27+
28+ * ecc-256.c (ecc_256_modp): Fixed carry propagation bug. Problem
29+ reported by Hanno Böck.
30+ (ecc_256_modq): Fixed another carry propagation bug.
31+
32 2013-05-28 Niels Möller <nisse@lysator.liu.se>
33
34 * Released nettle-2.7.1.
35diff --git a/ecc-256.c b/ecc-256.c
36index 571cf73..7bee4c7 100644
37--- a/ecc-256.c
38+++ b/ecc-256.c
39@@ -96,9 +96,19 @@ ecc_256_modp (const struct ecc_curve *ecc, mp_limb_t *rp)
16 q2 += t + (q1 < t); 40 q2 += t + (q1 < t);
17 41
18 assert (q2 < 2); 42 assert (q2 < 2);
43-
44- /* We multiply by two low limbs of p, 2^96 - 1, so we could use
45- shifts rather than mul. */
19+ /* 46+ /*
20+ n-1 n-2 n-3 n-4 47+ n-1 n-2 n-3 n-4
21+ +---+---+---+---+ 48+ +---+---+---+---+
@@ -25,16 +52,14 @@ Index: nettle-2.7.1/ecc-256.c
25+ +-------+---+ 52+ +-------+---+
26+ |q2(2^.)| 53+ |q2(2^.)|
27+ +-------+ 54+ +-------+
28 55+
29- /* We multiply by two low limbs of p, 2^96 - 1, so we could use
30- shifts rather than mul. */
31+ We multiply by two low limbs of p, 2^96 - 1, so we could use 56+ We multiply by two low limbs of p, 2^96 - 1, so we could use
32+ shifts rather than mul. 57+ shifts rather than mul.
33+ */ 58+ */
34 t = mpn_submul_1 (rp + n - 4, ecc->p, 2, q1); 59 t = mpn_submul_1 (rp + n - 4, ecc->p, 2, q1);
35 t += cnd_sub_n (q2, rp + n - 3, ecc->p, 1); 60 t += cnd_sub_n (q2, rp + n - 3, ecc->p, 1);
36 t += (-q2) & 0xffffffff; 61 t += (-q2) & 0xffffffff;
37@@ -108,7 +118,10 @@ ecc_256_modp (const struct ecc_curve *ec 62@@ -108,7 +118,10 @@ ecc_256_modp (const struct ecc_curve *ecc, mp_limb_t *rp)
38 u0 -= t; 63 u0 -= t;
39 t = (u1 < cy); 64 t = (u1 < cy);
40 u1 -= cy; 65 u1 -= cy;
@@ -46,7 +71,7 @@ Index: nettle-2.7.1/ecc-256.c
46 u1 -= (-t) & 0xffffffff; 71 u1 -= (-t) & 0xffffffff;
47 } 72 }
48 rp[2] = u0; 73 rp[2] = u0;
49@@ -195,7 +208,7 @@ ecc_256_modq (const struct ecc_curve *ec 74@@ -195,7 +208,7 @@ ecc_256_modq (const struct ecc_curve *ecc, mp_limb_t *rp)
50 75
51 /* Conditional add of p */ 76 /* Conditional add of p */
52 u1 += t; 77 u1 += t;
@@ -55,17 +80,3 @@ Index: nettle-2.7.1/ecc-256.c
55 80
56 t = cnd_add_n (t, rp + n - 4, ecc->q, 2); 81 t = cnd_add_n (t, rp + n - 4, ecc->q, 2);
57 u1 += t; 82 u1 += t;
58Index: nettle-2.7.1/ChangeLog
59===================================================================
60--- nettle-2.7.1.orig/ChangeLog
61+++ nettle-2.7.1/ChangeLog
62@@ -1,3 +1,9 @@
63+2015-12-10 Niels Möller <nisse@lysator.liu.se>
64+
65+ * ecc-256.c (ecc_256_modp): Fixed carry propagation bug. Problem
66+ reported by Hanno Böck.
67+ (ecc_256_modq): Fixed another carry propagation bug.
68+
69 2013-05-28 Niels Möller <nisse@lysator.liu.se>
70
71 * Released nettle-2.7.1.
diff --git a/recipes-support/nettle/nettle-2.7.1/CVE-2015-8804.patch b/recipes-support/nettle/nettle-2.7.1/CVE-2015-8804.patch
index 73723a9..f6906fd 100644
--- a/recipes-support/nettle/nettle-2.7.1/CVE-2015-8804.patch
+++ b/recipes-support/nettle/nettle-2.7.1/CVE-2015-8804.patch
@@ -1,13 +1,23 @@
1From 8cbd1d71caf56d45c54b1d8d073b330c07c66d12 Mon Sep 17 00:00:00 2001
2From: Armin Kuster <akuster@mvista.com>
3Date: Thu, 2 Mar 2017 12:24:31 +0000
4Subject: [PATCH] Create meta-gplv2 from files from OE-Core
5
1Upstream-Status: Backport 6Upstream-Status: Backport
2 https://git.lysator.liu.se/nettle/nettle/commit/fa269b6ad06dd13c901dbd84a12e52b918a09cd7 7 https://git.lysator.liu.se/nettle/nettle/commit/fa269b6ad06dd13c901dbd84a12e52b918a09cd7
3 8
4CVE: CVE-2015-8804 9CVE: CVE-2015-8804
5Signed-off-by: Armin Kuster <akuster@mvista.com> 10Signed-off-by: Armin Kuster <akuster@mvista.com>
6 11
7Index: nettle-2.7.1/ChangeLog 12---
8=================================================================== 13 ChangeLog | 8 +++
9--- nettle-2.7.1.orig/ChangeLog 14 x86_64/ecc-384-modp.asm | 169 +++++++++++++++++++++---------------------------
10+++ nettle-2.7.1/ChangeLog 15 2 files changed, 83 insertions(+), 94 deletions(-)
16
17diff --git a/ChangeLog b/ChangeLog
18index abdd974..c81168b 100644
19--- a/ChangeLog
20+++ b/ChangeLog
11@@ -1,3 +1,11 @@ 21@@ -1,3 +1,11 @@
12+2015-12-15 Niels Möller <nisse@lysator.liu.se> 22+2015-12-15 Niels Möller <nisse@lysator.liu.se>
13+ 23+
@@ -20,10 +30,10 @@ Index: nettle-2.7.1/ChangeLog
20 2015-12-10 Niels Möller <nisse@lysator.liu.se> 30 2015-12-10 Niels Möller <nisse@lysator.liu.se>
21 31
22 * ecc-256.c (ecc_256_modp): Fixed carry propagation bug. Problem 32 * ecc-256.c (ecc_256_modp): Fixed carry propagation bug. Problem
23Index: nettle-2.7.1/x86_64/ecc-384-modp.asm 33diff --git a/x86_64/ecc-384-modp.asm b/x86_64/ecc-384-modp.asm
24=================================================================== 34index 698838f..31b739e 100644
25--- nettle-2.7.1.orig/x86_64/ecc-384-modp.asm 35--- a/x86_64/ecc-384-modp.asm
26+++ nettle-2.7.1/x86_64/ecc-384-modp.asm 36+++ b/x86_64/ecc-384-modp.asm
27@@ -20,7 +20,7 @@ C MA 02111-1301, USA. 37@@ -20,7 +20,7 @@ C MA 02111-1301, USA.
28 .file "ecc-384-modp.asm" 38 .file "ecc-384-modp.asm"
29 39
diff --git a/recipes-support/nettle/nettle-2.7.1/check-header-files-of-openssl-only-if-enable_.patch b/recipes-support/nettle/nettle-2.7.1/check-header-files-of-openssl-only-if-enable_.patch
index 38d9107..d72165a 100644
--- a/recipes-support/nettle/nettle-2.7.1/check-header-files-of-openssl-only-if-enable_.patch
+++ b/recipes-support/nettle/nettle-2.7.1/check-header-files-of-openssl-only-if-enable_.patch
@@ -1,4 +1,4 @@
1From c369dd7049f5a198f8b6c96fde6e294ce5146c2f Mon Sep 17 00:00:00 2001 1From 95c6efc308c314f0cfe874d6a26cd1f59089adf6 Mon Sep 17 00:00:00 2001
2From: Haiqing Bai <Haiqing.Bai@windriver.com> 2From: Haiqing Bai <Haiqing.Bai@windriver.com>
3Date: Fri, 9 Dec 2016 16:16:45 +0800 3Date: Fri, 9 Dec 2016 16:16:45 +0800
4Subject: [PATCH] nettle: check header files of openssl only if 4Subject: [PATCH] nettle: check header files of openssl only if
@@ -10,6 +10,7 @@ building for nettle.
10 10
11Upstream-Status: Pending 11Upstream-Status: Pending
12Signed-off-by: Haiqing Bai <Haiqing.Bai@windriver.com> 12Signed-off-by: Haiqing Bai <Haiqing.Bai@windriver.com>
13
13--- 14---
14 configure.ac | 8 +++++--- 15 configure.ac | 8 +++++---
15 1 file changed, 5 insertions(+), 3 deletions(-) 16 1 file changed, 5 insertions(+), 3 deletions(-)
@@ -33,6 +34,3 @@ index 78a3d4e..4f16a98 100644
33 34
34 LSH_FUNC_ALLOCA 35 LSH_FUNC_ALLOCA
35 LSH_FUNC_STRERROR 36 LSH_FUNC_STRERROR
36--
371.9.1
38